Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > ISIS and EIGRP mutual redistribution --Help!

Reply
Thread Tools

ISIS and EIGRP mutual redistribution --Help!

 
 
phillip
Guest
Posts: n/a
 
      12-20-2004
This does not work-->

interface Serial0
description connection to router3 EIGRP net
ip address 192.168.1.1 255.255.255.0

!
interface Serial1
description connection to router2 ISIS net
ip address 10.1.1.1 255.255.255.0
ip router isis
!

router eigrp 1
redistribute isis level-1 metric 64 100 255 1 1500
network 192.168.1.0
no auto-summary

!
router isis
redistribute eigrp 1 metric 10 metric-type external level-1
net 02.0010.7b36.027e.00


This does, why?--->

Here is what I had to do to get ISIS and EIGRP to do mutual redistribution

interface Serial0
description connection to router3 EIGRP net
ip address 192.168.1.1 255.255.255.0

!
interface Serial1
description connection to router2 ISIS net
ip address 10.1.1.1 255.255.255.0
ip router isis
!

router eigrp 1
redistribute isis level-1 metric 64 100 255 1 1500
network 10.1.1.0 0.0.0.255
network 192.168.1.0
no auto-summary

!
router isis
redistribute eigrp 1 metric 10 metric-type external level-1


Here is the part that is confusing me. The only way I could get it to work
is to
redistribute connected or tell EIGRP about the 10.1.1.0 network which is
basically the same thing.

Usually when you redistribute you don't have to tell the protocol about both
networks.

I didn't have to enable ISIS on interface Serial0 (eigrp side)

Why do I have to enable EIGRP on interface Serial1 (isis side)


I tried it the other way around, I removed the 10.1.1.0 network From EIGRP
and enabled ISIS on the 192.168.1.0 side but it didn't work, why?


 
Reply With Quote
 
 
 
 
Ivan Ostreš
Guest
Posts: n/a
 
      12-20-2004
In article <41c6cdee$(E-Mail Removed)>, http://www.velocityreviews.com/forums/(E-Mail Removed)
says...
>
> I didn't have to enable ISIS on interface Serial0 (eigrp side)
>
> Why do I have to enable EIGRP on interface Serial1 (isis side)
>
>


Usually you don't need to do that. ISIS is a special case. When you have
a redistribution ISIS to anything else, you have to redistribute
connected interfaces which are under ISIS process manualy by
'redistribute connected' or 'network' statement in destination routing
protocol.

I've never find out why this happens, but it does. I tried it on the
Juniper router and there wasn't such situation (if I remember
correctly). So, it's probably due cisco implementation of ISIS.

If anyone know this in some more depth and find some time to write it
here, that would be great...


--
-Ivan.

*** Use Rot13 to see my eMail address ***
 
Reply With Quote
 
 
 
 
mos33 mos33 is offline
Junior Member
Join Date: Aug 2008
Posts: 8
 
      09-19-2008
what the meaning of redistribution level 1 routes inside EIGRP??
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
EIGRP, BPG, and Redistribution Scrif Cisco 1 02-23-2007 03:16 AM
configuring route redistribution from eigrp into isis ciscohelp Cisco 0 09-05-2006 05:41 AM
Problems mutual redistributing of ISIS and EIGRP phillip Cisco 5 12-07-2004 07:49 PM
route redistribution RIP and EIGRP slipstream_242 Cisco 1 07-15-2004 11:21 PM
Redistribution between IS-IS, EIGRP & OSPF Sam Soh Cisco 5 08-15-2003 02:03 AM



Advertisments