Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Problem with incomplete page and blank explorer

Reply
Thread Tools

Problem with incomplete page and blank explorer

 
 
Daniel Alvarez
Guest
Posts: n/a
 
      08-28-2006
Hello. First of all, I'm working in an ASP.NET 1.1 project, which has a
large page (due to client requirements, a huge page is needed to process the
information, and it has a lot of interactivity with the user, so that if
some value changes, the screen refresh showing some other data, or a grid,
and so on). This is working well (but slow, but this is not the problem
right now).
The problem is that, randomly, opening the page, or refreshing it due to a
postback, the explorer gets a blank page, and the content is never rendered
(only if the F5 or back is pressed the content refresh).

Some guides:

The application is built to run with Internet Explorer only, so we cannot
test the problem with Firefox or another browser.
We have the latest patchs and service packs applied (I've read some problems
occured when using Internet Explorer without some patchs).
The problem is difficult to reproduce. But some people here is testing the
system, so we get some feedback of them when using and having the error.
When the page is in that state, the cursor is in waiting state when the
mouse is over the title bar.
Doing a "view source" command, shows the page, but it is incomplete (at
random places).
Cutting the view source text and pasting in a text file, we get a file size
smaller that the page size got with the "properties" in the page. (This
means to me that the page has not finalized transmitting the content
completely)
We have some dropdownlists in the page, some of them have lots of data, so
we cut the data in them so to discard the problem. Keep on failing.
In one test, we changed the http 1.1 protocol (default in Internet
Explorer), to http 1.0, so the page transmit syncronously and not using
chunked encoding. (The problem persisted, but it was less often... But
persisted)
Other thing that we tested is disabling the compression in the IIS. (but
didn't work)

Any other clues?

Thank you very much

Daniel Alvarez
Inworx IT Solutions
http://www.inworx.com
Buenos Aires
Argentina


 
Reply With Quote
 
 
 
 
Tim_Mac
Guest
Posts: n/a
 
      08-28-2006
hi Daniel,
my guess is that there are intermittent network problems between the client
and web server. the problem may not manifest with other web sites because
the pages are probably much smaller. is there anything common between the
users reporting the problem? i.e. VPN, hardware, modem type, location,
anti-virus software, firewalls?
do all the network cards have the correct and most up-to-date drivers? i
know it sounds like a long shot but it is a possibility, a corrupt packet on
the network could cause the network card to hang etc.

how about the server, is it under heavy stress? you could leave the
performance monitor running for a while. i wonder what the HTTP status
codes of the failed page loads are. it may or may not be practical to look
at such detail.

i've also heard of proxy servers that interfere with asp.net page output,
corrupting the viewstate, but this usually produces an exception so i guess
it's not related.

i hope this provides you with some areas to look at in more detail. i'd be
interested to hear if you make any progress.
tim

------------------------------------------
blog: http://tim.mackey.ie

"Daniel Alvarez" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hello. First of all, I'm working in an ASP.NET 1.1 project, which has a
> large page (due to client requirements, a huge page is needed to process
> the
> information, and it has a lot of interactivity with the user, so that if
> some value changes, the screen refresh showing some other data, or a grid,
> and so on). This is working well (but slow, but this is not the problem
> right now).
> The problem is that, randomly, opening the page, or refreshing it due to a
> postback, the explorer gets a blank page, and the content is never
> rendered
> (only if the F5 or back is pressed the content refresh).
>
> Some guides:
>
> The application is built to run with Internet Explorer only, so we cannot
> test the problem with Firefox or another browser.
> We have the latest patchs and service packs applied (I've read some
> problems
> occured when using Internet Explorer without some patchs).
> The problem is difficult to reproduce. But some people here is testing the
> system, so we get some feedback of them when using and having the error.
> When the page is in that state, the cursor is in waiting state when the
> mouse is over the title bar.
> Doing a "view source" command, shows the page, but it is incomplete (at
> random places).
> Cutting the view source text and pasting in a text file, we get a file
> size
> smaller that the page size got with the "properties" in the page. (This
> means to me that the page has not finalized transmitting the content
> completely)
> We have some dropdownlists in the page, some of them have lots of data, so
> we cut the data in them so to discard the problem. Keep on failing.
> In one test, we changed the http 1.1 protocol (default in Internet
> Explorer), to http 1.0, so the page transmit syncronously and not using
> chunked encoding. (The problem persisted, but it was less often... But
> persisted)
> Other thing that we tested is disabling the compression in the IIS. (but
> didn't work)
>
> Any other clues?
>
> Thank you very much
>
> Daniel Alvarez
> Inworx IT Solutions
> http://www.inworx.com
> Buenos Aires
> Argentina
>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet Explorer 8: C:\Program Files\Internet Explorer\iexplore.exe vs C:\Program Files (x86)\Internet Explorer\iexplore.exe Nathan Sokalski Windows 64bit 16 02-22-2010 08:31 AM
blank CD-R and blank DVD-R not recognized by Vista 64 Ultimate =?Utf-8?B?R3JlZyBLaXJrcGF0cmljaw==?= Windows 64bit 13 11-07-2007 12:23 PM
Microsoft Internet Explorer Displays a Blank Page While It Uses HTTP 1.1 on IIS6 Web Developer ASP .Net 1 01-05-2007 11:08 PM
Where does Internet Explorer Store Incomplete Downloads? ya-ka Computer Support 3 08-11-2006 03:41 PM



Advertisments