Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > UK VOIP > Using Asterisk to simulate an ISDN2e line

Reply
Thread Tools

Using Asterisk to simulate an ISDN2e line

 
 
Ron Wellsted
Guest
Posts: n/a
 
      08-25-2006
I am trying to get 2 Asterisk servers to communicate over an ISDN2e line.

Each is running Asterisk 1.2.10 + Bristuff driving a HFC-S chipset BRI
card. One is configured as bri_net_ptmp, the other as bri_cpe_ptmp.

I have built a crossover cable wired as

(Rx+) 3 ------ 4 (Tx+)
(Tx+) 4 ------ 3 (Rx+)
(Tx-) 5 ------ 6 (Rx-)
(Rx-) 6 ------ 5 (Tx-)

However the slave (cpe) Asterisk box always reports that the
D-channel is unavailable. While the master (net) box seems happy.

Changing to ptp mode (bri_net and bri_cpe signalling) causes both boxes to
report a lack of D-channel.

Can anybody tell me where I am going wrong?

--
Ron Wellsted
http://www.velocityreviews.com/forums/(E-Mail Removed) http://www.wellsted.org.uk
N 52.567623, W 2.137621 Linux Counter No. 202120
FWD:519961

 
Reply With Quote
 
 
 
 
Thomas Kenyon
Guest
Posts: n/a
 
      08-26-2006
Ron Wellsted wrote:
> I am trying to get 2 Asterisk servers to communicate over an ISDN2e line.
>
> Each is running Asterisk 1.2.10 + Bristuff driving a HFC-S chipset BRI
> card. One is configured as bri_net_ptmp, the other as bri_cpe_ptmp.
>
> I have built a crossover cable wired as
>
> (Rx+) 3 ------ 4 (Tx+)
> (Tx+) 4 ------ 3 (Rx+)
> (Tx-) 5 ------ 6 (Rx-)
> (Rx-) 6 ------ 5 (Tx-)
>
> However the slave (cpe) Asterisk box always reports that the
> D-channel is unavailable. While the master (net) box seems happy.
>
> Changing to ptp mode (bri_net and bri_cpe signalling) causes both boxes to
> report a lack of D-channel.
>
> Can anybody tell me where I am going wrong?
>

I personally thought that you didn't use a crossover in this arrangement.

I wouldn't know though. You'd be better off asking on the asterisk-users
mailing list. There are a lot more ISDN users on there.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Simulate webform inheritance without using master pages Pedro Mir ASP .Net 0 08-16-2006 11:24 AM
How to Simulate more than One User using Microsoft Web Application Stress (WAS) Tool Anupa ASP .Net Web Services 0 03-26-2006 12:28 PM
Putting outbound call to ISDN2e line on hold rings second ISDN channel Linker3000 UK VOIP 1 03-21-2006 11:13 PM
hardware needed to simulate 500 vusers(HTTP) using grinder HArolD Java 4 04-14-2005 07:44 AM
How to simulate HTTP POST using headers? Luis Faisco ASP General 1 05-09-2004 04:50 PM



Advertisments