Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Cisco Catalyst 5500 - Routing between VLAN problems?

Reply
Thread Tools

Cisco Catalyst 5500 - Routing between VLAN problems?

 
 
xrule
Guest
Posts: n/a
 
      12-10-2004
Recently many people can't print to many Lexmark Network Printers.

Printer is on 10.8.18.0/24 network
PCs received IP from DHCP Server range from 10.8.20.1/23
DHCP Server gives gateway as 10.8.18.1/24

On Catalyist it was configured as the following

Current configuration:
!
version 11.3
service timestamps debug datetime
service timestamps log datetime
service password-encryption
!
hostname PraGunPai_RSM
!
boot system flash bootflash:c5rsm-ds-mz.113-2.WA4.4.bin
enable secret 5 $1$hBQe$U3xeftavktzAWc8TI24YG.
enable password 7 0310581823012645400C1C17
!
ip name-server 10.100.10.1
!
interface Vlan1
ip address 11.1.8.1 255.255.0.0
ip helper-address 10.8.18.15
!
interface Vlan3
ip address 10.8.1.1 255.255.255.0 secondary
ip address 10.8.18.1 255.255.255.0
ip helper-address 10.8.18.15
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.18.2
snmp-server community public RO
snmp-server community private RW
!
line con 0
line aux 0
line vty 0 4
password 7 1506081F21242C2D26363030
login
!
end

So, I add this line ip address 10.8.20.1 255.255.254.0 secondary

into VLAN3 Interface

But, it doesn't seem to stop the problem. Some time I can't even ping
the printer. Please give me some advices, you help is greatly
appriciated.

 
Reply With Quote
 
 
 
 
Phillip Remaker
Guest
Posts: n/a
 
      12-12-2004
"xrule" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
> Recently many people can't print to many Lexmark Network Printers.
>
> Printer is on 10.8.18.0/24 network
> PCs received IP from DHCP Server range from 10.8.20.1/23
> DHCP Server gives gateway as 10.8.18.1/24


Which VLANs are these devices on?
What changed?
Do the printers get addressed by DHCP, too?
What VLAN are they on?

> interface Vlan3
> ip address 10.8.1.1 255.255.255.0 secondary
> ip address 10.8.18.1 255.255.255.0
> ip helper-address 10.8.18.15
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 10.8.18.2


Hmmm, what other default routed exist? No routing protocol? Maybe a
routing loop?



 
Reply With Quote
 
 
 
 
xrule
Guest
Posts: n/a
 
      12-12-2004
They are all on VLAN3
Printer is manually configures such as 18.8.18.54/24
No routing protocal ever turned on.
Please explain more about the routing loop?

Many thanks

xrule...

 
Reply With Quote
 
PES
Guest
Posts: n/a
 
      12-13-2004
xrule wrote:
> Recently many people can't print to many Lexmark Network Printers.
>
> Printer is on 10.8.18.0/24 network
> PCs received IP from DHCP Server range from 10.8.20.1/23
> DHCP Server gives gateway as 10.8.18.1/24


I don't understand what you are saying here. I understand the that
printers can be in the range of 10.8.18.1-254. I understand the pc's
can be in the range of 10.8.20.1-10.8.21.254. However if the dhcp
server hands out a gateway of 10.8.18.1, you are basically asking and
hoping that the pc sends a proxy arp and that the router responds. The
gateway is not on the same subnet as the pc's.

The gateway wouldn't have a prefix length. The prefix length is to
determine if a gateway should be used. The gateway is simply an ip
address. So when the DHCP server gives the gateway, it simply gives an
IP address.

Bottom line is are you wanting to hierarchically structure this, or do
you want to flatten it out. If the former is the case, create separate
vlans for the printers, configure their respective ports and point them
to the correct ip for their subnet mask. If you want to flatten the
network, you can point them all (the pc's and printers to the same
gateway) and shorten your prefix length to a /21 or less. If you want
to keep it simple go to /16 or 255.255.0.0. Make sure the mask matches
on all devices.

You are basically asking your pc's and devices to use some less
trustworthy mechanisms for route determination and resolution.
Different os's behave differently. If you configure this all correctly
it should work. However, I would not attempt to have multiple layer 3
networks laying atop of a single vlan. It is not good practice.

>
> On Catalyist it was configured as the following
>
> Current configuration:
> !
> version 11.3
> service timestamps debug datetime
> service timestamps log datetime
> service password-encryption
> !
> hostname PraGunPai_RSM
> !
> boot system flash bootflash:c5rsm-ds-mz.113-2.WA4.4.bin
> enable secret 5 $1$hBQe$U3xeftavktzAWc8TI24YG.
> enable password 7 0310581823012645400C1C17
> !
> ip name-server 10.100.10.1
> !
> interface Vlan1
> ip address 11.1.8.1 255.255.0.0
> ip helper-address 10.8.18.15
> !
> interface Vlan3
> ip address 10.8.1.1 255.255.255.0 secondary
> ip address 10.8.18.1 255.255.255.0
> ip helper-address 10.8.18.15
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 10.8.18.2
> snmp-server community public RO
> snmp-server community private RW
> !
> line con 0
> line aux 0
> line vty 0 4
> password 7 1506081F21242C2D26363030
> login
> !
> end
>
> So, I add this line ip address 10.8.20.1 255.255.254.0 secondary
>
> into VLAN3 Interface
>
> But, it doesn't seem to stop the problem. Some time I can't even ping
> the printer. Please give me some advices, you help is greatly
> appriciated.
>



--
-------------------------
Paul Stewart
Lexnet Inc.
Email address is in ROT13
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone know about: vlan trunking with catalyst 1900 to any other iosdevice (catalyst 2950) Neddy Cisco 8 05-27-2009 04:37 PM
VLAN routing on Catalyst 4006 with L3-module Catalyst_user Cisco 3 11-22-2006 08:01 PM
Connecting Cisco Catalyst 5500 to network introduces VLAN problems Tozz Cisco 2 01-19-2006 12:32 PM
VLAN trunking across Catalyst 2900 XL and Catalyst 1900. Jarek Jarzebowski Cisco 1 06-18-2005 08:57 PM
VLAN Trunking Cisco Cat 5500 switch (multiple vlans per port) help please BG Cisco 4 09-07-2004 01:39 AM



Advertisments