Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > MS Cluster and NLB with PIX 501

Reply
Thread Tools

MS Cluster and NLB with PIX 501

 
 
Scott Lowe
Guest
Posts: n/a
 
      11-29-2004
A customer of mine is experiencing some problems with some co-located
servers behind their Cisco PIX 501 running 6.2(1). Specifically, they
are experiencing connectivity problems with a newly-created
active/passive cluster (running Win2K3, IIRC). Based on the research
I've done thus far, I suspect the problem is related to MAC addresses
and how those MAC addresses relate to the cluster node IP addresses and
the IP address of the cluster virtual server. When the cluster fails
over, the cluster virtual server IP address must now be associated with
the MAC address of the now active cluster node NIC. I believe this is
causing a problem with the PIX.

In addition, I've seen some references that indicate that the cluster
virtual IP is a "receive only" IP address, and that traffic generated
from the cluster will actually originate from the IP address of the
active node. If this is the case, I can see situations where traffic
is set to one IP (the cluster virtual server IP), but the reply comes
from a different iP (the cluster node itself). Anyone run into this?
If so, any workarounds? I thought of using a separate NAT group to
translate the cluster node IP addresses and the cluster virtual IP
address itself all the same public IP, but this affects connectivity
directly to the cluster nodes themselves.

Any insight, suggestions, etc., would be greatly appreciated. TIA.

--
Scott Lowe

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Validation of viewstate MAC failed. If this application is hosted by a Web Farm or cluster, ensure that <machineKey> configuration specifies the same validationKey and validation algorithm. AutoGenerate cannot be used in a cluster. Mark B ASP .Net 2 09-11-2009 07:09 AM
Validation of viewstate MAC failed. If this application is hosted by a Web Farm or cluster, ensure that <machineKey> configuration specifies the same validationKey and validation algorithm. AutoGenerate cannot be used in a cluster. Dhruba Bandopadhyay ASP .Net 1 05-25-2006 01:06 AM
NAT'd NLB Web Cluster Carlos Cisco 2 02-28-2006 03:41 AM
Duplication Submission on NLB cluster =?Utf-8?B?QWVkZW4gSmFtZXNvbg==?= ASP .Net 2 10-04-2005 01:08 AM
PIX 501 <-> PIX 501 - Problem contating private networks on the inside Andre Cisco 7 02-20-2005 07:02 PM



Advertisments