Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > cable modem giving private IP

Reply
Thread Tools

cable modem giving private IP

 
 
ddpant@gmail.com
Guest
Posts: n/a
 
      08-10-2006
hello,
i have been trying to connect Cisco 1720 router to time-warner cable
modem for home network. the router has two ethernet ports, fa0 and
eth0. i want eth0 to be internal and fa0 to connect to modem. i enabled
dhcp on fa0, but the cable modem always gives a private IP instead of
public. time warner has no idea how to fix this. their response was
that for some reason the modem thinks that the router is one of their
network's nodes.

i would really appreciate your response.

 
Reply With Quote
 
 
 
 
www.BradReese.Com
Guest
Posts: n/a
 
      08-10-2006
You may also wish to "post" on the cable modem newsgroup:

comp.dcom.modems.cable

http://groups.google.com/group/comp.dcom.modems.cable

Found on Brad's Technical Forum List:

http://www.bradreese.com/cisco-techn...roups.htm#TECH

Sincerely,

Brad Reese
BradReese.Com - Global Cisco Systems Pre-Sales Support
http://www.bradreese.com/contact-us.htm#CISCO
1293 Hendersonville Road, Suite 17
Asheville, North Carolina USA 28803
USA & Canada: 877-549-2680
International: 828-277-7272
Fax: 775-254-3558
AIM: R2MGrant
BradReese.Com - Cisco CraigsList Job Openngs
http://www.bradreese.com/craigslist-networking-jobs.htm

 
Reply With Quote
 
 
 
 
Merv
Guest
Posts: n/a
 
      08-10-2006

Try changing the MAC address on the FA 0 interface so that it does not
have a Cisco vendor ID in the first 6 characters

int fa 0
mac-address EEEE.EE00.0001
end

 
Reply With Quote
 
Martin Gallagher
Guest
Posts: n/a
 
      08-12-2006
On Thu, 10 Aug 2006 12:28:43 -0700, http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:

> i have been trying to connect Cisco 1720 router to time-warner cable
> modem for home network. the router has two ethernet ports, fa0 and
> eth0. i want eth0 to be internal and fa0 to connect to modem. i enabled
> dhcp on fa0, but the cable modem always gives a private IP instead of
> public. time warner has no idea how to fix this. their response was
> that for some reason the modem thinks that the router is one of their
> network's nodes.


How old is your IOS. There was a bug in the DHCP client some time ago
that did exactly that. One of the option fields was inappropriately filled
in and made the router look like a cable modem to the DHCP server.

It seems Google really is our friend:

The bug ID is CSCdx67972:
------------
A Cisco router running 12.1T or 12.2 IOS will incorrectly set the
Class ID (Option 60) of a DHCP Discover Packet.

This only causes a problem when the following is true:

1) Router is setup to be a DHCP Client.
2) DHCP Server is looking at Option 60 to assign IP addresses
3) Router is connected behind a Cable Modem.

This is a rare problem that does not effect every customer running
the router as a DHCP Client.
-----------

--
Rgds,
Martin
 
Reply With Quote
 
ddpant@gmail.com
Guest
Posts: n/a
 
      09-02-2006
I updated the IOS, and it works fine now.
Thanks for all your help.
-DP


Martin Gallagher wrote:
> On Thu, 10 Aug 2006 12:28:43 -0700, (E-Mail Removed) wrote:
>
> > i have been trying to connect Cisco 1720 router to time-warner cable
> > modem for home network. the router has two ethernet ports, fa0 and
> > eth0. i want eth0 to be internal and fa0 to connect to modem. i enabled
> > dhcp on fa0, but the cable modem always gives a private IP instead of
> > public. time warner has no idea how to fix this. their response was
> > that for some reason the modem thinks that the router is one of their
> > network's nodes.

>
> How old is your IOS. There was a bug in the DHCP client some time ago
> that did exactly that. One of the option fields was inappropriately filled
> in and made the router look like a cable modem to the DHCP server.
>
> It seems Google really is our friend:
>
> The bug ID is CSCdx67972:
> ------------
> A Cisco router running 12.1T or 12.2 IOS will incorrectly set the
> Class ID (Option 60) of a DHCP Discover Packet.
>
> This only causes a problem when the following is true:
>
> 1) Router is setup to be a DHCP Client.
> 2) DHCP Server is looking at Option 60 to assign IP addresses
> 3) Router is connected behind a Cable Modem.
>
> This is a rare problem that does not effect every customer running
> the router as a DHCP Client.
> -----------
>
> --
> Rgds,
> Martin


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cable modem to Wireless modem MRRIGGA Wireless Networking 2 02-19-2008 06:41 PM
The giving that keeps on giving sixteenmillion C Programming 0 11-19-2007 10:59 PM
Cisco 3640 NM-4E Westell ADSL Modem & Ambit Cable Modem/Router Half 1/2 Speed Chris Cisco 0 06-04-2006 07:38 PM



Advertisments