Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > VHDL > Virtual Signals in Modelsim

Reply
Thread Tools

Virtual Signals in Modelsim

 
 
a1_nocrap_exh@hotmail.com
Guest
Posts: n/a
 
      08-08-2006
One of the best (and most under used) features of Modelsim is the
virtual signals feature.

Ok, so it needs a GUI to help create the functions/signals but I think
it's great and use it all the time to say.... create virtual enumerated
busses or quickly gate signals that I would otherwise have to change my
HDL, recompile and resimulate. etc.

However I've got this strange problem. I fire up Modelsim (6.1c) and
load in my .do files (Which include virtual signals and functions) run
my simulation and quit and for some strange reason Modelsim saves a
file called virtuals.do

This file has a copy of all virtual commands in my do files.

I run modelsim again and it appends the same entries over to this
virtuals.do.

Each time I run modelsim this file gets bigger and bigger until it
starts to slow down the simulator (when starting and exiting).

Can anyone explain to me this behaviour? I could understand if it just
saved newly created virtuals, but saving ones which have been loaded
in? And saving the same ones over and over again?

Any advice accepted.

Alex

 
Reply With Quote
 
 
 
 
Jonathan Bromley
Guest
Posts: n/a
 
      08-08-2006
On 8 Aug 2006 04:46:07 -0700, http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:


>I run modelsim again and it appends the same entries over to this
>virtuals.do.


I didn't know that; but it seems to me that you can easily enough
get around it. When you load the sim, just do it with a little
script that first does
file delete virtual.do
so that your file is created afresh.

No promises - just a suggestion.

A bug report to Mentor sounds good, too
--
Jonathan Bromley, Consultant

DOULOS - Developing Design Know-how
VHDL * Verilog * SystemC * e * Perl * Tcl/Tk * Project Services

Doulos Ltd., 22 Market Place, Ringwood, BH24 1AW, UK
(E-Mail Removed)
http://www.MYCOMPANY.com

The contents of this message may contain personal views which
are not the views of Doulos Ltd., unless specifically stated.
 
Reply With Quote
 
 
 
 
a1_nocrap_exh@hotmail.com
Guest
Posts: n/a
 
      08-08-2006
Jonathan Bromley wrote:
> On 8 Aug 2006 04:46:07 -0700, (E-Mail Removed) wrote:
> do it with a little script that first does file delete virtual.do


Sure but I was hoping for a parameter / command for modelsim.

 
Reply With Quote
 
Mike Treseler
Guest
Posts: n/a
 
      08-08-2006
(E-Mail Removed) wrote:

> Sure but I was hoping for a parameter / command for modelsim.


do you have the .pdfs?
check out "virtual save" options

-- Mike Treseler
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Adding internal signals in Modelsim Al VHDL 4 11-13-2006 08:04 AM
[modelsim] displaying signals from inside components Nikola Skoric VHDL 3 06-23-2006 05:05 PM
Internal Signals and other questions with ModelSim XE/II Starter 5.7g VHDL Testbench Martin Maurer VHDL 2 05-21-2004 03:45 AM
Modelsim - forcing signals to 'Z' DonQ VHDL 2 02-28-2004 11:33 AM
Adding internal signals in Modelsim ALuPin VHDL 5 01-08-2004 07:35 AM



Advertisments