Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > dns relay(through dhcp)...

Reply
Thread Tools

dns relay(through dhcp)...

 
 
Captain
Guest
Posts: n/a
 
      07-26-2006
I have a cisco806 with 2 ethernet ports,
(Ethernet1 is connected to the internet,
Ethernet0 is connected to my LAN).

The router picks up everthing using DHCP,
and passes everthing internally using DHCP.

But no-one,(not even the router itself),
can connect to,(or even ping), either of
the dns without adding the following 2
lines of code,(y.y.y.y is the ISP gateway):

ip route x.x.x.a 255.255.255.255 y.y.y.y
ip route x.x.x.b 255.255.255.255 y.y.y.y

Why would this be?

fyi: I don't want to leave the ISP gateway
in the configuration if possible.

Partial configuration follows:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
version 12.2
!
ip name-server x.x.x.a
ip name-server x.x.x.b
ip dhcp excluded-address 192.168.0.1 192.168.0.200
!
ip dhcp pool main
import all
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server x.x.x.a
!
no ip dhcp-client network-discovery
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
no ip redirects
ip nat inside
no cdp enable
!
interface Ethernet1
ip address dhcp
no ip unreachables
ip nat outside
no cdp enable
!
ip nat inside source list 101 interface Ethernet1 overload
ip classless
ip route x.x.x.a 255.255.255.255 y.y.y.y
ip route x.x.x.b 255.255.255.255 y.y.y.y
!
access-list 101 permit ip 192.168.0.0 0.0.0.255 any
no cdp run
!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


----== Posted via Newsfeeds.Com - Unlimited-Unrestricted-Secure Usenet News==----
http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
----= East and West-Coast Server Farms - Total Privacy via Encryption =----
 
Reply With Quote
 
 
 
 
Merv
Guest
Posts: n/a
 
      07-27-2006
Default route ???

ip route 0.0.0.0 0.0.0.0 dhcp

or

ip route 0.0.0.0 0.0.0.0 y.y.y.y

 
Reply With Quote
 
 
 
 
Captain
Guest
Posts: n/a
 
      07-28-2006
I don't have one.

fyi: Everything seems to work without one, and this way the dhcp
seems to get the default route WITHOUT having to hard code
it in.

However, the 2 dns IPs,(which again the dhcp picks up), seem to
not route?!?!?!




On 27 Jul 2006 03:10:08 -0700, "Merv" <(E-Mail Removed)> wrote:
>Default route ???
>
>ip route 0.0.0.0 0.0.0.0 dhcp
>
>or
>
>ip route 0.0.0.0 0.0.0.0 y.y.y.y
>



----== Posted via Newsfeeds.Com - Unlimited-Unrestricted-Secure Usenet News==----
http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
----= East and West-Coast Server Farms - Total Privacy via Encryption =----
 
Reply With Quote
 
Merv
Guest
Posts: n/a
 
      07-28-2006

Captain wrote:
> I don't have one.
>
> fyi: Everything seems to work without one, and this way the dhcp
> seems to get the default route WITHOUT having to hard code
> it in.
>




You want to have a default route !!!

The dns servers IP addresses could change at any point in time.

IMHO configuring static routes for the current dns servers is not a
good idea

So configure a default route. remove the current static and confirm
that you have connectivity by name...

 
Reply With Quote
 
Martin Gallagher
Guest
Posts: n/a
 
      07-30-2006
On Fri, 28 Jul 2006 20:39:29 +0000, Captain wrote:

> I don't have one.
>
> fyi: Everything seems to work without one, and this way the dhcp
> seems to get the default route WITHOUT having to hard code
> it in.
>
> However, the 2 dns IPs,(which again the dhcp picks up), seem to
> not route?!?!?!
>


So post "show ip route" then. Do you perhaps have "no ip classless"
configured?

--
Rgds,
Martin
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure win 2k3 DNS so it won't try to register it to dns roots? juska General Computer Support 1 11-12-2007 06:15 PM
PIX 501 relay client DNS requests out to an internet DNS server? nicough@gmail.com Cisco 1 11-18-2006 03:29 PM
DNS query to internal DNS server from static NAT host none Cisco 5 04-25-2006 03:11 AM
DNS query from outside to internal, public DNS server Lars Bonnesen Cisco 9 04-08-2006 11:16 AM
DNS question - reverse DNS getting cluttered Jose Padilla Computer Support 0 01-21-2004 10:29 PM



Advertisments