Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > QUESTION: Unable to ping between Router 1 and Router 3

Reply
Thread Tools

QUESTION: Unable to ping between Router 1 and Router 3

 
 
Voitec
Guest
Posts: n/a
 
      09-12-2004
Hi,

2nd prob for the day; I'm unable to ping between:
Router 2 s1 <> Router 3 s0

Can anyone pls correct the following config if necessary? Are all those
items listed below needed or can I get rid of certain items? I'm trying to
have as basic a config as necessary for bare connectivity.

Many thanks,
Voitec



ROUTER 1
*********
!
interface Serial1
ip address 192.169.15.1 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
router rip
network 192.169.0.0
!
no ip classless
ip route 172.17.0.0 255.255.0.0 192.169.15.2
!


ROUTER 2
*********
!
interface Serial0
ip address 172.17.0.1 255.255.0.0
no ip route-cache
no ip mroute-cache
clockrate 64000
!
interface Serial1
ip address 192.169.15.2 255.255.255.0
no ip route-cache
no ip mroute-cache
!
router rip
network 172.17.0.0
network 192.169.0.0
!
no ip classless
!


ROUTER 3
*********
!
interface Serial0
ip address 172.17.0.2 255.255.0.0
no ip mroute-cache
!
interface Serial1
ip address 192.168.15.3 255.255.255.0
clockrate 64000
!
router rip
network 172.17.0.0
network 192.169.0.0
!
no ip classless
!


 
Reply With Quote
 
 
 
 
PES
Guest
Posts: n/a
 
      09-12-2004

"Voitec" <(E-Mail Removed)> wrote in message
news:UhV0d.28112$(E-Mail Removed)...
> Hi,
>
> 2nd prob for the day; I'm unable to ping between:
> Router 2 s1 <> Router 3 s0
>
> Can anyone pls correct the following config if necessary? Are all those
> items listed below needed or can I get rid of certain items? I'm trying to
> have as basic a config as necessary for bare connectivity.
>
> Many thanks,
> Voitec
>


Is router 3 s0 physically connected to r1 s1, or r2 s1? Or is r1 s1
connected to r2 s1? In any case, I would say it is impossible for you to
connect 3 point to point connections together, the way your configuration
suggests.

>
>
> ROUTER 1
> *********
> !
> interface Serial1
> ip address 192.169.15.1 255.255.255.0
> no ip directed-broadcast
> clockrate 64000
> !
> router rip
> network 192.169.0.0
> !
> no ip classless
> ip route 172.17.0.0 255.255.0.0 192.169.15.2


What is this static for? Rip should give you the routing table.

> !
>
>
> ROUTER 2
> *********
> !
> interface Serial0
> ip address 172.17.0.1 255.255.0.0
> no ip route-cache
> no ip mroute-cache
> clockrate 64000
> !
> interface Serial1
> ip address 192.169.15.2 255.255.255.0
> no ip route-cache
> no ip mroute-cache
> !
> router rip
> network 172.17.0.0
> network 192.169.0.0
> !
> no ip classless
> !
>
>
> ROUTER 3
> *********
> !
> interface Serial0
> ip address 172.17.0.2 255.255.0.0
> no ip mroute-cache
> !
> interface Serial1
> ip address 192.168.15.3 255.255.255.0
> clockrate 64000
> !
> router rip
> network 172.17.0.0
> network 192.169.0.0
> !
> no ip classless
> !
>
>



 
Reply With Quote
 
 
 
 
Barry Margolin
Guest
Posts: n/a
 
      09-12-2004
In article <UhV0d.28112$(E-Mail Removed)>,
"Voitec" <(E-Mail Removed)> wrote:

> Hi,
>
> 2nd prob for the day; I'm unable to ping between:
> Router 2 s1 <> Router 3 s0


Your subject line says the problem is between Router 1 and Router 3, but
now you're asking about Router 2 and Router 3. Which is it?

>
> Can anyone pls correct the following config if necessary? Are all those
> items listed below needed or can I get rid of certain items? I'm trying to
> have as basic a config as necessary for bare connectivity.
>
> Many thanks,
> Voitec
>
>
>
> ROUTER 1
> *********
> !
> interface Serial1
> ip address 192.169.15.1 255.255.255.0
> no ip directed-broadcast
> clockrate 64000
> !
> router rip
> network 192.169.0.0


Shouldn't this be "network 192.168.15.0", since your interface has a
Class C address? Or do you have a 192.169.0.x address on some other
interface that you're not showing?

> !
> no ip classless
> ip route 172.17.0.0 255.255.0.0 192.169.15.2
> !
>
>
> ROUTER 2
> *********
> !
> interface Serial0
> ip address 172.17.0.1 255.255.0.0
> no ip route-cache
> no ip mroute-cache
> clockrate 64000
> !
> interface Serial1
> ip address 192.169.15.2 255.255.255.0
> no ip route-cache
> no ip mroute-cache
> !
> router rip
> network 172.17.0.0
> network 192.169.0.0
> !
> no ip classless
> !
>
>
> ROUTER 3
> *********
> !
> interface Serial0
> ip address 172.17.0.2 255.255.0.0
> no ip mroute-cache
> !
> interface Serial1
> ip address 192.168.15.3 255.255.255.0
> clockrate 64000
> !
> router rip
> network 172.17.0.0
> network 192.169.0.0
> !
> no ip classless
> !


--
Barry Margolin, http://www.velocityreviews.com/forums/(E-Mail Removed)
Arlington, MA
*** PLEASE post questions in newsgroups, not directly to me ***
 
Reply With Quote
 
Voitec
Guest
Posts: n/a
 
      09-12-2004
Yes, sorry, just realised the typo.

I'm unable to ping between Router3 s0 and Router 2 s1, ie. 172.17.0.2 and
192.169.15.2. This in turn means I cannot ping between 172.17.0.2 and
192.169.15.1 (which is Router 1 s1).

Physical connections are as follows:
Router 3 s0 <> Router 2 s0 (DCE)
Router 2 s1 <> Router 1 s1 (DCE)

Apologies for the confusion.


"Barry Margolin" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> In article <UhV0d.28112$(E-Mail Removed)>,
> "Voitec" <(E-Mail Removed)> wrote:
>
> > Hi,
> >
> > 2nd prob for the day; I'm unable to ping between:
> > Router 2 s1 <> Router 3 s0

>
> Your subject line says the problem is between Router 1 and Router 3, but
> now you're asking about Router 2 and Router 3. Which is it?
>
> >
> > Can anyone pls correct the following config if necessary? Are all those
> > items listed below needed or can I get rid of certain items? I'm trying

to
> > have as basic a config as necessary for bare connectivity.
> >
> > Many thanks,
> > Voitec
> >
> >
> >
> > ROUTER 1
> > *********
> > !
> > interface Serial1
> > ip address 192.169.15.1 255.255.255.0
> > no ip directed-broadcast
> > clockrate 64000
> > !
> > router rip
> > network 192.169.0.0

>
> Shouldn't this be "network 192.168.15.0", since your interface has a
> Class C address? Or do you have a 192.169.0.x address on some other
> interface that you're not showing?
>
> > !
> > no ip classless
> > ip route 172.17.0.0 255.255.0.0 192.169.15.2
> > !
> >
> >
> > ROUTER 2
> > *********
> > !
> > interface Serial0
> > ip address 172.17.0.1 255.255.0.0
> > no ip route-cache
> > no ip mroute-cache
> > clockrate 64000
> > !
> > interface Serial1
> > ip address 192.169.15.2 255.255.255.0
> > no ip route-cache
> > no ip mroute-cache
> > !
> > router rip
> > network 172.17.0.0
> > network 192.169.0.0
> > !
> > no ip classless
> > !
> >
> >
> > ROUTER 3
> > *********
> > !
> > interface Serial0
> > ip address 172.17.0.2 255.255.0.0
> > no ip mroute-cache
> > !
> > interface Serial1
> > ip address 192.168.15.3 255.255.255.0
> > clockrate 64000
> > !
> > router rip
> > network 172.17.0.0
> > network 192.169.0.0
> > !
> > no ip classless
> > !

>
> --
> Barry Margolin, (E-Mail Removed)
> Arlington, MA
> *** PLEASE post questions in newsgroups, not directly to me ***



 
Reply With Quote
 
PES
Guest
Posts: n/a
 
      09-12-2004

"Voitec" <(E-Mail Removed)> wrote in message
news:BZX0d.28491$(E-Mail Removed)...
> Yes, sorry, just realised the typo.
>
> I'm unable to ping between Router3 s0 and Router 2 s1, ie. 172.17.0.2 and
> 192.169.15.2. This in turn means I cannot ping between 172.17.0.2 and
> 192.169.15.1 (which is Router 1 s1).
>
> Physical connections are as follows:
> Router 3 s0 <> Router 2 s0 (DCE)
> Router 2 s1 <> Router 1 s1 (DCE)
>
> Apologies for the confusion.


After reading Barry's post and this post closer, I realize I previously made
a mistake. I mistaked 192.169. for 192.168 and thought all three interfaces
were on the same subnet. I do see an issue with rip. In the network
statement for rip you have 192.169.0.0. Since 192 is class C, if you had
typed in 192.169.15.0 (which would be correct), it would show in the config
file. If you typed 172.17.15.0 in the config, it would show 172.17.0.0. I
guess what I am trying to say is that rip is configured wrong. You need to
configure Rip on r2 and r1 with a network of 192.169.15.0. If it still
doesn't work check to make sure all interfaces are up/up, then post a show
ip route from each router.

>
>
> "Barry Margolin" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> In article <UhV0d.28112$(E-Mail Removed)>,
>> "Voitec" <(E-Mail Removed)> wrote:
>>
>> > Hi,
>> >
>> > 2nd prob for the day; I'm unable to ping between:
>> > Router 2 s1 <> Router 3 s0

>>
>> Your subject line says the problem is between Router 1 and Router 3, but
>> now you're asking about Router 2 and Router 3. Which is it?
>>
>> >
>> > Can anyone pls correct the following config if necessary? Are all those
>> > items listed below needed or can I get rid of certain items? I'm trying

> to
>> > have as basic a config as necessary for bare connectivity.
>> >
>> > Many thanks,
>> > Voitec
>> >
>> >
>> >
>> > ROUTER 1
>> > *********
>> > !
>> > interface Serial1
>> > ip address 192.169.15.1 255.255.255.0
>> > no ip directed-broadcast
>> > clockrate 64000
>> > !
>> > router rip
>> > network 192.169.0.0

>>
>> Shouldn't this be "network 192.168.15.0", since your interface has a
>> Class C address? Or do you have a 192.169.0.x address on some other
>> interface that you're not showing?
>>
>> > !
>> > no ip classless
>> > ip route 172.17.0.0 255.255.0.0 192.169.15.2
>> > !
>> >
>> >
>> > ROUTER 2
>> > *********
>> > !
>> > interface Serial0
>> > ip address 172.17.0.1 255.255.0.0
>> > no ip route-cache
>> > no ip mroute-cache
>> > clockrate 64000
>> > !
>> > interface Serial1
>> > ip address 192.169.15.2 255.255.255.0
>> > no ip route-cache
>> > no ip mroute-cache
>> > !
>> > router rip
>> > network 172.17.0.0
>> > network 192.169.0.0
>> > !
>> > no ip classless
>> > !
>> >
>> >
>> > ROUTER 3
>> > *********
>> > !
>> > interface Serial0
>> > ip address 172.17.0.2 255.255.0.0
>> > no ip mroute-cache
>> > !
>> > interface Serial1
>> > ip address 192.168.15.3 255.255.255.0
>> > clockrate 64000
>> > !
>> > router rip
>> > network 172.17.0.0
>> > network 192.169.0.0
>> > !
>> > no ip classless
>> > !

>>
>> --
>> Barry Margolin, (E-Mail Removed)
>> Arlington, MA
>> *** PLEASE post questions in newsgroups, not directly to me ***

>
>



 
Reply With Quote
 
mh
Guest
Posts: n/a
 
      09-12-2004
change the network command under the rip routing process for network 192.168.15.0


router rip
no network 192.168.0.0
network 192.168.15.0
exit
 
Reply With Quote
 
Voitec
Guest
Posts: n/a
 
      09-12-2004
That was it! Totally missed the 3rd octet in the 192.169.x.x range when
configuring RIP.
Thanks very much


"PES" <NO*SPAMpestewartREMOVE*(E-Mail Removed)*SUCK S> wrote in message
news:41445764$(E-Mail Removed)...
>
> "Voitec" <(E-Mail Removed)> wrote in message
> news:BZX0d.28491$(E-Mail Removed)...
> > Yes, sorry, just realised the typo.
> >
> > I'm unable to ping between Router3 s0 and Router 2 s1, ie. 172.17.0.2

and
> > 192.169.15.2. This in turn means I cannot ping between 172.17.0.2 and
> > 192.169.15.1 (which is Router 1 s1).
> >
> > Physical connections are as follows:
> > Router 3 s0 <> Router 2 s0 (DCE)
> > Router 2 s1 <> Router 1 s1 (DCE)
> >
> > Apologies for the confusion.

>
> After reading Barry's post and this post closer, I realize I previously

made
> a mistake. I mistaked 192.169. for 192.168 and thought all three

interfaces
> were on the same subnet. I do see an issue with rip. In the network
> statement for rip you have 192.169.0.0. Since 192 is class C, if you had
> typed in 192.169.15.0 (which would be correct), it would show in the

config
> file. If you typed 172.17.15.0 in the config, it would show 172.17.0.0.

I
> guess what I am trying to say is that rip is configured wrong. You need

to
> configure Rip on r2 and r1 with a network of 192.169.15.0. If it still
> doesn't work check to make sure all interfaces are up/up, then post a show
> ip route from each router.
>
> >
> >
> > "Barry Margolin" <(E-Mail Removed)> wrote in message
> > news:(E-Mail Removed)...
> >> In article <UhV0d.28112$(E-Mail Removed)>,
> >> "Voitec" <(E-Mail Removed)> wrote:
> >>
> >> > Hi,
> >> >
> >> > 2nd prob for the day; I'm unable to ping between:
> >> > Router 2 s1 <> Router 3 s0
> >>
> >> Your subject line says the problem is between Router 1 and Router 3,

but
> >> now you're asking about Router 2 and Router 3. Which is it?
> >>
> >> >
> >> > Can anyone pls correct the following config if necessary? Are all

those
> >> > items listed below needed or can I get rid of certain items? I'm

trying
> > to
> >> > have as basic a config as necessary for bare connectivity.
> >> >
> >> > Many thanks,
> >> > Voitec
> >> >
> >> >
> >> >
> >> > ROUTER 1
> >> > *********
> >> > !
> >> > interface Serial1
> >> > ip address 192.169.15.1 255.255.255.0
> >> > no ip directed-broadcast
> >> > clockrate 64000
> >> > !
> >> > router rip
> >> > network 192.169.0.0
> >>
> >> Shouldn't this be "network 192.168.15.0", since your interface has a
> >> Class C address? Or do you have a 192.169.0.x address on some other
> >> interface that you're not showing?
> >>
> >> > !
> >> > no ip classless
> >> > ip route 172.17.0.0 255.255.0.0 192.169.15.2
> >> > !
> >> >
> >> >
> >> > ROUTER 2
> >> > *********
> >> > !
> >> > interface Serial0
> >> > ip address 172.17.0.1 255.255.0.0
> >> > no ip route-cache
> >> > no ip mroute-cache
> >> > clockrate 64000
> >> > !
> >> > interface Serial1
> >> > ip address 192.169.15.2 255.255.255.0
> >> > no ip route-cache
> >> > no ip mroute-cache
> >> > !
> >> > router rip
> >> > network 172.17.0.0
> >> > network 192.169.0.0
> >> > !
> >> > no ip classless
> >> > !
> >> >
> >> >
> >> > ROUTER 3
> >> > *********
> >> > !
> >> > interface Serial0
> >> > ip address 172.17.0.2 255.255.0.0
> >> > no ip mroute-cache
> >> > !
> >> > interface Serial1
> >> > ip address 192.168.15.3 255.255.255.0
> >> > clockrate 64000
> >> > !
> >> > router rip
> >> > network 172.17.0.0
> >> > network 192.169.0.0
> >> > !
> >> > no ip classless
> >> > !
> >>
> >> --
> >> Barry Margolin, (E-Mail Removed)
> >> Arlington, MA
> >> *** PLEASE post questions in newsgroups, not directly to me ***

> >
> >

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can ping from router but unable to ping from client machines verve13 Software 0 09-06-2012 11:25 PM
I can ping the router but router can't ping me superkingkong Cisco 2 04-17-2010 01:59 PM
I do ping others and viceversa but, cannot ping myself jorgeantibes Wireless Networking 0 05-15-2009 11:37 AM
VRRP : I am unable to ping the virtual address, I can only ping thebackup addresses. ATM Cisco 2 11-13-2008 09:50 PM
Setting up a router with 29 Global IPs, BUT can't ping router internal interface from server or server interface from router war_wheelan@yahoo.com Cisco 1 12-14-2005 03:31 PM



Advertisments