Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Python > XEmacs python-mode question

Reply
Thread Tools

XEmacs python-mode question

 
 
Thomas Heller
Guest
Posts: n/a
 
      01-13-2006
I'm trying to customize the python interpreter that is used to execute
my scripts from within WinXP, XEmacs, python-mode version
$Revision4.70$, but cannot get it to work.

The only thing that works is M-x customize-group python, and change the
value of 'Python Command'. However, this changes the interpreter for
all buffers, but I want different buffers use different interpreters.
Is that possible?

What I tried so far:

Insert several variants of '#! py23.cmd' at the top of the buffer - no
effect.

Insert this into the buffer - no effect:
## Local Variables:
## py-python-command: "py23"
## End:

Execute "M-x set-variable py-python-command py23" - no effect.

Can anyone help?

Thomas
 
Reply With Quote
 
 
 
 
skip@pobox.com
Guest
Posts: n/a
 
      01-13-2006

Thomas> I'm trying to customize the python interpreter that is used to
Thomas> execute my scripts from within WinXP, XEmacs, python-mode
Thomas> version $Revision4.70$, but cannot get it to work.

Thomas> The only thing that works is M-x customize-group python, and
Thomas> change the value of 'Python Command'. However, this changes the
Thomas> interpreter for all buffers, but I want different buffers use
Thomas> different interpreters. Is that possible?

Thomas,

py-python-command is not buffer local. Try executing

(make-variable-buffer-local 'py-python-command)

and let me know if that allows your Local Variables setting to work.

Skip
 
Reply With Quote
 
 
 
 
Thomas Heller
Guest
Posts: n/a
 
      01-13-2006
http://www.velocityreviews.com/forums/(E-Mail Removed) writes:

> Thomas> I'm trying to customize the python interpreter that is used to
> Thomas> execute my scripts from within WinXP, XEmacs, python-mode
> Thomas> version $Revision4.70$, but cannot get it to work.
>
> Thomas> The only thing that works is M-x customize-group python, and
> Thomas> change the value of 'Python Command'. However, this changes the
> Thomas> interpreter for all buffers, but I want different buffers use
> Thomas> different interpreters. Is that possible?
>
> Thomas,
>
> py-python-command is not buffer local. Try executing
>
> (make-variable-buffer-local 'py-python-command)
>
> and let me know if that allows your Local Variables setting to work.


No, it doesn't work. The only ugly workaround that I found was to use
py-toggle-shells, and create a jython.bat file which invokes the other
interpreter.

Thomas
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xemacs vhdl-mode.el editing/compiling question bluesforsalvador VHDL 0 06-09-2008 03:03 PM
Unicode table conversion project for XEmacs folks Skip Montanaro Python 0 11-17-2004 03:04 PM
Folding in XEmacs with python mode. Jorge Godoy Python 0 07-25-2004 06:59 PM
XEmacs python mode + WxWindows => Freeze Ian Adams Python 0 04-16-2004 11:02 AM
xemacs jde James David Miller Java 1 10-30-2003 08:57 PM



Advertisments