Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Python > After migrating from debian to ubuntu, tkinter "hello world" doesn't work

Reply
Thread Tools

After migrating from debian to ubuntu, tkinter "hello world" doesn't work

 
 
mortuno@gmail.com
Guest
Posts: n/a
 
      11-28-2005
Hi

My tkinter apps worked fine in debian linux (woody and sarge)
I moved to ubuntu 5.10

I follow the 'hello world' test as seen in
http://wiki.python.org/moin/TkInter


import _tkinter # with underscore, and lowercase 't'
import Tkinter # no underscore, uppercase 'T'
Tkinter._test() # note underscore in _test()

and at the third point I get:

File "/usr/lib/python2.4/lib-tk/Tkinter.py", line 1569, in __init__
self.tk = _tkinter.create(screenName, baseName, className,
interactive, wantobjects, useTk, sync, use)
_tkinter.TclError: this isn't a Tk applicationi


Some posts relate this error to locales, but I didn't change them

locale.getlocale()
('es_ES', 'iso-8859-15')

any help will be appreciated

Miguel

 
Reply With Quote
 
 
 
 
Mandus
Guest
Posts: n/a
 
      11-29-2005
28 Nov 2005 11:02:57 -0800 skrev http://www.velocityreviews.com/forums/(E-Mail Removed):
> Hi
>
> My tkinter apps worked fine in debian linux (woody and sarge)
> I moved to ubuntu 5.10
>
> I follow the 'hello world' test as seen in
> http://wiki.python.org/moin/TkInter
>
>
> import _tkinter # with underscore, and lowercase 't'
> import Tkinter # no underscore, uppercase 'T'
> Tkinter._test() # note underscore in _test()


works just fine on my ubunty 5.10. Make sure you have the python2.4-tk
package installed (sudo apt-get install python2.4-tk).


--
Mandus - the only mandus around.
 
Reply With Quote
 
 
 
 
mortuno@gmail.com
Guest
Posts: n/a
 
      11-30-2005

Mandus ha escrito:

> works just fine on my ubunty 5.10. Make sure you have the python2.4-tk
> package installed (sudo apt-get install python2.4-tk).
>


yes, i got it.
It's a fresh instalation from a cd in a brand new laptop. I tried to
reinstall python2.4-tk and many other packeges

There are two errors
_tkinter.TclError: this isn't a Tk application
invalid color name "#efebe7 "

It is a tk problem. amsn (also based on tk) displays the same error.
Somebody in a post said that
aptitude install xrgb
solved it, but it didn't work for me.

It seems to be a problem of X window.
In a debian box, it works fine. But if I export the display to the
ubuntu
one, get same error. (Other apps export fine)
And even running it in the debian box, with a vnc display in the
ubuntu,
same error! (


>
> --
> Mandus - the only mandus around.


 
Reply With Quote
 
Wade Leftwich
Guest
Posts: n/a
 
      11-30-2005

(E-Mail Removed) wrote:
> Hi
>
> My tkinter apps worked fine in debian linux (woody and sarge)
> I moved to ubuntu 5.10
>
> I follow the 'hello world' test as seen in
> http://wiki.python.org/moin/TkInter
>


Ubuntu uses X.org. Did your Debian distro use xfree86?

 
Reply With Quote
 
Mandus
Guest
Posts: n/a
 
      11-30-2005
30 Nov 2005 04:23:37 -0800 skrev (E-Mail Removed):
>
> Mandus ha escrito:
>
>> works just fine on my ubunty 5.10. Make sure you have the python2.4-tk
>> package installed (sudo apt-get install python2.4-tk).
>>

>
> yes, i got it.
> It's a fresh instalation from a cd in a brand new laptop. I tried to
> reinstall python2.4-tk and many other packeges
>


If you think it may help, I can drop you my complete
'dpkg --get-selections'. Just tell me where you want it.

mvh,
--
Mandus - the only mandus around.
 
Reply With Quote
 
mortuno@gmail.com
Guest
Posts: n/a
 
      12-01-2005
yes, but everybody using ubuntu tells me it works fine for them.
The problem must be something very specific to my laptop and
x window.
I am using need "855resolution" , I'd like to know if it works for
somedy else with ubuntu and 855resolution.

thanks for your interest

 
Reply With Quote
 
mortuno@gmail.com
Guest
Posts: n/a
 
      12-01-2005
thank you very much, but now I don't think it is a problem of
dependencies

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian MySQL Perl DBI - connection terminates unexpectedly after 100 secs. John Perl Misc 10 03-26-2009 03:42 PM
[ANN] Builds of PyWebkitGtk and Webkit-Glib-Gtk(r39359+#16401.master) for Debian i386,Debian AMD64 and Macports MacOSX 10.4 Luke Kenneth Casson Leighton Python 0 12-31-2008 08:23 PM
Ambigous Match Found After Migrating App from VS2003 to 2005 =?Utf-8?B?Q29hY2g=?= ASP .Net 0 06-08-2006 03:33 PM
Rail fails after update of Debian Iwan van der Kleyn Ruby 3 11-29-2004 05:55 PM
[Debian] Upgrading to kernel 2.6 in Debian DUser NZ Computing 0 01-11-2004 12:38 AM



Advertisments