Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Area 0 in OSPF routing protocol ?

Reply
Thread Tools

Area 0 in OSPF routing protocol ?

 
 
Benson
Guest
Posts: n/a
 
      08-17-2004
Hi,

I have a network 10.0.0.0. the area is like the following :

network 10.9.0.0 0.0.255.255 area 9

I want to config an area 0 for the network.

Can I configure like the following :

network 10.9.0.0 0.0.255.255 area 9
network 10.9.252.0 0.0.0.255 area 0

thank you
Benson
 
Reply With Quote
 
 
 
 
Ivan Ostres
Guest
Posts: n/a
 
      08-17-2004
In article <(E-Mail Removed) >,
http://www.velocityreviews.com/forums/(E-Mail Removed) says...
> Hi,
>
> I have a network 10.0.0.0. the area is like the following :
>
> network 10.9.0.0 0.0.255.255 area 9
>
> I want to config an area 0 for the network.
>
> Can I configure like the following :
>
> network 10.9.0.0 0.0.255.255 area 9
> network 10.9.252.0 0.0.0.255 area 0
>
> thank you
> Benson
>


You can get some unexpected results doing that. It looks like it should
work, since network statements should act like access lists (first thing
first). If you want to be sure what you're doing, you can specify the
interfaces themself (with wildcard mask 0.0.0.0).

It might be much easier this way when problems come in and you need to
troubleshoot.

--
-Ivan.

*** Use Rot13 to see my eMail address ***
 
Reply With Quote
 
 
 
 
Vikram
Guest
Posts: n/a
 
      08-17-2004
Ivan Ostres <(E-Mail Removed)> wrote in message news:<(E-Mail Removed) et>...
> In article <(E-Mail Removed) >,
> (E-Mail Removed) says...
> > Hi,
> >
> > I have a network 10.0.0.0. the area is like the following :
> >
> > network 10.9.0.0 0.0.255.255 area 9
> >
> > I want to config an area 0 for the network.
> >
> > Can I configure like the following :
> >
> > network 10.9.0.0 0.0.255.255 area 9
> > network 10.9.252.0 0.0.0.255 area 0
> >
> > thank you
> > Benson
> >

>
> You can get some unexpected results doing that. It looks like it should
> work, since network statements should act like access lists (first thing
> first). If you want to be sure what you're doing, you can specify the
> interfaces themself (with wildcard mask 0.0.0.0).
>
> It might be much easier this way when problems come in and you need to
> troubleshoot.


I believe u cannot have n/w 's

network 10.9.0.0 0.0.255.255 area 9
network 10.9.252.0 0.0.0.255 area 0

defined like the one above, since on u'r Area Boundary Router (for
Area 9) u will need to summarize 10.9.0.0 network and advertise .

Regds,
Vikram
 
Reply With Quote
 
Hansang Bae
Guest
Posts: n/a
 
      08-18-2004
In article <(E-Mail Removed) >,
(E-Mail Removed) says...
> Hi,
>
> I have a network 10.0.0.0. the area is like the following :
>
> network 10.9.0.0 0.0.255.255 area 9
>
> I want to config an area 0 for the network.
>
> Can I configure like the following :
>
> network 10.9.0.0 0.0.255.255 area 9
> network 10.9.252.0 0.0.0.255 area 0


YOu can do the above. But based on your earlier question, you may want
to research what it is you're trying to accomplish. It's quite easy to
break OSPF if you don't design it properly.

--

hsb

"Somehow I imagined this experience would be more rewarding" Calvin
*************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
************************************************** ******************
Due to the volume of email that I receive, I may not not be able to
reply to emails sent to my account. Please post a followup instead.
************************************************** ******************
 
Reply With Quote
 
Hansang Bae
Guest
Posts: n/a
 
      08-18-2004

> > network 10.9.0.0 0.0.255.255 area 9
> > network 10.9.252.0 0.0.0.255 area 0


In article <(E-Mail Removed)>,
(E-Mail Removed) says...
> YOu can do the above. But based on your earlier question, you may want
> to research what it is you're trying to accomplish. It's quite easy to
> break OSPF if you don't design it properly.


Oops.. didn't see the overlapping wildcard mask.

--

hsb

"Somehow I imagined this experience would be more rewarding" Calvin
*************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
************************************************** ******************
Due to the volume of email that I receive, I may not not be able to
reply to emails sent to my account. Please post a followup instead.
************************************************** ******************
 
Reply With Quote
 
Benson
Guest
Posts: n/a
 
      08-18-2004
Hi, Ivan,


Thank you for your help.
Could you please tell me something about the "unexpected result" ?

And show me how to configure the "If you want to be sure what you're
doing, you can specify the interfaces themself (with wildcard mask
0.0.0.0). " ?

Thank you



Ivan Ostres <(E-Mail Removed)> wrote in message news:<(E-Mail Removed) et>...
> In article <(E-Mail Removed) >,
> (E-Mail Removed) says...
> > Hi,
> >
> > I have a network 10.0.0.0. the area is like the following :
> >
> > network 10.9.0.0 0.0.255.255 area 9
> >
> > I want to config an area 0 for the network.
> >
> > Can I configure like the following :
> >
> > network 10.9.0.0 0.0.255.255 area 9
> > network 10.9.252.0 0.0.0.255 area 0
> >
> > thank you
> > Benson
> >

>
> You can get some unexpected results doing that. It looks like it should
> work, since network statements should act like access lists (first thing
> first). If you want to be sure what you're doing, you can specify the
> interfaces themself (with wildcard mask 0.0.0.0).
>
> It might be much easier this way when problems come in and you need to
> troubleshoot.

 
Reply With Quote
 
Ivan Ostres
Guest
Posts: n/a
 
      08-18-2004
In article <(E-Mail Removed) >,
(E-Mail Removed) says...
> Hi, Ivan,
>
>
> Thank you for your help.
> Could you please tell me something about the "unexpected result" ?
>
> And show me how to configure the "If you want to be sure what you're
> doing, you can specify the interfaces themself (with wildcard mask
> 0.0.0.0). " ?
>
>


Let's say you have following interfaces:

int faste 0/1
ip address 10.10.10.1 255.255.255.0

int faste 0/2
ip address 10.11.12.13 255.255.255.0

router ospf 1
network 10.10.10.1 0.0.0.0 area 0
network 10.11.12.13 0.0.0.0 area 9

You don't need to specify networks (in ospf), just interfaces that
participate in OSPF process.


--
-Ivan.

*** Use Rot13 to see my eMail address ***
 
Reply With Quote
 
Hansang Bae
Guest
Posts: n/a
 
      08-19-2004
In article <(E-Mail Removed) >,
(E-Mail Removed) says...
> Hi, Ivan,
>
>
> Thank you for your help.
> Could you please tell me something about the "unexpected result" ?
>
> And show me how to configure the "If you want to be sure what you're
> doing, you can specify the interfaces themself (with wildcard mask
> 0.0.0.0). " ?


Please don't take this the wrong way, but if your company is expecting
you to connect the two companies together, you really should get some
help making this happen.

--

hsb

"Somehow I imagined this experience would be more rewarding" Calvin
*************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
************************************************** ******************
Due to the volume of email that I receive, I may not not be able to
reply to emails sent to my account. Please post a followup instead.
************************************************** ******************
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
basic/weird ospf question- ospf gurus need help!!! k65020@gmail.com Cisco 4 12-13-2007 05:22 PM
OSPF: Is an NSSA required for Internet access just within an area? jimbo Cisco 2 04-25-2005 03:55 PM
Redistribute static to OSPF, overriding the slower OSPF-native route? E.Finlayson Cisco 0 09-10-2004 02:13 PM
Area 0 for SOPF routing protocol ? Benson Cisco 0 08-17-2004 02:30 AM
OSPF Area 0 Benson Cisco 4 06-21-2004 05:55 AM



Advertisments