Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Can't ping local side of GRE tunnel

Reply
Thread Tools

Can't ping local side of GRE tunnel

 
 
Vsevolod Denisenko
Guest
Posts: n/a
 
      07-21-2004
Hi, All!

It looks like a kind of "catch 22".
There is CISCO 2503 with activated eth0 && serial0.
There is tun0 with source interface serial0 from 2503 to other
router 2610. The problem is ping inside 2503 to his local tunnel side when
encapsulation type is set to GRE IP. After changing encapsulation type to IP
IP all pings works fine. But I need exactly GRE encapsulation.
Could you please take a look to my configs and tell me what's wrong?

my-2503#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-IOS56I-L), Version 12.0(28a), RELEASE SOFTWARE
(fc1)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Wed 21-Apr-04 21:14 by cmong
Image text-base: 0x035AA584, data-base: 0x00001000

ROM: System Bootstrap, Version 4.14(9.1), SOFTWARE

my-2503 uptime is 19 hours, 15 minutes
System restarted by reload
System image file is "flash:c2500-ios56i-l.120-28a.bin"

cisco 2500 (68030) processor (revision D) with 16384K/2048K bytes of memory.
Processor board ID 01723534, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
Basic Rate ISDN software, Version 1.1.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

my-2503#


ip subnet-zero
interface Tunnel0
šipšaddressš10.0.0.6š255.255.255.252
šnošipšdirected-broadcast
šipšmtuš1440
šdelayš1000
štunnelšsourcešSerial0
štunnelšdestinationša.b.c.18
štunnelšmodešgrešip
štunnelškeyš100000
!
interface Ethernet0
šipšaddressš192.168.3.34š255.255.255.0
šnošipšdirected-broadcast
!
interface Serial0
šipšaddressšx.y.z.82š255.255.255.252

!
ip classless
ip route 0.0.0.0 0.0.0.0 x.y.z.81
ip route 192.168.2.0 255.255.255.0 Tunnel0
!

access-list 101 permit gre host x.y.z.82 host a.b.c.18
access-list 101 permit ip any any
access-list 101 permit icmp any any

This is pings result from 2503 to it's own tunnel address
with activated GRE IP encapsulation type

my-2503#ping 10.0.0.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.6, timeout is 2 seconds:
......
Success rate is 0 percent (0/5)
my-2503#

This is ping's result when IPIP encapsulation is active:
my-2503#ping 10.0.0.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
my-2503#

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Packet drops on GRE Tunnel LAN side, whereas public IP are fine Addy Cisco 0 03-11-2013 01:58 PM
GRE Tunnel up/up Cannot ping tunnel interface tsvanduyn@yahoo.com Cisco 6 03-09-2006 01:33 AM
Split Tunnel Blocks http through tunnel but passes http around tunnel a.nonny mouse Cisco 2 09-19-2004 12:10 AM
Can't ping local side of GRE tunnel VsevolodV. Denisenko Cisco 0 07-21-2004 01:39 PM
Termination of an IPSec VPN tunnel and a GRE Tunnel on one physical interface. John Ireland Cisco 1 11-11-2003 04:47 PM



Advertisments