Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Python > losing CGI variables in os.environ in Python 2.4

Reply
Thread Tools

losing CGI variables in os.environ in Python 2.4

 
 
jtauber
Guest
Posts: n/a
 
      01-08-2005
Did something change between 2.3 and 2.4 that would affect os.environ
being populated with CGI variables when using the
BaseHTTPServer/CGIHTTPServer?

I received a bug report from someone trying to run my wiki/blog
software, Leonardo[1] under Python 2.4 on Windows 2000. I was able to
reproduce the problem under Python 2.4 on Windows XP Pro but confirmed
that it worked fine under Python 2.3.

Simply printing out os.environ at the point things like PATH_INFO are
extracted by Leonardo revealed that os.environ contained no CGI-related
variables when run under Python 2.4 but did contain them under 2.3

I can't see in the code for the http server modules that anything
changed in this area. Am I missing something?

Thanks in advance.
James Tauber
http://jtauber.com/blog/

[1] http://jtauber.com/leonardo

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regex losing <br> (different from the earlier topic about losing $1) Jason C Perl Misc 4 06-26-2012 10:29 PM
Put variables into member variables or function variables? tjumail@gmail.com C++ 9 03-23-2008 04:03 PM
Losing Drives - Finding Drives - Losing Drives mel@no.spam.com Computer Support 2 09-21-2007 10:16 PM
Python-cgi or Perl-cgi script doubt praba kar Python 1 07-30-2005 08:25 AM
Python CGI - Accepting Input, Invoking Another Process, Ending CGI LarsenMTL Python 4 11-04-2004 05:59 PM



Advertisments