Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > VoiP Vlan help

Reply
Thread Tools

VoiP Vlan help

 
 
bolt thrower
Guest
Posts: n/a
 
      05-22-2004
Greeings all.

I inherited a network which inclues two site using Cisco phones for IP
telephony. Data traffic performance at these sites is dismal -- 3-4mb/ps
perceived on 3550s. Checking the switches' configs, every port is set up
as a trunk port, and every port has a voice vlan configured on it.

I'm thinking that configuring 26 trunk ports on a switch might make its
performance go away. But I'm not a hugely experienced vlan god so I'll
put it to the group.

I am not getting any errors on any ports, I'm just not getting any
performance. I know this isn't configured properly, and I'm on Cisco's
web site as I write this looking for some sample configs.

Still... Does anything jump out at anyone here?

Thanks.

****

Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/5
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/7
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/8
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/9
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/10
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/11
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/12
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/14
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/15
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/16
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/17
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/18
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 106
spanning-tree portfast
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface VLAN1
no ip address
no ip directed-broadcast
no ip route-cache
shutdown
!
interface VLAN100
ip address 192.168.6.6 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 192.168.6.1
!
 
Reply With Quote
 
 
 
 
Fatman Superstar
Guest
Posts: n/a
 
      05-23-2004
What do your f0/... and g0/... 's connect to?


"bolt thrower" <(E-Mail Removed)> wrote in message
news:c8oe0s$eqd$(E-Mail Removed)...
> Greeings all.
>
> I inherited a network which inclues two site using Cisco phones for IP
> telephony. Data traffic performance at these sites is dismal -- 3-4mb/ps
> perceived on 3550s. Checking the switches' configs, every port is set up
> as a trunk port, and every port has a voice vlan configured on it.
>
> I'm thinking that configuring 26 trunk ports on a switch might make its
> performance go away. But I'm not a hugely experienced vlan god so I'll
> put it to the group.
>
> I am not getting any errors on any ports, I'm just not getting any
> performance. I know this isn't configured properly, and I'm on Cisco's
> web site as I write this looking for some sample configs.
>
> Still... Does anything jump out at anyone here?
>
> Thanks.
>
> ****
>
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> no service pad
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> !
> !
> !
> !
> !
> !
> ip subnet-zero
> !
> !
> !
> interface FastEthernet0/1
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/2
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/3
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/4
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/5
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/6
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/7
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/8
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/9
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/10
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/11
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/12
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/13
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/14
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/15
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/16
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/17
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/18
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/19
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/20
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/21
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/22
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/23
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface FastEthernet0/24
> switchport trunk encapsulation dot1q
> switchport mode trunk
> switchport voice vlan 106
> spanning-tree portfast
> !
> interface GigabitEthernet0/1
> switchport trunk encapsulation dot1q
> switchport mode trunk
> !
> interface GigabitEthernet0/2
> switchport trunk encapsulation dot1q
> switchport mode trunk
> !
> interface VLAN1
> no ip address
> no ip directed-broadcast
> no ip route-cache
> shutdown
> !
> interface VLAN100
> ip address 192.168.6.6 255.255.255.0
> no ip directed-broadcast
> no ip route-cache
> !
> ip default-gateway 192.168.6.1
> !



 
Reply With Quote
 
 
 
 
User
Guest
Posts: n/a
 
      05-23-2004
> What do your f0/... and g0/... 's connect to?

FA's connect to 7940s wth PCs on the other end, and the Gig's connect to
other switches. The whole mess is terminated on a 3745.

When I take the phones out of the loop and plug the PCs directly into the
local eth ports on the walls, the network speed blazes. When the phones get
put back inbetween, the network starts puking again.


 
Reply With Quote
 
Majortom
Guest
Posts: n/a
 
      05-25-2004
It may not be a silver bullet, but maybe you could try explicitly telling
the switch to use another vlan for data...we have the following config and
no problems.

interface FastEthernet0/1
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode trunk
switchport voice vlan 20


 
Reply With Quote
 
AnyBody43
Guest
Posts: n/a
 
      05-26-2004
"Majortom" <(E-Mail Removed)> wrote in message news:<__Qsc.32436$(E-Mail Removed) m>...
> It may not be a silver bullet, but maybe you could try explicitly telling
> the switch to use another vlan for data...we have the following config and
> no problems.
>
> interface FastEthernet0/1
> switchport access vlan 2
> switchport trunk encapsulation dot1q
> switchport trunk native vlan 2
> switchport mode trunk
> switchport voice vlan 20


How about the phones are somehow or other forcing the link to be 10M?
 
Reply With Quote
 
sherryeis sherryeis is offline
Junior Member
Join Date: Feb 2008
Posts: 1
 
      02-16-2008
Have you tried removing
spanning tree portfast


from the ports with both a telephone and data

Normally you would only enable spanning tree portfast on a port with a
SINGLE Host..
You now have one Telephone IP and MAC and One Data IP and MAC on the same port (two hosts). The Telephone has a mini hub in it.
 
Reply With Quote
 
vash vash is offline
Junior Member
Join Date: Apr 2008
Posts: 1
 
      04-23-2008
Take the trunk commands off the non-uplink ports and set them to switchport access. And, either let your data traffic go untagged as it currently is or setup another vlan for data. I don't believe trunking is the preferred method anymore on access ports as it can lead to high cpu utilization.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VLAN or Not to VLAN Paul Cisco 0 10-27-2003 06:16 PM



Advertisments