Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Cisco DHCP Problems

Reply
Thread Tools

Cisco DHCP Problems

 
 
Aaron Taylor
Guest
Posts: n/a
 
      05-12-2004
Hi All,

I've got a problem with DHCP on a 7206. It's got multiple interfaces and
two DHCP pools to serve out to clients.

The problem is that client on the 192.168.0.x interface are receiving
DHCP addresses of 192.168.0.x and 192.168.2.x. Also, clients on the
192.168.2.x interface are receiving addresses in both subnets. How do I
make it so that clients on one interface only receive addresses that are
in the subnet they reside in?

Thanks,
-Aaron Taylor

Here is the config:

Current configuration : 3370 bytes
!
! Last configuration change at 11:16:44 PDT Tue May 11 2004 by xxxx
! NVRAM config last updated at 15:29:36 PDT Fri Apr 30 2004 by xxxx
!
version 12.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
service linenumber
!
hostname xxxx
!
aaa new-model
aaa authentication banner ^CMain xxxx Router - Unauthorized Access
Prohibited^C
aaa authentication fail-message ^CFailed login. Try again.^C
aaa authentication login default local-case
enable secret x xxxxxxxxxxxxxx
enable password x xxxxxxxxxxxxxxxx
!
username ataylor password x xxxxxxxxxxxxxxxx
username gregb password x xxxxxxxxxxxxxx
username cloper password x xxxxxxxxxxxxxx
clock timezone PST -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
no ip source-route
!
!
ip domain-name crowncollege.edu
ip name-server x.x.x.x
ip name-server x.x.x.x
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.2.0 192.168.2.15
ip dhcp excluded-address 192.168.0.16 192.168.0.255
!
ip dhcp pool crowncollege
network 192.168.2.0 255.255.255.0
domain-name crowncollege.edu
dns-server x.x.x.x x.x.x.x x.x.x.x
default-router 192.168.2.1
lease 0 1
!
ip dhcp pool crowncollege-tech
network 192.168.0.0 255.255.255.0
domain-name crowncollege.edu
dns-server x.x.x.x x.x.x.x x.x.x.x
default-router 192.168.0.1
lease 0 1
!
ip cef
ip audit notify log
ip audit po max-events 100
ip ssh time-out 20
ip ssh authentication-retries 2
prompt %h:%n%p
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Serial1/0
description *Connection to xxxx -- Outside Interface*
ip address x.x.x.x 255.255.255.252
ip nat outside
encapsulation ppp
no ip mroute-cache
framing c-bit
cablelength 10
dsu bandwidth 44210
serial restart-delay 0
!
interface Serial2/0
no ip address
no ip mroute-cache
shutdown
framing c-bit
cablelength 10
dsu bandwidth 44210
serial restart-delay 0
!
interface Serial2/1
no ip address
no ip mroute-cache
shutdown
framing c-bit
cablelength 10
dsu bandwidth 44210
serial restart-delay 0
!
interface FastEthernet3/0
ip address x.x.x.x 255.255.254.0
no ip mroute-cache
duplex full
ntp broadcast
no mop enabled
!
interface FastEthernet4/0
ip address 192.168.0.1 255.255.255.0
ip nat inside
no ip mroute-cache
duplex full
ntp broadcast
!
interface FastEthernet5/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
no ip mroute-cache
shutdown
duplex full
ntp broadcast
!
interface FastEthernet6/0
ip address 192.168.2.1 255.255.255.0
ip nat inside
no ip mroute-cache
duplex full
ntp broadcast
!
ip nat pool overload x.x.x.x x.x.x.x netmask 255.255.255.252
ip nat inside source list 7 pool overload overload
ip classless
ip route profile
ip route 0.0.0.0 0.0.0.0 66.236.9.29
no ip http server
!
access-list 7 permit any
access-list 10 permit any
access-list 98 permit any
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
location DownstairsServerRoom
exec-timeout 30 0
line aux 0
line vty 0 4
access-class 10 in
exec-timeout 30 0
password 7 045F28220C256E4A
transport preferred ssh
transport input ssh
transport output ssh
!
ntp clock-period 17179867
ntp access-group peer 98
ntp master 4
ntp update-calendar
ntp server 204.87.183.6
end
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help setting up a wireless DHCP behind a wired non-DHCP network? sonicgravy Hardware 0 11-13-2006 07:45 PM
Dhcp Relay Agent And Acl On Sw 3750, DHCP Relay Agent and ACL on Sw 3750 Vimokh Cisco 3 09-06-2006 02:16 AM
Wireless DHCP clients cannot obtain an IP address from the DHCP se =?Utf-8?B?SGVpbkQ=?= Wireless Networking 0 01-08-2006 03:41 PM
run > ipconfig > net stop dhcp then > net start dhcp Fayza Computer Support 3 05-12-2004 07:10 PM
if Active Directory no DHCP? or: Where ist my DHCP Ingo Hauf Computer Support 2 10-18-2003 02:25 PM



Advertisments