Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > 3550 routing

Reply
Thread Tools

3550 routing

 
 
Jo Knight
Guest
Posts: n/a
 
      05-08-2004
Hi,

Would someone be so kind as to look at the configuration below and tell me
why I cannot route between VLAN's on my 3550. I have enabled ip routing and
rip, but I still cannot ping or connect across the VLAN's.

Many thanks,

Jo

-------------------------START CONFIG----------------------

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname HC_CORE_2

!

enable secret 5 $1$qZkH$dBbMbdhIz14oUTs2xZzvv1

!

ip subnet-zero

ip routing

!

no ip domain-lookup

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

interface FastEthernet0/1

no switchport

no ip address

!

interface FastEthernet0/4

switchport access vlan 192

switchport mode dynamic desirable

no ip address

!

interface FastEthernet0/24

switchport access vlan 22

switchport mode dynamic desirable

no ip address

interface Vlan1

no ip address

shutdown

!

interface Vlan22

ip address 192.168.22.250 255.255.255.0

!

interface Vlan192

ip address 192.168.1.1 255.255.255.0

!

router rip

network 192.168.1.0

network 192.168.22.0

!

ip default-gateway 192.168.22.4

no ip classless

no ip http server

!

end


 
Reply With Quote
 
 
 
 
Steinar Haug
Guest
Posts: n/a
 
      05-08-2004
["Jo Knight"]

| Would someone be so kind as to look at the configuration below and tell me
| why I cannot route between VLAN's on my 3550. I have enabled ip routing and
| rip, but I still cannot ping or connect across the VLAN's.

Why on earth do you have "no ip classless"?

Also, you don't need "router rip" for the 3550 to perform routing.

Steinar Haug, Nethelp consulting, http://www.velocityreviews.com/forums/(E-Mail Removed)
 
Reply With Quote
 
 
 
 
Jo Knight
Guest
Posts: n/a
 
      05-08-2004
So are you saying take out no ip classless and remove rip and it will work?


"Steinar Haug" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> ["Jo Knight"]
>
> | Would someone be so kind as to look at the configuration below and

tell me
> | why I cannot route between VLAN's on my 3550. I have enabled ip

routing and
> | rip, but I still cannot ping or connect across the VLAN's.
>
> Why on earth do you have "no ip classless"?
>
> Also, you don't need "router rip" for the 3550 to perform routing.
>
> Steinar Haug, Nethelp consulting, (E-Mail Removed)



 
Reply With Quote
 
Steinar Haug
Guest
Posts: n/a
 
      05-08-2004
["Jo Knight"]

| So are you saying take out no ip classless and remove rip and it will work?

Whether you need to run RIP depends on *other factors*, for instance
whether this switch needs to propagate routing information to and from
other routers. It is completely irrelevant for routing between two SVIs
(two VLAN interfaces) on the same switch.

I would take out the "no ip classless", and also verify that your two
VLANs 22 and 192 have indeed been created.

Steinar Haug, Nethelp consulting, (E-Mail Removed)


|
|
| "Steinar Haug" <(E-Mail Removed)> wrote in message
| news:(E-Mail Removed)...
| > ["Jo Knight"]
| >
| > | Would someone be so kind as to look at the configuration below and
| tell me
| > | why I cannot route between VLAN's on my 3550. I have enabled ip
| routing and
| > | rip, but I still cannot ping or connect across the VLAN's.
| >
| > Why on earth do you have "no ip classless"?
| >
| > Also, you don't need "router rip" for the 3550 to perform routing.
| >
| > Steinar Haug, Nethelp consulting, (E-Mail Removed)
|
|
 
Reply With Quote
 
Jo Knight
Guest
Posts: n/a
 
      05-08-2004
"Steinar Haug" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...

> I would take out the "no ip classless", and also verify that your two
> VLANs 22 and 192 have indeed been created.


I will give it a try.

One thing I didnt mention I have the SMI version, routing is enabled in this
version isnt it?


 
Reply With Quote
 
Matthew Melbourne
Guest
Posts: n/a
 
      05-08-2004
In article <zB5nc.14743$(E-Mail Removed)>, Jo Knight
<(E-Mail Removed)> wrote:
> "Steinar Haug" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>
> > I would take out the "no ip classless", and also verify that your two
> > VLANs 22 and 192 have indeed been created.

>
> I will give it a try.
>
> One thing I didnt mention I have the SMI version, routing is enabled in
> this version isnt it?


Basic routing (static and RIP) is available in the SMI image from IOS
release 12.1(11)EA1. Images earlier than this require an EMI image for
basic routing.

Cheers,

Matt

--
Matthew Melbourne
 
Reply With Quote
 
mh
Guest
Posts: n/a
 
      05-08-2004
Did you add the vlan to the vlan database?

conf t
vlan database
vlan 22
vlan 192
apply
exit


What do the following commands display:

sh vlan

sh ip int brief

sh ip route

sh arp


Can you ping from within the switch to devices on subnet 192.168.1.0
or subnet 192.168.22.0 ?
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
integrating new 3550 with routing into existing routing structure? joeblow Cisco 3 03-14-2005 08:50 AM
Routing between Vlans on Cisco 3550 : Help Needed. Ori Cisco 12 12-04-2003 11:16 AM
Re: Differences between 3550-24-SMI and 3550-24-EMI Steinar Haug Cisco 0 10-20-2003 02:59 PM
Differences between 3550-24-SMI and 3550-24-EMI JohnNews Cisco 10 10-20-2003 12:33 PM
Catalyst 3550 EMI Upgrade Kit (CD-3550-EMI=) problem! show version = SMI desdronox Cisco 1 07-10-2003 02:08 AM



Advertisments