Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > RIP v.2 authentication

Reply
Thread Tools

RIP v.2 authentication

 
 
virgil
Guest
Posts: n/a
 
      02-24-2004
Alright, who can help with this?

There seems to be a bug with RIP / md5 authentication on Cisco routers
and especially between cisco routers and a cisco pix firewall in which,
once the authentication is configured, routes are not passed between the
pix and the router.

Performing a debug yields (invalid authentication) on the router and no
matter how it is reconfigured, rebooted, etc. the authentication will not
work.

But it is intermittent - some times the config does work.

I did see a post a while back in which a person stated that the proper
way to do the configuration was as follows:

1st - configure rip version 2 on router
2nd - configure md5 authentication on the interface(s)
3rd - configure the key chain used by rip
4th - configure the pix

I did this one night when I was having the problem and it seemed to work;
however, if the router is rebooted, you have no way of knowing what order
that is going to become active in. Upon my reboot, the config that had
been working stopped.

This is not IOS specific. I have had it happen in my lab, in a lab at
work and on the Cisco CCIE lab. If anyone can give any advice or more
specifically, links to resources discussing this issue, I would greatly
appreciate it.

Thanks

--
Vik
Network Engineer
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
converting accuset 1200 HW rip to software rip Wendell Computer Support 0 06-05-2004 07:32 PM
automatic default route propagation into RIP: default metric Ben Low Cisco 2 12-28-2003 03:57 AM
PPTP with MPPE & RIP not working between Cisco4500 & WinXP native VPN Pedro Ribeiro Cisco 0 12-14-2003 10:36 AM
Converting from RIP to EIGRP - netware issue Mark Smythe Cisco 3 11-29-2003 01:40 AM
ipx rip bug or not? Ivan Ostres Cisco 0 10-22-2003 01:02 PM



Advertisments