Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Python > Problem installing ppgplot

Reply
Thread Tools

Problem installing ppgplot

 
 
Enno Middelberg
Guest
Posts: n/a
 
      08-20-2003
Hi,

I want to install pgplot but I can't really get it to work. Here is
what I did; pgplot libraries are installed in ~/pgplot

-downloaded ppgplot-1.1.tar.gz from
http://www.astro.rug.nl/~breddels/python/ppgplot/

-PGPLOT_DIR was set correctly, so I tried python setup.py install, but
that stopped saying

-------------------------------------------------------------
gcc -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -fPIC
-I/homes/emiddelb/local2/include/python2.2/Numeric
-I/homes/emiddelb/local2/include/python2.2 -c ppgplot.c -o
build/temp.linux-i686-2.2/ppgplot.o

ppgplot.c:21: cpgplot.h: No such file or directory
-------------------------------------------------------------

-I found a website describing that error
(http://www.astro.rub.de/laboca/downl..._for_boa.html). I
copied cpgplot.h to my local include dir as I don't have root
permissions and re-ran the install script. Apparently, the gcc command
now worked, but another one now crashed:

-------------------------------------------------------------
gcc -shared build/temp.linux-i686-2.2/ppgplot.o -L/usr/X11R6/lib/
-L/homes/emiddelb/pgplot -L/usr/X11R6/lib/ -lcpgplot -lpgplot -lX11
-lm -lg2c -o build/lib.linux-i686-2.2/ppgplot.so

/usr/i486-linux/bin/ld: cannot open -lcpgplot: No such file or
directory
collect2: ld returned 1 exit status
-------------------------------------------------------------

I had the suspicion that the "-lcpgplot" was not correct, as the
pgplot distribution does not contain any other files named cpgplot.*
except for cpgplot.h and a cpgplot.c demonstration file.

I therefore tried to run the gcc command without "-lcpgplot" and got a
file called "ppgplot.so" in the "build/lib.linux-i686-2.2/"
subdirectory. I copied that file to
~/lib/python2.2/site-packages/ppgplot/ppgplot.so, i.e., to a directory
similar to all the other local packages, but now when I try to use it,
I get an error saying "ImportError: No module named ppgplot".

I still suspect that the installation is incomplete because all the
other packages have at least some python files.

Can someone give me a hint on how to fix this? I'm not a great
programmer and I do not know much of libraries and those things, I
just want to _use_ ppgplot :-/


Cheers,

Enno
 
Reply With Quote
 
 
 
 
A.M. Kuchling
Guest
Posts: n/a
 
      08-20-2003
On 20 Aug 2003 12:07:06 GMT,
Enno Middelberg <(E-Mail Removed)> wrote:
> I had the suspicion that the "-lcpgplot" was not correct, as the
> pgplot distribution does not contain any other files named cpgplot.*
> except for cpgplot.h and a cpgplot.c demonstration file.


The correct file to look for is libcpgplot.a.

--amk
 
Reply With Quote
 
 
 
 
A.M. Kuchling
Guest
Posts: n/a
 
      08-20-2003
On 20 Aug 2003 12:38:08 GMT,
> copying build/lib.linux-i686-2.2/ppgplot.so ->
> /homes/emiddelb/local2/lib/python2.2/site-packages


Hm. Is the /homes/emiddelb/... directory in Python's path? You can check
by doing "import sys ; print sys.path".

If the directory isn't in sys.path, you can add it by either setting the
PYTHONPATH environment variable before running Python, or by modifying
sys.path; it's just a list of strings, so you can do
sys.path.append('/homes/....').

If it *is* on the path, then I'm puzzled. Running 'python -v' will cause
Python to print out each filename it tries; maybe the file has strange
permissions or something.

--amk
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing wireless USB Adapter =?Utf-8?B?cmZz?= Wireless Networking 2 07-10-2005 05:58 AM
Problem installing wireless card w/ Windows =?Utf-8?B?UmFuZGFsbA==?= Wireless Networking 0 03-28-2005 09:55 PM
Problem installing modules on redhat 9 - strange connection problem championsleeper Perl Misc 0 01-26-2005 12:19 PM
Problem w/ Windows 98SE installing 802.11g router Wireless Networking 3 01-21-2005 01:08 AM
installing ppgplot (using OS X 10.3 / gcc 3.4 / python 2.3b) Dennis Hore Python 2 11-07-2004 10:59 PM



Advertisments