Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Python > Unable to run IDLE from 2.3?

Reply
Thread Tools

Unable to run IDLE from 2.3?

 
 
M Wells
Guest
Posts: n/a
 
      08-05-2003
Hi all,

I recently downloaded and installed Python 2.3 for Windows (on XP
professional) and I don't seem to be able to run IDLE from my start
menu? It seems something happens when I click on it (ie I get an
hourglass) but no actual application turns up.

Has anyone else experienced this and can anyone give me some advice on
how to fix it?

Much warmth,

Murray
http://www.planetthoughtful.org
Building a thoughtful planet,
one snide comment at a time...
 
Reply With Quote
 
 
 
 
Bernard Delmée
Guest
Posts: n/a
 
      08-05-2003
> Has anyone else experienced this and can anyone give me some advice on
> how to fix it?


Works for me, on Win2000. I've never used XP, but I'd suggest:

*) opening a command-prompt box
*) cd'ing to %PYTHON_HOME%\lib\idlelib
(where PYTHON_HOME=C:\python23 unless changed at install time)
*) ..\..\python idle.py

watch out for error messages, and let us know...



 
Reply With Quote
 
 
 
 
Alex Martelli
Guest
Posts: n/a
 
      08-05-2003
<posted & mailed>

M Wells wrote:

> I recently downloaded and installed Python 2.3 for Windows (on XP
> professional) and I don't seem to be able to run IDLE from my start
> menu? It seems something happens when I click on it (ie I get an
> hourglass) but no actual application turns up.
>
> Has anyone else experienced this and can anyone give me some advice on
> how to fix it?


There are two known causes for this bug:

-- you installed Python in a directory with a space in its path

Workaround: uninstall it, install it again in a directory with
no spaces in its path, e.g. its default C:\Python23

-- you are running a "personal firewall" that is set to inhibit
connections to host 127.0.0.1

Workaround: remove your "personal firewall" or at least reprogram
it so that connections to 127.0.0.1 are allowed; 127.0.0.1 in
TCP/IP means "this very host, me, myself" and therefore there is
no way in which connections to this address can put you at risk.

IDLE 1.0 uses sockets for communication between the 'main' process
and a secondary process that's set up to run code being developed,
and some misprogrammed 'personal firewalls' are known to interfere
with this. In theory, it is conceivable that a bad installation
of "networking" on some Windows machine might cause the same
effect as a misconfigured 'personal firewall', but so far in each
case I've analyzed it did boil down to 'personal firewalls'.


It's not necessarily the case that your troubles come from either
of these known causes, but please check both of them -- if it's
something else again, we'll need to root around for it.


Alex

 
Reply With Quote
 
Kendall Clark
Guest
Posts: n/a
 
      08-05-2003
On Tue, Aug 05, 2003 at 03:14:22PM -0400, Tim Peters wrote:
> In addition to the two possible causes Alex spelled out, another common
> problem is some *other* program setting up Tcl or Tk environment variables
> pointing to an inappropriate version of Tcl/Tk. The installer for Ruby is
> the most common culprit for this problem, so if you've installed Ruby that's
> probably the cause.


I'm battling what seems to be a related issue on RH 9 (accursed Red Hat!). I
installed 2.3 from src tarball last week, and it worked fine. The new Idle
is very sexy. Yay, idle.

Then last night I decided to upgrade from RH 8 to RH 9 (accursed Red Hat!).
That was a disaster on many fronts (it's not a good thing to have corrup CD
media on the 3rd disc of a KRUD update...argh!), but it also totally trashed
my 2.3's _tkinter.so. Now when I try to rebuild 2.3 from src, I can't seem
to get a _tkinter.so which points to valid tcl & tk libraries (despite using
"--with-libs="" to point to the libtcl & libtk RH 9 installed).

(The extent of my dynamic library fu on Linux is to futz around with
symlinks from the places where _tkinter.so wants to find tcl/tk libs to the
places where they actually are on my RH 9 (accursed Red Hat!) system, then
to rerun /sbin/ldconfig. This "trick" didn't work either.)

So I decided that RH is completely evil (accursed Red Hat!), and I would
just install Tk & Tcl from scratch in /usr/local/lib and rebuild 2.3 using
those libs, like this:

./configure --with-libs="/usr/local/lib/libtcl8.4.so \
/usr/local/lib/libtk8.4.so"

This works, but goddam what a pain in my ass...In case it's now clear by
now: I hate Red Hat (though hitting back at SCO is pretty cool, trying to
keep up with Python on a RH box has been way too painful for far too long).

I recommend repeated playings, at max volume, of Bob Dylan's "Idiot Wind" if
you have to fight this battle -- it seemed to help my mood.

Kendall Clark
--
Jazz is only what you are. -- Louis Armstrong

 
Reply With Quote
 
Paul Moore
Guest
Posts: n/a
 
      08-05-2003
M Wells <(E-Mail Removed)> writes:

> I recently downloaded and installed Python 2.3 for Windows (on XP
> professional) and I don't seem to be able to run IDLE from my start
> menu? It seems something happens when I click on it (ie I get an
> hourglass) but no actual application turns up.
>
> Has anyone else experienced this and can anyone give me some advice on
> how to fix it?


Do you have any form of "personal firewall" software? There is a known
issue when Idle is used with a (misconfigured) firewall. The problem
is that Idle relies on an internal socket connection. If the firewall
is set to block that socket, Idle won't start. There should be no need
to block traffic to IP address 127.0.0.1 (the local machine) so the
firewall settings should be changed to allow this.

For a better explanation, see http://www.python.org/2.3/bugs.html

Hope this helps,
Paul.
--
This signature intentionally left blank
 
Reply With Quote
 
Bernard Delmée
Guest
Posts: n/a
 
      08-05-2003
> It appears the fact that I also have ruby installed is causing the
> problem? Should I uninstall ruby, do you think, and try re-installing
> python? I'd prefer to have access to both of them, but Python is the
> language I want to concentrate on at present.


I seem to recall ruby defines tcl/tk related environment variables
which may interfere with python. If you are not using ruby-tk,
I don't think you need to de-install but merely un-defining those
variables should correct the situation. I think that's what I did
long ago so I don't see those variable names myself, and can't
be more specific....

HTH,

Bernard.



 
Reply With Quote
 
M Wells
Guest
Posts: n/a
 
      08-06-2003
On Tue, 5 Aug 2003 22:08:02 +0200, "Bernard Delmée"
<(E-Mail Removed)> wrote:

>I seem to recall ruby defines tcl/tk related environment variables
>which may interfere with python. If you are not using ruby-tk,
>I don't think you need to de-install but merely un-defining those
>variables should correct the situation. I think that's what I did
>long ago so I don't see those variable names myself, and can't
>be more specific....


Hi Bernard,

Worked perfectly!

Removed the ruby variables and now IDLE is running! Thank you to you
(and also to the others that replied) for your help!

Much warmth,

Murray
http://www.planetthoughtful.org
Building a thoughtful planet,
one snide comment at a time...
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to bring up b-channel after idle anadev Cisco 4 06-30-2009 06:19 AM
unable to connect after idle on 1841 anadev@yahoo.com Cisco 0 04-09-2007 03:02 AM
Unable to validate data after idle Solje ASP .Net 6 03-20-2007 03:16 PM
Unable to run IDLE Under Windows Jonathan Polley Python 8 03-07-2005 02:04 PM
Python Program runs but itself but does not run under IDLE Ollie Python 0 10-02-2003 04:05 PM



Advertisments