Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > No link with Cisco 828 and new dslam

Reply
Thread Tools

No link with Cisco 828 and new dslam

 
 
Miika Pekkarinen
Guest
Posts: n/a
 
      07-22-2006
Hi

So our ISP upgraded some hardware and new dslam (probably some Siemens
system) and now Cisco 828 is unable to establish a link between that new
hardware. I have taken some debug logging from the router, and it seems
that Cisco gets the link for about a second or two, but after that the
dslam immediately drops the link. Before the upgrade everything was working
fine, and it would be great if I could get that Cisco router working again.
Would it be possible to upgrade the IOS with a newer version that could
solve the issue? Current version is:

IOS (tm) C828 Software (C828-Y6-M), Version 12.2(1)XE2, EARLY DEPLOYMENT
RELEASE SOFTWARE (fc1)
Synched to technology version 12.2(0.11)T

System image file is "flash:c828-y6-mz.122-1.XE2.bin"

CISCO C828 (MPC855T) processor (revision 0x201) with 31744K/1024K bytes of
memory.
Processor board ID JAD062106H0 (1489037529), with hardware revision 0000
CPU rev number 5

The debug log can be found here:
http://ihme.org/~miipekk/cisco.txt

The interface section in the config file looks like this (I have tried many
different settings with same success):

interface ATM0
ip address x.x.x.x x.x.x.x
no atm ilmi-keepalive
pvc 0/100
encapsulation aal5snap
!
dsl equipment-type CPE
dsl operating-mode GSHDSL symmetric annex B
dsl linerate 2312
!

Lets hope there is something to do

Regards,
--
Miika Pekkarinen <(E-Mail Removed)>



 
Reply With Quote
 
 
 
 
Merv
Guest
Posts: n/a
 
      07-22-2006

did you try linerate auto ?

 
Reply With Quote
 
 
 
 
Miika Pekkarinen
Guest
Posts: n/a
 
      07-22-2006
Merv wrote:
> did you try linerate auto ?


Yes, I tried that also but with the same results. Modem establishes a link
and even receives a few packets but suddenly (in 1s or so) the link drops
and all link leds go off.

--
Miika Pekkarinen <(E-Mail Removed)>

 
Reply With Quote
 
www.BradReese.Com
Guest
Posts: n/a
 
      07-22-2006
Hi Miika,

Could it be a a problem with max packet size ( i.e. receives a few
packets before dropping ) ?

Sincerely,

Brad Reese
BradReese.Com - Cisco Jobs
http://www.bradreese.com/hot-jobs.htm
1293 Hendersonville Road, Suite 17
Asheville, North Carolina USA 28803
USA & Canada: 877-549-2680
International: 828-277-7272
Fax: 775-254-3558
AIM: R2MGrant
BradReese.Com - Cisco Resumes
http://www.bradreese.com/cisco-resumes.htm

 
Reply With Quote
 
anybody43@hotmail.com
Guest
Posts: n/a
 
      07-23-2006

Miika Pekkarinen wrote:
> Merv wrote:
> > did you try linerate auto ?

>
> Yes, I tried that also but with the same results. Modem establishes a link
> and even receives a few packets but suddenly (in 1s or so) the link drops
> and all link leds go off.

There seem to me to be a few possibilities.

1.
There is a low level dsl issue.
Solution - upgrage IOS

2.
The ISP no longer supports your settings but they did before
the change.

3.
The DSL level is OK however a higher level protocol at the ISP
end is getting upset at you and is tearing down the connection.

I have posted what we use in the UK for SDSL Internet.
This is an 878.

controller DSL 0
mode atm
line-term cpe
line-mode 2-wire line-zero
dsl-mode shdsl symmetric annex B
line-rate auto

interface ATM0
no ip address
ip virtual-reassembly
atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1

interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname xxxx
ppp chap password 7 xxxxx
ppp ipcp dns request
crypto map xxx

ip route 0.0.0.0 0.0.0.0 Dialer0


I have just noticed that there is no dialer-list
on this router but it is working???

Please post the outcome.

 
Reply With Quote
 
Miika Pekkarinen
Guest
Posts: n/a
 
      07-23-2006
Thanks for the replies.

http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> There seem to me to be a few possibilities.
>
> 1.
> There is a low level dsl issue.
> Solution - upgrage IOS


This seems to be the more likely issue as I have tried everything now I can
think about. Then the only problem would be how to get a new IOS as I don't
have any service contract with Cisco. I will try to contact them by email
to see if they could provide the IOS.

> 2.
> The ISP no longer supports your settings but they did before
> the change.


They did small changes but that doesn't seem to be the issue because ZyXEL
modem can establish a link even with incorrect settings but it has other
more serious issues which Cisco didn't have (for example halting data
connection for a few minutes several times a day and even the whole device
crashes and reboots once for a while).

> 3.
> The DSL level is OK however a higher level protocol at the ISP
> end is getting upset at you and is tearing down the connection.


If I have understood correctly, the link should stay up even with minimal
configuration (only ATM interface configured with correct DSL parameters).
It worked before but wont no longer.

> I have just noticed that there is no dialer-list
> on this router but it is working???


This shouldn't be an issue as our ISP doesn't use PPP. It uses RFC1483
AAL5/LLC encapsulation that I have also enabled on the PVC.

Lets hope this great device still works one day again

--
Miika Pekkarinen <(E-Mail Removed)>



 
Reply With Quote
 
www.BradReese.Com
Guest
Posts: n/a
 
      07-23-2006
Hi Miika,

Your Cisco Systems Contact Information:

Suomi Website:

http://www.cisco.com/global/FI/index.shtml

Cisco Sales Office:

http://www.cisco.com/ciscodotcom/too...s/finland.html

Cisco TAC Contact:

http://www.bradreese.com/cisco-tac-c...ide.htm#EUROPE

Hope this helps.

Brad Reese
BradReese.Com - Global Cisco Systems Pre-Sales Support
http://www.bradreese.com/contact-us.htm#GLOBAL

 
Reply With Quote
 
Miika Pekkarinen
Guest
Posts: n/a
 
      07-23-2006
www.BradReese.Com wrote:
> Your Cisco Systems Contact Information:


Hi Brad,

Thanks for the information. I will try to contact Cisco tomorrow.

--
Miika Pekkarinen <(E-Mail Removed)>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hooking Cisco Router to AFC DSL DSLAM Matt Cisco 4 06-16-2005 09:16 PM
show logging in DSLAM Cisco 6260 Joxelito Cisco 3 05-13-2005 07:59 PM
G.SHDSL 828-to-828 Lars L. Christensen Cisco 2 12-17-2004 03:40 PM
Help with a Cisco 6100 DSLAM BikeZilla Cisco 0 08-13-2004 07:38 PM
Cisco 6200 DSLAM Question Matthew M. Gamble Cisco 0 11-27-2003 12:59 AM



Advertisments