Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Address Aging Issue

Reply
Thread Tools

Address Aging Issue

 
 
Dan
Guest
Posts: n/a
 
      01-21-2004
Is anyone familiar with the address aging issue between a Catalyst 1900
and a Catalyst 2900. Specifically, if a laptop is disconnected for a
1900 port to a 2900, the use can't login to the network. The work
around is too go into the 1900's Address Aging field and change it from
18000 to 300 and the wait 5 minutes and laptop can connect. Then change
the aging back to 18000. Here is what firmware/ios is running:

1900 Firmware v 7.02

2900 V 11.2(8.6)sa6

Is there a way to fix this issue as it is very annoying.

TIA, Dan
 
Reply With Quote
 
 
 
 
Christoph Gartmann
Guest
Posts: n/a
 
      01-21-2004
In article <(E-Mail Removed)>, Dan <(E-Mail Removed)> writes:
>Is anyone familiar with the address aging issue between a Catalyst 1900
>and a Catalyst 2900. Specifically, if a laptop is disconnected for a
>1900 port to a 2900, the use can't login to the network. The work
>around is too go into the 1900's Address Aging field and change it from
>18000 to 300 and the wait 5 minutes and laptop can connect. Then change
>the aging back to 18000. Here is what firmware/ios is running:
>
> 1900 Firmware v 7.02
>
> 2900 V 11.2(8.6)sa6
>
>Is there a way to fix this issue as it is very annoying.


Why do you change the aging time back? The important thing is to have the same
aging time on all your switches in the network. 18000 seems a bit too high for
me. I would suggest something like 30 minutes.

Regards,
Christoph Gartmann

--
Max-Planck-Institut fuer Phone : +49-761-5108-464 Fax: -452
Immunbiologie
Postfach 1169 Internet: gartmann@immunbio dot mpg dot de
D-79011 Freiburg, Germany
http://www.immunbio.mpg.de/home/menue.html
 
Reply With Quote
 
 
 
 
Dan
Guest
Posts: n/a
 
      01-22-2004
On 1/21/2004 2:41 AM, Christoph Gartmann wrote:
> In article <(E-Mail Removed)>, Dan <(E-Mail Removed)> writes:
>
>>Is anyone familiar with the address aging issue between a Catalyst 1900
>>and a Catalyst 2900. Specifically, if a laptop is disconnected for a
>>1900 port to a 2900, the use can't login to the network. The work
>>around is too go into the 1900's Address Aging field and change it from
>>18000 to 300 and the wait 5 minutes and laptop can connect. Then change
>>the aging back to 18000. Here is what firmware/ios is running:
>>
>> 1900 Firmware v 7.02
>>
>> 2900 V 11.2(8.6)sa6
>>
>>Is there a way to fix this issue as it is very annoying.

>
>
> Why do you change the aging time back? The important thing is to have the same
> aging time on all your switches in the network. 18000 seems a bit too high for
> me. I would suggest something like 30 minutes.
>
> Regards,
> Christoph Gartmann
>


I think 1800 seconds (300 minutes) was the default. But even changing
it to 30 minutes is not going to fix the problem will it if done on all
3 routers?. I don't know how to change the Address Aging on the 2900 as
it has a command line which commands i am not too familiar with.

Also, what about upgrading the firmware in the 1900s and IOS in the 2900?

TIA, Dan
 
Reply With Quote
 
AnyBody43
Guest
Posts: n/a
 
      01-22-2004
http://www.velocityreviews.com/forums/(E-Mail Removed) (Christoph Gartmann) wrote in message news:<buldvh$li4$(E-Mail Removed)-freiburg.de>...
> In article <(E-Mail Removed)>, Dan <(E-Mail Removed)> writes:
> >Is anyone familiar with the address aging issue between a Catalyst 1900
> >and a Catalyst 2900. Specifically, if a laptop is disconnected for a
> >1900 port to a 2900, the use can't login to the network. The work
> >around is too go into the 1900's Address Aging field and change it from
> >18000 to 300 and the wait 5 minutes and laptop can connect. Then change
> >the aging back to 18000. Here is what firmware/ios is running:
> >
> > 1900 Firmware v 7.02
> >
> > 2900 V 11.2(8.6)sa6
> >
> >Is there a way to fix this issue as it is very annoying.

>
> Why do you change the aging time back? The important thing is to have the same
> aging time on all your switches in the network. 18000 seems a bit too high for
> me. I would suggest something like 30 minutes.
>
> Regards,
> Christoph Gartmann



This may not be 100% but I think that it is not too bad.

The original solution to this behviour (I don't think that it is a
'problem') is to relay on the Spanning Tree Protocol
which is enabled by default.

STP sent (note past tense) a Topology Change Notification (TCN)
whenever a port was brought up or went down (I think both).

This caused the forwarding database (terminology from 802.1d,
sorry) to be put into fast aging which is, IIRC, 15 seconds.

I cannot now recall exactly but I suspect that ports with
portfast enabled do not result in TCN on state change.

Anyway to your issue, the default aging time is 300s and
unless there was a sepcific problem being experienced
I see no need to change it.

If you have STP off you could consider turning it on which
would enable fast aging.

I do not have time right now to look up the portfast vs
fast aging thing.

Finally remember that 802.1d protocol was designed
when there was the real prospect of a 2000 node (or more)
bridged network and processors were less fast and memory was
much more costly. Modern stuff is really (perhaps I should
say Absolutely) fabulous in comparison. It would be most unusual
consider increasing the aging time from the default.

Good luck.
 
Reply With Quote
 
Christoph Gartmann
Guest
Posts: n/a
 
      01-22-2004
In article <trIPb.97608$(E-Mail Removed)-kc.rr.com>, Dan <(E-Mail Removed)> writes:
>I think 1800 seconds (300 minutes) was the default. But even changing
>it to 30 minutes is not going to fix the problem will it if done on all
>3 routers?.


I just noticed: 1800 seconds is already 30 minutes. So try something like
300 (5 minutes). At least there shouldn't be a problem when moving a computer
if you wait 30 or five minutes before reconnecting it.

>I don't know how to change the Address Aging on the 2900 as it has a command
>line which commands i am not too familiar with.


Connect to it, then at the prompt:
> enable

...
# configure terminal
(config)# interface ethernet 0
(config-if)# arp timeout 300
(config-if)# end
(config)# end
# write mem

>Also, what about upgrading the firmware in the 1900s and IOS in the 2900?


Not a bad idea either.

Regards,
Christoph Gartmann

--
Max-Planck-Institut fuer Phone : +49-761-5108-464 Fax: -452
Immunbiologie
Postfach 1169 Internet: gartmann@immunbio dot mpg dot de
D-79011 Freiburg, Germany
http://www.immunbio.mpg.de/home/menue.html
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anti aging products Treas4ever ASP .Net 0 10-26-2006 10:26 PM
C6000 MAC aging problem Martin Bilgrav Cisco 2 12-02-2005 08:57 AM
XP on an aging PIII? Karl Engel Computer Support 10 08-13-2005 11:23 PM
Question: Artificially aging digital photos BD Digital Photography 8 07-15-2005 08:12 PM
CMOS image aging Dave L Digital Photography 2 04-18-2005 02:01 PM



Advertisments