Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > cant ping another interface on the same router ...

Reply
Thread Tools

cant ping another interface on the same router ...

 
 
J Bard
Guest
Posts: n/a
 
      12-30-2003

I'm getting this error

Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
%Invalid next hop address (it's this router)

and when I simply try to ping 192.168.4.1, I get a time out. Though I'm new
to this, I must say I'm puzzled by the behavior. Why should I not be able to
ping another interface on the router ?


Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable password ah
!
!
!
!
interface Ethernet0
ip address 192.168.3.1 255.255.255.0
!
interface Serial0
no ip address
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip address 192.168.4.1 255.255.255.0
encapsulation ppp
async dynamic routing
async mode dedicated
!
router rip
network 1.0.0.0
network 169.254.0.0
network 192.0.0.0
!
ip classless
!
!
line con 0
session-timeout 3000
absolute-timeout 10000
line aux 0

modem InOut
transport input all
speed 38400
flowcontrol hardware
line vty 0 4
password ah
login
!
end


 
Reply With Quote
 
 
 
 
Claude LeFort
Guest
Posts: n/a
 
      12-30-2003
what are the results of "show ip arp interface async1" ?

Your default route should point to the next hop routing device.

Claude

"J Bard" <(E-Mail Removed)> wrote in message
news:dtiIb.15429$(E-Mail Removed) link.net...
>
> I'm getting this error
>
> Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
> %Invalid next hop address (it's this router)
>
> and when I simply try to ping 192.168.4.1, I get a time out. Though I'm

new
> to this, I must say I'm puzzled by the behavior. Why should I not be able

to
> ping another interface on the router ?
>
>
> Current configuration:
> !
> version 11.3
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname Router
> !
> enable password ah
> !
> !
> !
> !
> interface Ethernet0
> ip address 192.168.3.1 255.255.255.0
> !
> interface Serial0
> no ip address
> no ip mroute-cache
> shutdown
> no fair-queue
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface Async1
> ip address 192.168.4.1 255.255.255.0
> encapsulation ppp
> async dynamic routing
> async mode dedicated
> !
> router rip
> network 1.0.0.0
> network 169.254.0.0
> network 192.0.0.0
> !
> ip classless
> !
> !
> line con 0
> session-timeout 3000
> absolute-timeout 10000
> line aux 0
>
> modem InOut
> transport input all
> speed 38400
> flowcontrol hardware
> line vty 0 4
> password ah
> login
> !
> end
>
>



 
Reply With Quote
 
 
 
 
Barry Margolin
Guest
Posts: n/a
 
      12-30-2003
In article <dtiIb.15429$(E-Mail Removed) .net>,
"J Bard" <(E-Mail Removed)> wrote:

> I'm getting this error
>
> Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
> %Invalid next hop address (it's this router)


It makes no sense to set a next hop to the router's own address. It
means that the packets will just cycle forever on the router. You
should use the address of the device at the other end, or the interface
name:

ip route 0.0.0.0 0.0.0.0 Async1

> and when I simply try to ping 192.168.4.1, I get a time out. Though I'm new
> to this, I must say I'm puzzled by the behavior. Why should I not be able to
> ping another interface on the router ?


When you ping a serial interface from the router itself, Cisco sends the
packet out the interface and expects it to be forwarded back by the
device at the other end. This allows you to use ping to confirm that
the serial line is functioning properly.

If the ping is failing, it may be a configuration problem with the
remote router. Perhaps it doesn't have the correct address or mask on
its Async interface.

>
> Current configuration:
> !
> version 11.3
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname Router
> !
> enable password ah
> !
> !
> !
> !
> interface Ethernet0
> ip address 192.168.3.1 255.255.255.0
> !
> interface Serial0
> no ip address
> no ip mroute-cache
> shutdown
> no fair-queue
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface Async1
> ip address 192.168.4.1 255.255.255.0
> encapsulation ppp
> async dynamic routing
> async mode dedicated
> !
> router rip
> network 1.0.0.0
> network 169.254.0.0
> network 192.0.0.0
> !
> ip classless
> !
> !
> line con 0
> session-timeout 3000
> absolute-timeout 10000
> line aux 0
>
> modem InOut
> transport input all
> speed 38400
> flowcontrol hardware
> line vty 0 4
> password ah
> login
> !
> end
>
>


--
Barry Margolin, http://www.velocityreviews.com/forums/(E-Mail Removed)
Arlington, MA
 
Reply With Quote
 
PES
Guest
Posts: n/a
 
      12-30-2003
Barry is correct. Don't route to yourself, route to the next hop. Also the
statement
network 192.0.0.0 is not 192.x.x.x it is 192.0.x.x. I doubt that is what
you want.

"J Bard" <(E-Mail Removed)> wrote in message
news:dtiIb.15429$(E-Mail Removed) link.net...
>
> I'm getting this error
>
> Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
> %Invalid next hop address (it's this router)
>
> and when I simply try to ping 192.168.4.1, I get a time out. Though I'm

new
> to this, I must say I'm puzzled by the behavior. Why should I not be able

to
> ping another interface on the router ?
>
>
> Current configuration:
> !
> version 11.3
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname Router
> !
> enable password ah
> !
> !
> !
> !
> interface Ethernet0
> ip address 192.168.3.1 255.255.255.0
> !
> interface Serial0
> no ip address
> no ip mroute-cache
> shutdown
> no fair-queue
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface Async1
> ip address 192.168.4.1 255.255.255.0
> encapsulation ppp
> async dynamic routing
> async mode dedicated
> !
> router rip
> network 1.0.0.0
> network 169.254.0.0
> network 192.0.0.0
> !
> ip classless
> !
> !
> line con 0
> session-timeout 3000
> absolute-timeout 10000
> line aux 0
>
> modem InOut
> transport input all
> speed 38400
> flowcontrol hardware
> line vty 0 4
> password ah
> login
> !
> end
>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I can ping the router but router can't ping me superkingkong Cisco 2 04-17-2010 01:59 PM
cant compile on linux system.cant compile on cant compile onlinux system. Nagaraj C++ 1 03-01-2007 11:18 AM
Setting up a router with 29 Global IPs, BUT can't ping router internal interface from server or server interface from router war_wheelan@yahoo.com Cisco 1 12-14-2005 03:31 PM
cant ping when adding secondary ip to 1 fastethernet interface on 1700 router jcharth@hotmail.com Cisco 2 08-18-2005 10:06 PM
PIX Help?cant PING the INSIDE Interface of MY PIX eugene123 Cisco 4 09-25-2003 04:16 AM



Advertisments