Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > www transparent proxy ?

Reply
Thread Tools

www transparent proxy ?

 
 
Casto
Guest
Posts: n/a
 
      12-13-2003
(excuse my english, i'm not english or american)


i want to install a www transparent proxy in my dmz.
i have a 1700 series cisco with 3 ethernet int

my lan network : 110.75.3.0 255.255.255.0 (110.75.3.210 address of the
router)
my dmz network : 80.19.3.0 255.255.255.0 (80.19.3.210 address of the router,
address of my www proxy 80.19.3.25)
outside network : 80.19.4.0 255.255.255.0 (80.19.4.210 address of the
router)



LAN ----------------ROUTER------------------OUTSIDE
|
|
|
|
_____ |______
DMZ (proxy)

i install a sniffer in the DMZ and
when i try to connect to an ouside web server, 110.75.3.1 --->
80.19.4.1(www)
i have in the dmz a paquet with
source : 110.75.3.1 destination : 80.19.4.1 port : 80 (www.mytestdomain.com)
(with destination mac address of my proxy, like a "routed" paquet)
and i would like to have
source : 110.75.3.1 destination : 80.19.3.25 port : 80
(www.mytestdomain.com)

is it normal ?
is it possible to change the destination address ?
a squid server can resolve this request with my paquet? (i don't install my
proxy at the moment)

can you help me, i try different configuration, but i didn't manage to work
my transparent proxy with the proxy address in destination paquet

i use use found on the web

interface Ethernet0
ip address 110.75.3.210 255.255.255.0
ip policy route-map proxy-redir
!
interface Fastethernet 0
ip address 80.19.3.210 255.255.255.0
!
interface Ethernet1
ip address 80.19.4.210 255.255.255.0
!
access-list 110 deny tcp host 80.19.3.25 any eq www
access-list 110 permit tcp any any eq www
!
route-map proxy-redir permit 10
match ip address 110
set ip next-hop 80.19.3.25




thanks a lot

xavier


 
Reply With Quote
 
 
 
 
Alan Strassberg
Guest
Posts: n/a
 
      12-15-2003
In article <3fdb4130$0$19279$(E-Mail Removed)>,
Casto <(E-Mail Removed)> wrote:
>(excuse my english, i'm not english or american)
>
>
>i want to install a www transparent proxy in my dmz.
>i have a 1700 series cisco with 3 ethernet int
>
>my lan network : 110.75.3.0 255.255.255.0 (110.75.3.210 address of the
>router)
>my dmz network : 80.19.3.0 255.255.255.0 (80.19.3.210 address of the router,
>address of my www proxy 80.19.3.25)
>outside network : 80.19.4.0 255.255.255.0 (80.19.4.210 address of the
>router)
>
>
>
>LAN ----------------ROUTER------------------OUTSIDE
> |
> |
> |
> |
> _____ |______
> DMZ (proxy)
>
>i install a sniffer in the DMZ and
>when i try to connect to an ouside web server, 110.75.3.1 --->
>80.19.4.1(www)
>i have in the dmz a paquet with
>source : 110.75.3.1 destination : 80.19.4.1 port : 80 (www.mytestdomain.com)
>(with destination mac address of my proxy, like a "routed" paquet)
>and i would like to have
>source : 110.75.3.1 destination : 80.19.3.25 port : 80
>(www.mytestdomain.com)
>
>is it normal ?
>is it possible to change the destination address ?
>a squid server can resolve this request with my paquet? (i don't install my
>proxy at the moment)
>
>can you help me, i try different configuration, but i didn't manage to work
>my transparent proxy with the proxy address in destination paquet
>
>i use use found on the web
>
>interface Ethernet0
>ip address 110.75.3.210 255.255.255.0
>ip policy route-map proxy-redir
>!
>interface Fastethernet 0
>ip address 80.19.3.210 255.255.255.0
>!
>interface Ethernet1
>ip address 80.19.4.210 255.255.255.0
>!
>access-list 110 deny tcp host 80.19.3.25 any eq www
>access-list 110 permit tcp any any eq www
>!
>route-map proxy-redir permit 10
>match ip address 110
>set ip next-hop 80.19.3.25


http://www.squid-cache.org/Doc/FAQ/FAQ-17.html#ss17.5

Use wccp if you can, very easy, route-map if you ned to.

alan
 
Reply With Quote
 
 
 
 
Casto
Guest
Posts: n/a
 
      12-15-2003
i complete my question :
does a squid server accept paquets like a router ?
paquet destination : eth : [squid mac address] and ip[real ip
destination of the web server].
thanks

xavier


"Casto" <(E-Mail Removed)> a écrit dans le message de news:
3fdb4130$0$19279$(E-Mail Removed)...
> (excuse my english, i'm not english or american)
>
>
> i want to install a www transparent proxy in my dmz.
> i have a 1700 series cisco with 3 ethernet int
>
> my lan network : 110.75.3.0 255.255.255.0 (110.75.3.210 address of the
> router)
> my dmz network : 80.19.3.0 255.255.255.0 (80.19.3.210 address of the

router,
> address of my www proxy 80.19.3.25)
> outside network : 80.19.4.0 255.255.255.0 (80.19.4.210 address of the
> router)
>
>
>
> LAN ----------------ROUTER------------------OUTSIDE
> |
> |
> |
> |
> _____ |______
> DMZ (proxy)
>
> i install a sniffer in the DMZ and
> when i try to connect to an ouside web server, 110.75.3.1 --->
> 80.19.4.1(www)
> i have in the dmz a paquet with
> source : 110.75.3.1 destination : 80.19.4.1 port : 80

(www.mytestdomain.com)
> (with destination mac address of my proxy, like a "routed" paquet)
> and i would like to have
> source : 110.75.3.1 destination : 80.19.3.25 port : 80
> (www.mytestdomain.com)
>
> is it normal ?
> is it possible to change the destination address ?
> a squid server can resolve this request with my paquet? (i don't install

my
> proxy at the moment)
>
> can you help me, i try different configuration, but i didn't manage to

work
> my transparent proxy with the proxy address in destination paquet
>
> i use use found on the web
>
> interface Ethernet0
> ip address 110.75.3.210 255.255.255.0
> ip policy route-map proxy-redir
> !
> interface Fastethernet 0
> ip address 80.19.3.210 255.255.255.0
> !
> interface Ethernet1
> ip address 80.19.4.210 255.255.255.0
> !
> access-list 110 deny tcp host 80.19.3.25 any eq www
> access-list 110 permit tcp any any eq www
> !
> route-map proxy-redir permit 10
> match ip address 110
> set ip next-hop 80.19.3.25
>
>
>
>
> thanks a lot
>
> xavier
>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transparent (redirecting) proxy with BaseHTTPServer paul koelle Python 3 01-28-2005 04:25 PM
T/Clear transparent proxy croaked, anybody got an open proxy handy? James Sleeman NZ Computing 12 09-19-2004 08:32 AM
Transparent proxy and Cisco router 831 and IOS 12.2 Mirek Cisco 1 01-18-2004 04:10 PM
transparent www proxy - port forwarding with 3660 Enrico Gloeckner Cisco 2 11-29-2003 02:51 PM
transparent www proxy - pix port forwarding Enrico Gloeckner Cisco 1 11-09-2003 05:53 PM



Advertisments