Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > cisco router weird problem (should be simple)

Reply
Thread Tools

cisco router weird problem (should be simple)

 
 
Joe
Guest
Posts: n/a
 
      12-04-2003
Hi, helpers,

We have just installed T1 service. The T1 provider turned up the
service this morning. However, we have a problem connecting our client
machine to outside.

Here is some info from the T1 provider -- Qwest:

Qwest Serial: 65.112.97.133/30(255.255.255.252)
Customer Serial: 65.112.97.134/30(255.255.255.252)
Encapsulation: HDLC
LAN IP Block: 65.115.16.64/27(255.255.255.224)
Routing Type: Static

Here is the configuration:

ip subnet-zero
!
interface fastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface serial0/0
ip address 65.112.97.134 255.255.255.252
!
interface fastEthernet0/1
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
router rip
network 10.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 65.112.97.133
no ip http server

From a client machine 10.10.10.10, we can ping 10.10.10.1,
65.112.97.134; we can also ping another interface 192.168.0.1 and that
subnet machines like 192.168.0.2. But we cannot ping 65.112.97.133 and
outside ip like 216.109.117.204.

This client machine(10.10.10.10) is with a mask of 255.255.255.0 and a
gateway of 10.10.10.1. From "route print" command, it has no routing
problem. However, when I "traceroute" to outside ip addresses like
216.109.117.204, it stops at 10.10.10.1.

From the router, the "show ip route" command shows the following info:

Gateway of last resort is 65.112.97.133 to network 0.0.0.0
65.0.0.0/30 is subnetted, 1 subnets
C 65.112.97.132 is directly connected, serial0/0
C 10.10.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, fastethernet0/0
C 192.168.0.0/24 is directly connected, fastethernet0/1
S* 0.0.0.0/0 [1/0] via 65.112.97.133 is directly connected, serial0/0

From the router, I can ping both outside and inside ip addresses.

I guess I may have missed something. Any advices will be highly
appreciated.

Sincerely,
Joe Gao
 
Reply With Quote
 
 
 
 
Doug McIntyre
Guest
Posts: n/a
 
      12-04-2003
http://www.velocityreviews.com/forums/(E-Mail Removed) (Joe) writes:
>We have just installed T1 service. The T1 provider turned up the
>service this morning. However, we have a problem connecting our client
>machine to outside.


>Here is some info from the T1 provider -- Qwest:


>Qwest Serial: 65.112.97.133/30(255.255.255.252)
>Customer Serial: 65.112.97.134/30(255.255.255.252)
>Encapsulation: HDLC
>LAN IP Block: 65.115.16.64/27(255.255.255.224)
>Routing Type: Static


>Here is the configuration:
>
>ip subnet-zero
>!
>interface fastEthernet0/0
> ip address 10.10.10.1 255.255.255.0
> duplex auto
> speed auto
>!
>interface serial0/0
> ip address 65.112.97.134 255.255.255.252



You don't have NAT turned on. If you are using private IP space (ie. 10.10.10)
you'll need to NAT into your public range of 65.115.16.64/27.

http://www.cisco.com/pcgi-bin/Suppor...networking:NAT


--
Doug McIntyre (E-Mail Removed)
Network Engineer/Jack of All Trades
Vector Internet Services, Inc.
 
Reply With Quote
 
 
 
 
PES
Guest
Posts: n/a
 
      12-04-2003
You have no NAT. Those private ip's will not work on the internet. You
need to do the following.

1. Assign interfaces to inside or outside

To do this go to each interface and do and ip nat inside or outside
statement. For example

interface fastEthernet0/0
ip nat inside
!
interface fastEthernet0/1
ip nat inside
!
interface serial0/0
ip nat outside
!

2. You need to create access-lists to assign what is to be translated.

access-list 1 10.10.10.0 0.0.0.255
access-list 1 192.168.0.0 0.0.0.255

3. Your next step is to either overload on an interface or create a pool
(using your lan range). It is easiest to overload on an interface.

ip nat inside source list 1 interface s0/0 overload


"Joe" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) om...
> Hi, helpers,
>
> We have just installed T1 service. The T1 provider turned up the
> service this morning. However, we have a problem connecting our client
> machine to outside.
>
> Here is some info from the T1 provider -- Qwest:
>
> Qwest Serial: 65.112.97.133/30(255.255.255.252)
> Customer Serial: 65.112.97.134/30(255.255.255.252)
> Encapsulation: HDLC
> LAN IP Block: 65.115.16.64/27(255.255.255.224)
> Routing Type: Static
>
> Here is the configuration:
>
> ip subnet-zero
> !
> interface fastEthernet0/0
> ip address 10.10.10.1 255.255.255.0
> duplex auto
> speed auto
> !
> interface serial0/0
> ip address 65.112.97.134 255.255.255.252
> !
> interface fastEthernet0/1
> ip address 192.168.0.1 255.255.255.0
> duplex auto
> speed auto
> !
> router rip
> network 10.0.0.0
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 65.112.97.133
> no ip http server
>
> From a client machine 10.10.10.10, we can ping 10.10.10.1,
> 65.112.97.134; we can also ping another interface 192.168.0.1 and that
> subnet machines like 192.168.0.2. But we cannot ping 65.112.97.133 and
> outside ip like 216.109.117.204.
>
> This client machine(10.10.10.10) is with a mask of 255.255.255.0 and a
> gateway of 10.10.10.1. From "route print" command, it has no routing
> problem. However, when I "traceroute" to outside ip addresses like
> 216.109.117.204, it stops at 10.10.10.1.
>
> From the router, the "show ip route" command shows the following info:
>
> Gateway of last resort is 65.112.97.133 to network 0.0.0.0
> 65.0.0.0/30 is subnetted, 1 subnets
> C 65.112.97.132 is directly connected, serial0/0
> C 10.10.0.0/24 is subnetted, 1 subnets
> C 10.10.10.0 is directly connected, fastethernet0/0
> C 192.168.0.0/24 is directly connected, fastethernet0/1
> S* 0.0.0.0/0 [1/0] via 65.112.97.133 is directly connected, serial0/0
>
> From the router, I can ping both outside and inside ip addresses.
>
> I guess I may have missed something. Any advices will be highly
> appreciated.
>
> Sincerely,
> Joe Gao



 
Reply With Quote
 
Vinny Abello
Guest
Posts: n/a
 
      12-04-2003
OK, a few things here.

If you're just doing static routing, get rid of the router rip
section. It's not needed.

How are you planning on using the /27 assigned to you? If you want to
have it fully routed, just add it to an ethernet interface as either
the primary ip address or a secondary.

Also, if you want to be able to use private IP address space you'll
need to configure NAT.

I'll insert some statements in your config that should make NAT work,
but I only got 4 hours of sleep last night so don't be surprised if it
doesn't work. I'm sure someone else will correct me if I make a
mistake.

On 3 Dec 2003 16:08:30 -0800, (E-Mail Removed) (Joe) wrote:

>Hi, helpers,
>
>We have just installed T1 service. The T1 provider turned up the
>service this morning. However, we have a problem connecting our client
>machine to outside.
>
>Here is some info from the T1 provider -- Qwest:
>
>Qwest Serial: 65.112.97.133/30(255.255.255.252)
>Customer Serial: 65.112.97.134/30(255.255.255.252)
>Encapsulation: HDLC
>LAN IP Block: 65.115.16.64/27(255.255.255.224)
>Routing Type: Static
>
>Here is the configuration:
>
>ip subnet-zero
>!
>interface fastEthernet0/0
> ip address 10.10.10.1 255.255.255.0

ip nat inside
> duplex auto
> speed auto
>!
>interface serial0/0
> ip address 65.112.97.134 255.255.255.252

ip nat outside
>!
>interface fastEthernet0/1
> ip address 192.168.0.1 255.255.255.0

ip nat inside
> duplex auto
> speed auto
>!
>router rip <delete>
> network 10.0.0.0 <delete>
>!
>ip classless
>ip route 0.0.0.0 0.0.0.0 65.112.97.133
>no ip http server


ip nat inside source list 1 interface serial0/0 overload

access-list 1 permit 10.10.10.0 0.0.0.255
access-list 1 permit 192.168.0.0 0.0.0.255
>
>From a client machine 10.10.10.10, we can ping 10.10.10.1,
>65.112.97.134; we can also ping another interface 192.168.0.1 and that
>subnet machines like 192.168.0.2. But we cannot ping 65.112.97.133 and
>outside ip like 216.109.117.204.
>
>This client machine(10.10.10.10) is with a mask of 255.255.255.0 and a
>gateway of 10.10.10.1. From "route print" command, it has no routing
>problem. However, when I "traceroute" to outside ip addresses like
>216.109.117.204, it stops at 10.10.10.1.
>
>From the router, the "show ip route" command shows the following info:
>
>Gateway of last resort is 65.112.97.133 to network 0.0.0.0
> 65.0.0.0/30 is subnetted, 1 subnets
>C 65.112.97.132 is directly connected, serial0/0
>C 10.10.0.0/24 is subnetted, 1 subnets
>C 10.10.10.0 is directly connected, fastethernet0/0
>C 192.168.0.0/24 is directly connected, fastethernet0/1
>S* 0.0.0.0/0 [1/0] via 65.112.97.133 is directly connected, serial0/0
>
>From the router, I can ping both outside and inside ip addresses.
>
>I guess I may have missed something. Any advices will be highly
>appreciated.
>
>Sincerely,
>Joe Gao


 
Reply With Quote
 
Vinny Abello
Guest
Posts: n/a
 
      12-04-2003
Oh, another reason your shouldn't use RIP is because you have
classless ip networks in your config. If you want to use RIP you need
to specificy to use version 2 which supports classless networks. I
still wouldn't use RIP though and if this is your only router, again
just disable it. You're not speaking with the ISP using RIP for
sure... or if you are and they are accepting your private address
space being announced (via RIP1!), they should re-evaluate their
customer setups and route propogation design. I'm sure that's not
the case though.

On 3 Dec 2003 16:08:30 -0800, (E-Mail Removed) (Joe) wrote:

>Hi, helpers,
>
>We have just installed T1 service. The T1 provider turned up the
>service this morning. However, we have a problem connecting our client
>machine to outside.
>
>Here is some info from the T1 provider -- Qwest:
>
>Qwest Serial: 65.112.97.133/30(255.255.255.252)
>Customer Serial: 65.112.97.134/30(255.255.255.252)
>Encapsulation: HDLC
>LAN IP Block: 65.115.16.64/27(255.255.255.224)
>Routing Type: Static
>
>Here is the configuration:
>
>ip subnet-zero
>!
>interface fastEthernet0/0
> ip address 10.10.10.1 255.255.255.0
> duplex auto
> speed auto
>!
>interface serial0/0
> ip address 65.112.97.134 255.255.255.252
>!
>interface fastEthernet0/1
> ip address 192.168.0.1 255.255.255.0
> duplex auto
> speed auto
>!
>router rip
> network 10.0.0.0
>!
>ip classless
>ip route 0.0.0.0 0.0.0.0 65.112.97.133
>no ip http server
>
>From a client machine 10.10.10.10, we can ping 10.10.10.1,
>65.112.97.134; we can also ping another interface 192.168.0.1 and that
>subnet machines like 192.168.0.2. But we cannot ping 65.112.97.133 and
>outside ip like 216.109.117.204.
>
>This client machine(10.10.10.10) is with a mask of 255.255.255.0 and a
>gateway of 10.10.10.1. From "route print" command, it has no routing
>problem. However, when I "traceroute" to outside ip addresses like
>216.109.117.204, it stops at 10.10.10.1.
>
>From the router, the "show ip route" command shows the following info:
>
>Gateway of last resort is 65.112.97.133 to network 0.0.0.0
> 65.0.0.0/30 is subnetted, 1 subnets
>C 65.112.97.132 is directly connected, serial0/0
>C 10.10.0.0/24 is subnetted, 1 subnets
>C 10.10.10.0 is directly connected, fastethernet0/0
>C 192.168.0.0/24 is directly connected, fastethernet0/1
>S* 0.0.0.0/0 [1/0] via 65.112.97.133 is directly connected, serial0/0
>
>From the router, I can ping both outside and inside ip addresses.
>
>I guess I may have missed something. Any advices will be highly
>appreciated.
>
>Sincerely,
>Joe Gao


 
Reply With Quote
 
Frank Boehm
Guest
Posts: n/a
 
      12-09-2003
> >Here is the configuration:
> >
> >ip subnet-zero
> >!
> >interface fastEthernet0/0
> > ip address 10.10.10.1 255.255.255.0
> >!
> >interface serial0/0
> > ip address 65.112.97.134 255.255.255.252
> >!
> >interface fastEthernet0/1
> > ip address 192.168.0.1 255.255.255.0
> >!
> >router rip
> > network 10.0.0.0


of course nat/pat

In comp.dcom.sys.cisco Vinny Abello <(E-Mail Removed)> wrote:
> Oh, another reason your shouldn't use RIP is because you have
> classless ip networks in your config. If you want to use RIP you need
> to specificy to use version 2 which supports classless networks. I
> still wouldn't use RIP though and if this is your only router, again
> just disable it. You're not speaking with the ISP using RIP for
> sure... or if you are and they are accepting your private address
> space being announced (via RIP1!), they should re-evaluate their
> customer setups and route propogation design. I'm sure that's not
> the case though.


rip will only be send/recieved on interface fastEthernet0/0, that is
the only match for network 10.0.0.0

there is no risk to send unnecessary rip updates to the ISP with this
configuration

on this router 10.x.x.x is only used for a single interface, if it's a
stubbed network and/or there are no other 10.x.x.x on his site, he
don't have to to use rip version 2

Followup-To: comp.dcom.sys.cisco

cu Frank

--
"It is worth noticing that there are 3 kinds of people in the world, those
who can count and those who canít." from Chap. 10.8 Diablo1 Guide Jarulf)
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie with a weird technical problem (@ least I think it's weird) will Ruby 6 12-27-2006 04:46 PM
weird problem with using a Cisco 1751 as a home office router ken gallagher Cisco 3 10-24-2006 09:15 PM
Cisco 1750 Router Cisco QoS Device Manager Cisco VPN Device Manager Rene Kuhn Cisco 0 12-28-2005 08:45 PM
Setting up a router with 29 Global IPs, BUT can't ping router internal interface from server or server interface from router war_wheelan@yahoo.com Cisco 1 12-14-2005 03:31 PM
ReQ; Help having problem with cisco router 1602R the Lan part works cannot log on to configure so PC can access internet, router connects to T1 line thier is an alarm light on anyone can help smokin@aol.com Computer Support 4 10-30-2004 06:06 AM



Advertisments