Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > images in java applet not showing

Reply
Thread Tools

images in java applet not showing

 
 
Navodit
Guest
Posts: n/a
 
      06-15-2006
I am working on a collaborative whiteboard application. So I have this piece
of code which is supposed to be using 2 jar files. I have been told that the
jar files (whiteboard.jar and collab.jar) work fine. However when the
whiteboard is displayed then the images of the icons (New, Close, draw line,
draw arrow etc) dont show up even though the whiteboard works perfectly
fine. Even the tooltip text can be seen when the mouse is placed over the
icons and I can perform all the functions required of the whiteboard. My
question is:

What could be the reason for the images of the icons not showing up ?

The images are not included in the jar file but are in a folder called gifs
which is in the same folder as the jar files. I tried including the images
in the jar file but that still did not work !
The code that I use (in a .asp file) to invoke the applet is as follows:




<OBJECT classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93" width="600"
height="400" align="baseline">
<PARAM NAME="code"
VALUE="com.inMeeting.client.whiteboard.WhiteBoardA pplet.class">
<PARAM NAME="archive" VALUE="collab.jar, whiteboard.jar">
<PARAM NAME="-Doracle.jdbc.Trace" VALUE="true">
<PARAM NAME="type" VALUE="application/x-java-applet;version=1.2.2">
<PARAM NAME="scriptable" VALUE="true">
<PARAM NAME="MAYSCRIPT" VALUE="true">
<PARAM NAME="username" VALUE="<%=Request.QueryString.Item("username")%>">
<PARAM NAME="meetID" VALUE="<%=Request.QueryString.Item("meetID")%>">
<COMMENT>
<!--<EMBED type="application/x-java-applet;version=1.3"
width="10" height="50" align="baseline"%
pluginspage="http://java.sun.com/products/plugin/1.3/plugin-install.html">
code="com.inMeeting.client.whiteboard.WhiteBoardAp plet.class"
archive="collab.jar, whiteboard.jar"
MAYSCRIPT="true"
username="<%=Request.QueryString.Item("username")% >"
meetID="<%=Request.QueryString.Item("meetID")%>"
<NOEMBED> -->
</COMMENT>
No Java 2 SDK, Standard Edition v 1.3 support for APPLET!!
</NOEMBED>
</EMBED>
</OBJECT>



Can anyone suggest why this could be happening ? Or take a educated guess as
to where I should look for the error ? Any help/hints would be appreciated.
Thanks....


 
Reply With Quote
 
 
 
 
Andy Flowers
Guest
Posts: n/a
 
      06-15-2006
Navodit wrote:
> I am working on a collaborative whiteboard application. So I have this piece
> of code which is supposed to be using 2 jar files. I have been told that the
> jar files (whiteboard.jar and collab.jar) work fine. However when the
> whiteboard is displayed then the images of the icons (New, Close, draw line,
> draw arrow etc) dont show up even though the whiteboard works perfectly
> fine. Even the tooltip text can be seen when the mouse is placed over the
> icons and I can perform all the functions required of the whiteboard. My
> question is:
>
> What could be the reason for the images of the icons not showing up ?
>
> The images are not included in the jar file but are in a folder called gifs
> which is in the same folder as the jar files. I tried including the images
> in the jar file but that still did not work !
> The code that I use (in a .asp file) to invoke the applet is as follows:
>
>
>
>
> <OBJECT classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93" width="600"
> height="400" align="baseline">
> <PARAM NAME="code"
> VALUE="com.inMeeting.client.whiteboard.WhiteBoardA pplet.class">
> <PARAM NAME="archive" VALUE="collab.jar, whiteboard.jar">
> <PARAM NAME="-Doracle.jdbc.Trace" VALUE="true">
> <PARAM NAME="type" VALUE="application/x-java-applet;version=1.2.2">
> <PARAM NAME="scriptable" VALUE="true">
> <PARAM NAME="MAYSCRIPT" VALUE="true">
> <PARAM NAME="username" VALUE="<%=Request.QueryString.Item("username")%>">
> <PARAM NAME="meetID" VALUE="<%=Request.QueryString.Item("meetID")%>">
> <COMMENT>
> <!--<EMBED type="application/x-java-applet;version=1.3"
> width="10" height="50" align="baseline"%
> pluginspage="http://java.sun.com/products/plugin/1.3/plugin-install.html">
> code="com.inMeeting.client.whiteboard.WhiteBoardAp plet.class"
> archive="collab.jar, whiteboard.jar"
> MAYSCRIPT="true"
> username="<%=Request.QueryString.Item("username")% >"
> meetID="<%=Request.QueryString.Item("meetID")%>"
> <NOEMBED> -->
> </COMMENT>
> No Java 2 SDK, Standard Edition v 1.3 support for APPLET!!
> </NOEMBED>
> </EMBED>
> </OBJECT>
>
>
>
> Can anyone suggest why this could be happening ? Or take a educated guess as
> to where I should look for the error ? Any help/hints would be appreciated.
> Thanks....
>
>


How are you attempting to read the images ?

Personally I'd put them into the jar file and read them from there, perhaps
http://java.sun.com/docs/books/tutor...et.html#images or
http://www.rgagnon.com/javadetails/java-0240.html might help ?
 
Reply With Quote
 
 
 
 
Navodit
Guest
Posts: n/a
 
      06-15-2006
I am using a pre Java 1.4 plug-in in my code. Does that make any difference
? In particular I am using Java 1.3 plugin... Also if I look at the Java
Console it does not show any error which means that it is able to locate the
image but during display instead of showing the image icon it is only
showing some buttons ... Any idea what cd be going on ?


"Andy Flowers" <(E-Mail Removed)> wrote in message
news:hyikg.19549$(E-Mail Removed)...
> Navodit wrote:
>> I am working on a collaborative whiteboard application. So I have this
>> piece of code which is supposed to be using 2 jar files. I have been told
>> that the jar files (whiteboard.jar and collab.jar) work fine. However
>> when the whiteboard is displayed then the images of the icons (New,
>> Close, draw line, draw arrow etc) dont show up even though the whiteboard
>> works perfectly fine. Even the tooltip text can be seen when the mouse is
>> placed over the icons and I can perform all the functions required of the
>> whiteboard. My question is:
>>
>> What could be the reason for the images of the icons not showing up ?
>>
>> The images are not included in the jar file but are in a folder called
>> gifs which is in the same folder as the jar files. I tried including the
>> images in the jar file but that still did not work !
>> The code that I use (in a .asp file) to invoke the applet is as follows:
>>
>>
>>
>>
>> <OBJECT classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93" width="600"
>> height="400" align="baseline">
>> <PARAM NAME="code"
>> VALUE="com.inMeeting.client.whiteboard.WhiteBoardA pplet.class">
>> <PARAM NAME="archive" VALUE="collab.jar, whiteboard.jar">
>> <PARAM NAME="-Doracle.jdbc.Trace" VALUE="true">
>> <PARAM NAME="type" VALUE="application/x-java-applet;version=1.2.2">
>> <PARAM NAME="scriptable" VALUE="true">
>> <PARAM NAME="MAYSCRIPT" VALUE="true">
>> <PARAM NAME="username"
>> VALUE="<%=Request.QueryString.Item("username")%>">
>> <PARAM NAME="meetID" VALUE="<%=Request.QueryString.Item("meetID")%>">
>> <COMMENT>
>> <!--<EMBED type="application/x-java-applet;version=1.3"
>> width="10" height="50" align="baseline"%
>>
>> pluginspage="http://java.sun.com/products/plugin/1.3/plugin-install.html">
>> code="com.inMeeting.client.whiteboard.WhiteBoardAp plet.class"
>> archive="collab.jar, whiteboard.jar"
>> MAYSCRIPT="true"
>> username="<%=Request.QueryString.Item("username")% >"
>> meetID="<%=Request.QueryString.Item("meetID")%>"
>> <NOEMBED> -->
>> </COMMENT>
>> No Java 2 SDK, Standard Edition v 1.3 support for APPLET!!
>> </NOEMBED>
>> </EMBED>
>> </OBJECT>
>>
>>
>>
>> Can anyone suggest why this could be happening ? Or take a educated guess
>> as to where I should look for the error ? Any help/hints would be
>> appreciated. Thanks....

>
> How are you attempting to read the images ?
>
> Personally I'd put them into the jar file and read them from there,
> perhaps
> http://java.sun.com/docs/books/tutor...et.html#images
> or http://www.rgagnon.com/javadetails/java-0240.html might help ?



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
confussed about showStatus in java.applet.Applet yawnmoth Java 1 08-15-2006 05:44 AM
ASP 1.1: DataGrid - Showing/Not Showing Buttons Ray Booysen ASP .Net 2 03-28-2006 02:49 PM
Java Applet loading in Applet Viewer but not in HTML page Archana Java 1 10-24-2004 11:41 PM
Java applet failed when I try to load the avi file in my java applet Krista Java 3 09-15-2004 02:53 AM
Re: play wave files using java.applet.Applet webster Java 0 07-20-2003 01:51 PM



Advertisments