Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > BGP won't work over GRE without multihop !

Reply
Thread Tools

BGP won't work over GRE without multihop !

 
 
b
Guest
Posts: n/a
 
      11-07-2003
Here is the lab setup :

[Cisco] <-> [Linux Box with IP forwarding enabled] <-> [Cisco]

These are the problems I've come accoss :
- BGP still won't work without an ebgp-multihop config. According to
the internet searches I've done, this should not be the case ?!?
- No matter if I put the linux box in single user mode (i.e. eth
interfaces still "on") or if I turn it off completely, the Ciscos
don't sem to loose their BGP session ?!?

I started from a clean router, so I did an "erase nvram" before
starting and only put in the minimum of commands to get things working
thereafter.

=========ROUTER A ============
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
!
!
interface Tunnel0
ip address 10.9.8.7 255.255.255.0
tunnel source FastEthernet0/1
tunnel destination 192.168.124.29
tunnel checksum
tunnel method gre ip
!
interface FastEthernet0/0
ip address 192.168.199.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.123.28 255.255.255.0
duplex auto
speed auto
!
router bgp 64525
no synchronisation
bgp log-neighbor-changes
network 192.168.199.0
neighbor 10.11.12.13 remote-as 64625
neighbor 10.11.12.13 ebgp-multihop 2
no auto-summary
!
ip classless
ip route 10.11.12 255.255.255.0 Tunnel0
ip route 192.168.124.0 255.255.255.0 192.168.123.30
ip http server
ip pim bidir-enable
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
====================================
=========ROUTER B ============
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
!
!
interface Tunnel0
ip address 10.11.12.13 255.255.255.0
tunnel source FastEthernet0/1
tunnel destination 192.168.123.28
tunnel checksum
tunnel method gre ip
!
interface FastEthernet0/0
ip address 192.168.198.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.124.29 255.255.255.0
duplex auto
speed auto
!
router bgp 64525
no synchronisation
bgp log-neighbor-changes
network 192.168.198.0
neighbor 10.9.8.7 remote-as 64525
neighbor 10.9.8.7 ebgp-multihop 2
no auto-summary
!
ip classless
ip route 10.9.8.0 255.255.255.0 Tunnel0
ip route 192.168.123.0 255.255.255.0 192.168.124.254
ip http server
ip pim bidir-enable
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
====================================
 
Reply With Quote
 
 
 
 
Ivan Ostres
Guest
Posts: n/a
 
      11-07-2003
"b" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) om...
> Here is the lab setup :
>
> [Cisco] <-> [Linux Box with IP forwarding enabled] <-> [Cisco]
>
> These are the problems I've come accoss :
> - BGP still won't work without an ebgp-multihop config. According to
> the internet searches I've done, this should not be the case ?!?


And how would it work without ebgp-multihop? You have one hop between ciscos
(linux with forwarding enabled acts as a router)....

Ivan


 
Reply With Quote
 
 
 
 
b
Guest
Posts: n/a
 
      11-07-2003
And what does an IP GRP tunnel do then Ivan ?

Ben

"Ivan Ostres" <(E-Mail Removed)> wrote
> And how would it work without ebgp-multihop? You have one hop between ciscos
> (linux with forwarding enabled acts as a router)....
>
> Ivan

 
Reply With Quote
 
Ivan Ostres
Guest
Posts: n/a
 
      11-10-2003
"b" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) om...
> And what does an IP GRP tunnel do then Ivan ?
>


Yeah, I know, it looked stupid even to me . Try to ping from one bgp
endpoint to other and debug packet to see difference between starting and
ending TTL in icmp packets...

Ivan


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
To BGP or not to BGP (multihoming with ISPs over uneven links speed)?!? papi Cisco 4 09-08-2009 02:45 AM
dual honed ebgp multihop mmark751969 Cisco 1 03-31-2008 10:11 AM
VOIP over VPN over TCP over WAP over 3G Theo Markettos UK VOIP 2 02-14-2008 03:27 PM
VPDN multihop 12.3 Kris Amy Cisco 0 04-12-2005 05:09 AM
Need Sample Config for BGP Multihop Bitoy Cisco 1 06-07-2004 11:27 AM



Advertisments