Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > DHCP option 82 and IOS 12.3T

Reply
Thread Tools

DHCP option 82 and IOS 12.3T

 
 
Thomas Novin
Guest
Posts: n/a
 
      11-05-2003
Hi,

Anyone using DHCP option 82 with the new ip unnumbered feature on
(Fast)Ethernet VLAN (sub)interfaces?

How do I get the DHCP-server (in my case, ISC DHCPd v3.01r4) to record
the extra information provider by option 82?

The little reading I have found on the topic has gotten me to believe
that the information provided by option 82 should get recorded in
dhcpd.leases on the DHCP-server. This is no the case with this setup,
dhcpd.leases looks very much the same.

Everything but option 82 works great. unnumbered works just like it's
supposed to. Clients on VLAN 101, 102 & 103 can successfully use the IP
address of Loopback0 as gateway.

Router 3640 w/ IOS 12.3(4)T:

!
ip dhcp relay information option
!
interface Loopback0
ip address 172.17.12.1 255.255.255.0
!
interface FastEthernet0/0
description Management / Servers
ip address 172.17.11.1 255.255.255.0
speed 100
full-duplex
!
interface FastEthernet0/1
description Trunk towards DSLAM
no ip address
speed 100
full-duplex
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
!
interface FastEthernet0/1.101
encapsulation dot1Q 101
ip unnumbered Loopback0
ip helper-address 172.17.11.3
!
interface FastEthernet0/1.102
encapsulation dot1Q 102
ip unnumbered Loopback0
ip helper-address 172.17.11.3
!
interface FastEthernet0/1.103
encapsulation dot1Q 103
ip unnumbered Loopback0
ip helper-address 172.17.11.3
!

DHCP Server (connected to Fa0/0):

option domain-name-servers 172.17.11.4, 172.17.11.5;
option subnet-mask 255.255.255.0;
option routers 172.17.12.1;
option broadcast-address 172.17.12.255;
option domain-name "y0.bitchez.org";

default-lease-time 1700;
min-lease-time 1600;
max-lease-time 1800;
ddns-updates off;
ddns-update-style none;
deny bootp;
authorative;
one-lease-per-client on;
option netbios-node-type 2;

subnet 172.17.11.0 netmask 255.255.255.0 {
not authoritative;
}

subnet 172.17.12.0 netmask 255.255.255.0 {
range 172.17.12.10 172.17.12.60;
}

--
Thomas Novin http://www.velocityreviews.com/forums/(E-Mail Removed) http://xyz.pp.se/~thnov/
V: +46 (0)431 445400 F: +46 (0)431 445410 GSM: +46 (0)730 667425
--

 
Reply With Quote
 
 
 
 
JC
Guest
Posts: n/a
 
      11-06-2003
Are you sure that your DHCP server supports option 82?

JC
--

"Thomas Novin" <(E-Mail Removed)> wrote in message
news:bobvbl$1bh1pp$(E-Mail Removed)-berlin.de...
> Hi,
>
> Anyone using DHCP option 82 with the new ip unnumbered feature on
> (Fast)Ethernet VLAN (sub)interfaces?
>
> How do I get the DHCP-server (in my case, ISC DHCPd v3.01r4) to record
> the extra information provider by option 82?
>
> The little reading I have found on the topic has gotten me to believe
> that the information provided by option 82 should get recorded in
> dhcpd.leases on the DHCP-server. This is no the case with this setup,
> dhcpd.leases looks very much the same.
>
> Everything but option 82 works great. unnumbered works just like it's
> supposed to. Clients on VLAN 101, 102 & 103 can successfully use the IP
> address of Loopback0 as gateway.
>
> Router 3640 w/ IOS 12.3(4)T:
>
> !
> ip dhcp relay information option
> !
> interface Loopback0
> ip address 172.17.12.1 255.255.255.0
> !
> interface FastEthernet0/0
> description Management / Servers
> ip address 172.17.11.1 255.255.255.0
> speed 100
> full-duplex
> !
> interface FastEthernet0/1
> description Trunk towards DSLAM
> no ip address
> speed 100
> full-duplex
> !
> interface FastEthernet0/1.1
> encapsulation dot1Q 1 native
> !
> interface FastEthernet0/1.101
> encapsulation dot1Q 101
> ip unnumbered Loopback0
> ip helper-address 172.17.11.3
> !
> interface FastEthernet0/1.102
> encapsulation dot1Q 102
> ip unnumbered Loopback0
> ip helper-address 172.17.11.3
> !
> interface FastEthernet0/1.103
> encapsulation dot1Q 103
> ip unnumbered Loopback0
> ip helper-address 172.17.11.3
> !
>
> DHCP Server (connected to Fa0/0):
>
> option domain-name-servers 172.17.11.4, 172.17.11.5;
> option subnet-mask 255.255.255.0;
> option routers 172.17.12.1;
> option broadcast-address 172.17.12.255;
> option domain-name "y0.bitchez.org";
>
> default-lease-time 1700;
> min-lease-time 1600;
> max-lease-time 1800;
> ddns-updates off;
> ddns-update-style none;
> deny bootp;
> authorative;
> one-lease-per-client on;
> option netbios-node-type 2;
>
> subnet 172.17.11.0 netmask 255.255.255.0 {
> not authoritative;
> }
>
> subnet 172.17.12.0 netmask 255.255.255.0 {
> range 172.17.12.10 172.17.12.60;
> }
>
> --
> Thomas Novin (E-Mail Removed) http://xyz.pp.se/~thnov/
> V: +46 (0)431 445400 F: +46 (0)431 445410 GSM: +46 (0)730 667425
> --
>



 
Reply With Quote
 
 
 
 
Thomas Novin
Guest
Posts: n/a
 
      11-11-2003
JC wrote:
> Are you sure that your DHCP server supports option 82?
>
> JC


Yes, ISC DHCPd v3 supports option 82. At least v3.0.1rc12 which I'm
currently using.

However, this is not the issue. I've done some sniffing with Ethereal
and I notice that there is no option 82 field in the packets to the
DHCP-server. So first of all I need to get the router configuration right.

This is what I've come up with so far:

ip dhcp relay information option
ip dhcp relay information trust-all
!
interface Loopback0
ip address 172.17.12.1 255.255.255.0
!
interface FastEthernet0/1.101
encapsulation dot1Q 101
ip unnumbered Loopback0
ip helper-address 172.17.11.3
!

Surely there must be someone who has successfully added option 82 to
relayed dhcp-messages? Any clues are appreciated...

--
--
Thomas Novin (E-Mail Removed) http://xyz.pp.se/~thnov/
V: +46 (0)431 445400 F: +46 (0)431 445410 GSM: +46 (0)730 667425
--

 
Reply With Quote
 
JC
Guest
Posts: n/a
 
      11-12-2003
You config looks good but now I'm a little confused. Maybe we should step
back here. What option 82 information are you hoping the router will send?
I have configured option 82 with DSL subcribers and RBE (so it will send NAS
information), 3550's (these will send port ifindex information) and routers
with MPLS (vpn information). These are very specific types of DHCP
information that IOS was coded to send and I can find no CCO information
regarding a vanilla router setup and what information it might send.

What documentation were you referring to in your original post and what were
you hoping the router will send?

JC

--

"Thomas Novin" <(E-Mail Removed)> wrote in message
news:bor8lt$1gt6hm$(E-Mail Removed)-berlin.de...
> JC wrote:
> > Are you sure that your DHCP server supports option 82?
> >
> > JC

>
> Yes, ISC DHCPd v3 supports option 82. At least v3.0.1rc12 which I'm
> currently using.
>
> However, this is not the issue. I've done some sniffing with Ethereal
> and I notice that there is no option 82 field in the packets to the
> DHCP-server. So first of all I need to get the router configuration right.
>
> This is what I've come up with so far:
>
> ip dhcp relay information option
> ip dhcp relay information trust-all
> !
> interface Loopback0
> ip address 172.17.12.1 255.255.255.0
> !
> interface FastEthernet0/1.101
> encapsulation dot1Q 101
> ip unnumbered Loopback0
> ip helper-address 172.17.11.3
> !
>
> Surely there must be someone who has successfully added option 82 to
> relayed dhcp-messages? Any clues are appreciated...
>
> --
> --
> Thomas Novin (E-Mail Removed) http://xyz.pp.se/~thnov/
> V: +46 (0)431 445400 F: +46 (0)431 445410 GSM: +46 (0)730 667425
> --
>



 
Reply With Quote
 
Thomas Novin
Guest
Posts: n/a
 
      11-13-2003
The goal is to forward VLAN-information to the DHCP-server. I'd like to
see in dhcpd.leases that IP-adress 1.2.3.4 with MAC-address
0000.0000.0000 is on VLAN ID 203 or subint f0/1.203, for example.

Some suggestions I've tried but not succeded with is:

aaa new-model
aaa nas port extended
aaa session-id common

rbe nasip loopback 0

The documentation I've read from Cisco is:

http://www.cisco.com/univercd/cc/td/...4/gtunvlan.htm
http://www.cisco.com/en/US/products/...080087ad8.html
http://www.cisco.com/en/US/products/...080173d22.html

JC wrote:
> You config looks good but now I'm a little confused. Maybe we should step
> back here. What option 82 information are you hoping the router will send?
> I have configured option 82 with DSL subcribers and RBE (so it will send NAS
> information), 3550's (these will send port ifindex information) and routers
> with MPLS (vpn information). These are very specific types of DHCP
> information that IOS was coded to send and I can find no CCO information
> regarding a vanilla router setup and what information it might send.
>
> What documentation were you referring to in your original post and what were
> you hoping the router will send?
>
> JC
>



--
--
Thomas Novin (E-Mail Removed) http://xyz.pp.se/~thnov/
V: +46 (0)431 445400 F: +46 (0)431 445410 GSM: +46 (0)730 667425
--

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
instructions on how to perform an IOS upgrade on a Catalyst 6500 switch (IOS to IOS) Mike Rahl Cisco 1 05-30-2007 05:22 PM
DHCP relay agent versus Option 3; Routers Option lcorrigan Cisco 2 09-27-2006 05:18 PM
Dhcp Relay Agent And Acl On Sw 3750, DHCP Relay Agent and ACL on Sw 3750 Vimokh Cisco 3 09-06-2006 02:16 AM
Option 82 in ios dhcp server Alex Cisco 1 03-11-2005 04:13 PM
"ip addr dhcp" is not available for my IOS release, who has latest IOS for 2514 and 2509? Ed Kideys, Tech-Train Cisco 3 04-30-2004 07:51 PM



Advertisments