Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Dual NAT of Port 80?

Reply
Thread Tools

Dual NAT of Port 80?

 
 
Peter Rowe
Guest
Posts: n/a
 
      11-05-2003
Hi there,

I have a 2 interface router with 2 Internet compliant IP addresses on the Eth0 interface (lets say int1 and int2) and a single private IP on the FastEthernet Interface.

I have tried to use NAT ie

IP NAT INSIDE SOURCE STATIC TCP 192.168.0.1 80 **Int1** 80 Extendable

and

IP NAT INSIDE SOURCE STATIC TCP 192.168.0.13 80 **int2** 80 Extendable

But it doesn't work when accessing http://**int2** , however Http://**int1** works OK, can anyone tell me how to accomplish the NAT to 2 different internal IP's?

Thanks,

Peter.
 
Reply With Quote
 
 
 
 
Peter Rowe
Guest
Posts: n/a
 
      11-05-2003
OK forget it, I was doing something stupid. It's working no problem now.

p.

>>> Peter Rowe<(E-Mail Removed)> 05/11/2003 12:07:41 >>>

Hi there,

I have a 2 interface router with 2 Internet compliant IP addresses on the Eth0 interface (lets say int1 and int2) and a single private IP on the FastEthernet Interface.

I have tried to use NAT ie

IP NAT INSIDE SOURCE STATIC TCP 192.168.0.1 80 **Int1** 80 Extendable

and

IP NAT INSIDE SOURCE STATIC TCP 192.168.0.13 80 **int2** 80 Extendable

But it doesn't work when accessing http://**int2** , however http://**int1** works OK, can anyone tell me how to accomplish the NAT to 2 different internal IP's?

Thanks,

Peter.


 
Reply With Quote
 
 
 
 
Geert Nijs
Guest
Posts: n/a
 
      11-05-2003
You are trying to 'dual home' your web server to two ISPs. This is possible
in newer IOS versions.
You need NAT and route-maps for this.

A sample configuration:
Enabling Static NAT Route Mapping Example
The following example shows the use of route mapping with static NAT
translations:

interface Ethernet3
ip address 172.68.1.100 255.255.255.0
ip nat outside
media-type 10BaseT
!
interface Ethernet4
ip address 192.68.1.100 255.255.255.0
ip nat outside
media-type 10BaseT
!
interface Ethernet5
ip address 11.1.1.100 255.255.255.0
ip nat inside
media-type 10BaseT
!
router rip
network 172.68.0.0
network 192.68.1.0
!
ip nat inside source static 11.1.1.2 192.68.1.21 route-map isp2
ip nat inside source static 11.1.1.2 172.68.1.21 route-map isp1
ip nat inside source static 11.1.1.1 192.68.1.11 route-map isp2
ip nat inside source static 11.1.1.1 172.68.1.11 route-map isp1
access-list 101 permit ip 11.1.1.0 0.0.0.255 172.0.0.0 0.255.255.255.
access-list 102 permit ip 11.1.1.0 0.0.0.255 192.0.0.0 0.255.255.255
!
route-map isp2 permit 10
match ip address 102
set ip next-hop 192.68.1.1
!
route-map isp1 permit 10
match ip address 101
set ip next-hop 172.68.1.1


You can find more at:

http://www.cisco.com/en/US/partner/p...080087bac.html


"Peter Rowe" <(E-Mail Removed)> schreef in bericht
news:boap6g$qfe$(E-Mail Removed)...
> Hi there,
>
> I have a 2 interface router with 2 Internet compliant IP addresses on the

Eth0 interface (lets say int1 and int2) and a single private IP on the
FastEthernet Interface.
>
> I have tried to use NAT ie
>
> IP NAT INSIDE SOURCE STATIC TCP 192.168.0.1 80 **Int1** 80 Extendable
>
> and
>
> IP NAT INSIDE SOURCE STATIC TCP 192.168.0.13 80 **int2** 80 Extendable
>
> But it doesn't work when accessing http://**int2** , however

Http://**int1** works OK, can anyone tell me how to accomplish the NAT to
2 different internal IP's?
>
> Thanks,
>
> Peter.



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Dual WAN on a 2651, NAT inside, opening one port on the seconday WAN Martin Gallagher Cisco 0 11-27-2012 09:27 AM
ip nat translation port-timeout -- WHICH port? Jon.R.Kibler@gmail.com Cisco 1 07-30-2008 10:04 PM
NetGear SPH200D dual Dual-mode, Cordless Phone vs Dualphone 3088 dual mode cordless phone Paul NZ Computing 0 05-08-2007 09:06 AM
Attn: NAT Experts - 2611XM and NAT pool JCVD Cisco 1 02-13-2004 12:30 PM
NAT or Not to NAT; how to do an Internet connection for a 100-PC company ? Al Dykes Cisco 8 10-29-2003 12:34 AM



Advertisments