Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Quick help needed: Adding IP scope passthrough on cisco 828

Reply
Thread Tools

Quick help needed: Adding IP scope passthrough on cisco 828

 
 
Lars Bonnesen
Guest
Posts: n/a
 
      06-14-2006
I have a cisco 828 router which is passing all traffic into our firewall.

sh running gives me this (among other):

ip nat inside source list 2 interface BVI1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 z.x.c.v
ip route a.b.c.d 255.255.255.248 10.10.10.5
ip http server


The "problem" is that now we get a new set of IP addresses (because of more
IP's needed)

How do I edit the above to pass all trafic from
ip q.w.e.r subnet 255.255.255.240 to IP 10.10.10.5
instead of ip route a.b.c.d 255.255.255.248 10.10.10.5
?

Regards, Lars.


 
Reply With Quote
 
 
 
 
Merv
Guest
Posts: n/a
 
      06-14-2006

> How do I edit the above to pass all trafic from
> ip q.w.e.r subnet 255.255.255.240 to IP 10.10.10.5
> instead of ip route a.b.c.d 255.255.255.248 10.10.10.5


conf t
no ip route a.b.c.d 255.255.255.248 10.10.10.5
ip route q.w.e.r 255.255.255.240 10.10.10.5
exit

wri mem

sh ip route static

 
Reply With Quote
 
 
 
 
Lars Bonnesen
Guest
Posts: n/a
 
      06-14-2006

"Merv" <(E-Mail Removed)> skrev i en meddelelse
news:(E-Mail Removed) ups.com...
>
>> How do I edit the above to pass all trafic from
>> ip q.w.e.r subnet 255.255.255.240 to IP 10.10.10.5
>> instead of ip route a.b.c.d 255.255.255.248 10.10.10.5

>
> conf t


What does conf t mean? you thing config?

> no ip route a.b.c.d 255.255.255.248 10.10.10.5
> ip route q.w.e.r 255.255.255.240 10.10.10.5
> exit


that simple?

> wri mem


Or copy runnning-config startup-config ?


 
Reply With Quote
 
SAto
Guest
Posts: n/a
 
      06-14-2006

Lars Bonnesen skrev:
> I have a cisco 828 router which is passing all traffic into our firewall.
>
> sh running gives me this (among other):
>
> ip nat inside source list 2 interface BVI1 overload
> ip classless
> ip route 0.0.0.0 0.0.0.0 z.x.c.v
> ip route a.b.c.d 255.255.255.248 10.10.10.5
> ip http server
>
>
> The "problem" is that now we get a new set of IP addresses (because of more
> IP's needed)
>
> How do I edit the above to pass all trafic from
> ip q.w.e.r subnet 255.255.255.240 to IP 10.10.10.5
> instead of ip route a.b.c.d 255.255.255.248 10.10.10.5


typing the following in the config mode should do the trick:

ip route q.w.e.r 255.255.255.240 10.10.10.5
no ip route a.b.c.d 255.255.255.248 10.10.10.5

Also please note the NAT access list, you may need to change that as
well to provide NATing for the new addresses.

-SAto

 
Reply With Quote
 
SAto
Guest
Posts: n/a
 
      06-14-2006

Lars Bonnesen skrev:
> "Merv" <(E-Mail Removed)> skrev i en meddelelse
> > conf t

>
> What does conf t mean? you thing config?


that is the command used to enter configuration mode
(actually an abbreviation of "configure terminal").

> > no ip route a.b.c.d 255.255.255.248 10.10.10.5
> > ip route q.w.e.r 255.255.255.240 10.10.10.5
> > exit

>
> that simple?


Yes

> > wri mem

>
> Or copy runnning-config startup-config ?


Yes

-SAto

 
Reply With Quote
 
Lars Bonnesen
Guest
Posts: n/a
 
      06-14-2006

"SAto" <(E-Mail Removed)> skrev i en meddelelse
news:(E-Mail Removed) ups.com...

> Also please note the NAT access list, you may need to change that as
> well to provide NATing for the new addresses.


The only thing regarding this is:

ip address 10.10.10.1 255.255.255.0
ip nat inside

interface BVI1
ip address a.b.c.d 255.255.255.252
ip nat outside

access-list 2 permit 10.10.10.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.255

Nothing more regaring NAT.

But I have tried (as a test) to add y.y.y.y 255.255.255.255 10.10.10.5
(without saveing and restarting), and it does not show up in the sh ip route
or sh config. Do I need to save and reboot it in order to have it here?

Regards, Lars.


 
Reply With Quote
 
Lars Bonnesen
Guest
Posts: n/a
 
      06-14-2006

"Lars Bonnesen" <none@none.Š°ň> skrev i en meddelelse
news:44900dec$0$139$(E-Mail Removed). ..
>
> "Merv" <(E-Mail Removed)> skrev i en meddelelse
> news:(E-Mail Removed) ups.com...
>>
>>> How do I edit the above to pass all trafic from
>>> ip q.w.e.r subnet 255.255.255.240 to IP 10.10.10.5
>>> instead of ip route a.b.c.d 255.255.255.248 10.10.10.5

>>
>> conf t

>
> What does conf t mean? you thing config?


Ok, now I get it - config terminal... (-;

Regards, Lars.


 
Reply With Quote
 
SAto
Guest
Posts: n/a
 
      06-15-2006

Lars Bonnesen skrev:
> access-list 2 permit 10.10.10.0 0.0.0.255
>
> Nothing more regaring NAT.


As long as the new network you are adding does not need to be NATed you
should be good. This access list will allow only addresses in the
10.10.10.1-254 range to be NATed.

> But I have tried (as a test) to add y.y.y.y 255.255.255.255 10.10.10.5
> (without saveing and restarting), and it does not show up in the sh ip route
> or sh config. Do I need to save and reboot it in order to have it here?


No, there should be no need to either save nor reboot. are you sure the
command is entered correctly?

conf t
ip route y.y.y.y 255.255.255.255 10.10.10.5

the mask you supply above is a host mask, probably not what you want
for that network but it should display in the routing table and the "sh
running" command.

The "sh config" command only displays configuration that is saved with
the wr mem or copy run start commands.


-SAto

 
Reply With Quote
 
Lars Bonnesen
Guest
Posts: n/a
 
      06-15-2006
It is working as expected and very nicely. Thanks to all of you.,

Regards, Lars.

"SAto" <(E-Mail Removed)> skrev i en meddelelse
news:(E-Mail Removed) ups.com...
>
> Lars Bonnesen skrev:
>> access-list 2 permit 10.10.10.0 0.0.0.255
>>
>> Nothing more regaring NAT.

>
> As long as the new network you are adding does not need to be NATed you
> should be good. This access list will allow only addresses in the
> 10.10.10.1-254 range to be NATed.
>
>> But I have tried (as a test) to add y.y.y.y 255.255.255.255 10.10.10.5
>> (without saveing and restarting), and it does not show up in the sh ip
>> route
>> or sh config. Do I need to save and reboot it in order to have it here?

>
> No, there should be no need to either save nor reboot. are you sure the
> command is entered correctly?
>
> conf t
> ip route y.y.y.y 255.255.255.255 10.10.10.5
>
> the mask you supply above is a host mask, probably not what you want
> for that network but it should display in the routing table and the "sh
> running" command.
>
> The "sh config" command only displays configuration that is saved with
> the wr mem or copy run start commands.
>
>
> -SAto
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cisco VPN client passthrough PIX to PIX problem daqua Hardware 1 05-31-2007 11:11 PM
Cisco 828 passthrough Lars Bonnesen Cisco 0 03-26-2007 06:26 AM
cisco 877 pptp passthrough Cen Cisco 1 08-17-2005 02:22 AM
"passthrough" modem on Cisco 2500 Kifla a.k.a. F. Stratocaster Cisco 1 04-14-2005 08:56 PM
G.SHDSL 828-to-828 Lars L. Christensen Cisco 2 12-17-2004 03:40 PM



Advertisments