Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Troubleshooting errors on 2950G interface, need help

Reply
Thread Tools

Troubleshooting errors on 2950G interface, need help

 
 
Ole Vik
Guest
Posts: n/a
 
      11-05-2003
Hi all.

The scenario is this:

We have a switch (Cisco 2950G) connected to a dsl modem on port 0/24.
The port is configured as a trunk port, as we have a vlan segmented line.
(Internal and secure zones).

interface FastEthernet0/24
description VLAN trunk
switchport trunk allowed vlan 1,1002-1005,1179,1180
switchport mode trunk
no ip address
speed 10
duplex half


(The modem is set to 10/half , so those settings are ok. )

Communications over this line is extremely slow. Checking the interface for
traffic shows that its not using even half of the bw.
Ping times are usually good, but sometimes peaks at 200-300 ms for short
periods of time.

There is a lot of errors on this interface, and here is where i need help.

Following is a sh controller output for this interface:

02OSLSWI01#sh controllers ethernet-controller fastEthernet 0/24

Transmit Receive
232577791 Bytes 985654725 Bytes
2341194 Frames 2304482 Frames
120306 Multicast frames 44454 FCS errors
10 Broadcast frames 0 Multicast frames
0 Pause frames 8483 Broadcast frames
15415 Single defer frames 0 Control frames
0 Multiple defer frames 0 Pause frames
948 1 collision frames 0 Unknown opcode frames
354 2-15 collisions 44586 Alignment errors
0 Late collisions 0 Length out of range
0 Excessive collisions 0 Symbol error frames
1687 Total collisions 0 False carrier errors
0 Control frames 0 Valid frames, too small
0 VLAN discard frames 0 Valid frames, too large
0 Too old frames 27806 Invalid frames, too small
2273476 Tagged frames 0 Invalid frames, too large
0 Aborted Tx frames 0 Discarded frames


FCS errors, alignment errors etc etc ... where do i begin?
Checking cables are the obvious first step, but where do i go next?

Best regards
Ole Vik







 
Reply With Quote
 
 
 
 
Walter Roberson
Guest
Posts: n/a
 
      11-05-2003
In article <1068025632.826588@gurney>, Ole Vik <(E-Mail Removed)> wrote:
:The scenario is this:

:We have a switch (Cisco 2950G) connected to a dsl modem on port 0/24.
:The port is configured as a trunk port, as we have a vlan segmented line.
Internal and secure zones).

:interface FastEthernet0/24
: description VLAN trunk
: switchport trunk allowed vlan 1,1002-1005,1179,1180
: switchport mode trunk
: no ip address
:speed 10
:duplex half
The modem is set to 10/half , so those settings are ok. )


Could I ask you to confirm for us that the dsl line itself is configured
as an 802.1Q trunk? I do not recall ever having heard of an ISP
providing such a thing before.

DSL lines here are usually configured for PPP encapsulation (though
I have heard of DSL with no encapsulation.)

My first thought upon seeing your errors was "duplex mismatch".
However, the sort of errors you are seeing could, I think, also be caused
by trying to interpret a tagged line as untagged, or a PPP connection
as not being encapsulated. I seem to recall that in theory
trying to interpret an untagged line as tagged should be okay
because I seem to recall that packets in the management vlan are not
supposed to be tagged when sent across the VLAN... but if that's
not accurate, then interpreting an untagged line as tagged could
cause a mess too.
--
I was very young in those days, but I was also rather dim.
-- Christopher Priest
 
Reply With Quote
 
 
 
 
Ole Vik
Guest
Posts: n/a
 
      11-05-2003
Hi,

The lines support IEEE 802.1Q , and is delivered with vlans in the range
1000-3999.
More info on www.catchspeed.no (Sadly only in Norwegian).

The default Vlan 1 , is not in use, but i haven't bothered with removing it
from any trunks.
How much "mess" could this actually cause?

Any more info on the Alignment, FCS and the Invalid Frame errors would be
very much appreciated.


Best Regards
Ole Vik
"Walter Roberson" <(E-Mail Removed)-cnrc.gc.ca> wrote in message
news:boal8t$7uf$(E-Mail Removed)...
> In article <1068025632.826588@gurney>, Ole Vik <(E-Mail Removed)>

wrote:
> :The scenario is this:
>
> :We have a switch (Cisco 2950G) connected to a dsl modem on port 0/24.
> :The port is configured as a trunk port, as we have a vlan segmented line.
> Internal and secure zones).
>
> :interface FastEthernet0/24
> : description VLAN trunk
> : switchport trunk allowed vlan 1,1002-1005,1179,1180
> : switchport mode trunk
> : no ip address
> :speed 10
> :duplex half
> The modem is set to 10/half , so those settings are ok. )
>
>
> Could I ask you to confirm for us that the dsl line itself is configured
> as an 802.1Q trunk? I do not recall ever having heard of an ISP
> providing such a thing before.
>
> DSL lines here are usually configured for PPP encapsulation (though
> I have heard of DSL with no encapsulation.)
>
> My first thought upon seeing your errors was "duplex mismatch".
> However, the sort of errors you are seeing could, I think, also be caused
> by trying to interpret a tagged line as untagged, or a PPP connection
> as not being encapsulated. I seem to recall that in theory
> trying to interpret an untagged line as tagged should be okay
> because I seem to recall that packets in the management vlan are not
> supposed to be tagged when sent across the VLAN... but if that's
> not accurate, then interpreting an untagged line as tagged could
> cause a mess too.
> --
> I was very young in those days, but I was also rather dim.
> -- Christopher Priest



 
Reply With Quote
 
SKY
Guest
Posts: n/a
 
      11-05-2003
Alignment error: frames do not end with an even number of octets and had a
bad CRC.

FCS: frame check sequence error.

All of these seems result from physical error. (cable, fa0/24 or dsl modem)

besides check the cable, you could try changing another port to see if
fa0/24 of the switch fault.
And using another device on fa0/24 to see if the dsl modem fault

regards,
SKY


"Ole Vik" <(E-Mail Removed)> bl news:1068037622.19105@gurney g
....
> Hi,
>
> The lines support IEEE 802.1Q , and is delivered with vlans in the range
> 1000-3999.
> More info on www.catchspeed.no (Sadly only in Norwegian).
>
> The default Vlan 1 , is not in use, but i haven't bothered with removing

it
> from any trunks.
> How much "mess" could this actually cause?
>
> Any more info on the Alignment, FCS and the Invalid Frame errors would be
> very much appreciated.
>
>
> Best Regards
> Ole Vik
> "Walter Roberson" <(E-Mail Removed)-cnrc.gc.ca> wrote in message
> news:boal8t$7uf$(E-Mail Removed)...
> > In article <1068025632.826588@gurney>, Ole Vik <(E-Mail Removed)>

> wrote:
> > :The scenario is this:
> >
> > :We have a switch (Cisco 2950G) connected to a dsl modem on port 0/24.
> > :The port is configured as a trunk port, as we have a vlan segmented

line.
> > Internal and secure zones).
> >
> > :interface FastEthernet0/24
> > : description VLAN trunk
> > : switchport trunk allowed vlan 1,1002-1005,1179,1180
> > : switchport mode trunk
> > : no ip address
> > :speed 10
> > :duplex half
> > The modem is set to 10/half , so those settings are ok. )
> >
> >
> > Could I ask you to confirm for us that the dsl line itself is configured
> > as an 802.1Q trunk? I do not recall ever having heard of an ISP
> > providing such a thing before.
> >
> > DSL lines here are usually configured for PPP encapsulation (though
> > I have heard of DSL with no encapsulation.)
> >
> > My first thought upon seeing your errors was "duplex mismatch".
> > However, the sort of errors you are seeing could, I think, also be

caused
> > by trying to interpret a tagged line as untagged, or a PPP connection
> > as not being encapsulated. I seem to recall that in theory
> > trying to interpret an untagged line as tagged should be okay
> > because I seem to recall that packets in the management vlan are not
> > supposed to be tagged when sent across the VLAN... but if that's
> > not accurate, then interpreting an untagged line as tagged could
> > cause a mess too.
> > --
> > I was very young in those days, but I was also rather dim.
> > -- Christopher Priest

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help troubleshooting CRC errors pfisterfarm Cisco 4 09-22-2009 01:40 AM
Connecting 2 2950G's via Fibre GBICs wally Cisco 8 03-28-2006 04:31 PM
2950G duplex bug? edavid3001@gmail.com Cisco 2 06-14-2005 02:48 PM
802.1x + RADIUS Session-Timeout / Termination-Action + Catalyst 2950G Matt Cisco 4 11-10-2004 05:54 PM
crc errors on a 2950G - 3750 link Trent Collicutt Cisco 12 05-07-2004 12:42 PM



Advertisments