Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Default runtime error page regardless of customerrors setting

Reply
Thread Tools

Default runtime error page regardless of customerrors setting

 
 
kristan.mcdonald@googlemail.com
Guest
Posts: n/a
 
      06-09-2006
Probably a simple one, but I've found nothing in groups or google so
here goes;
trying to deploy a simple .net asp app to our web server, which has
been hardended as it's public facing. It's only ever run classic asp
apps before. I've tried to upload a basic app with nothing but an empty
web form, and I get the default "Runtime error, The custom error
settings prevent you blah"

I've tried setting customErrors but I get the same page, I've tried
aspnet_regiis -i to reinstall, I've tried doing a -ua then an -i to
remove and install. I'm guessing it's something to do with whatever
security settings were applied to the box, but I've even tried giving
everyone full control to the folder and still nothing!

Please has anyone got any ideas?

ta

 
Reply With Quote
 
 
 
 
=?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=
Guest
Posts: n/a
 
      06-09-2006
If this is IIS 6.0, have you "Allowed" the webservice extension for ASP.NET?
They all come locked down by default, except for plain old HTML.
Peter

--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com




"(E-Mail Removed)" wrote:

> Probably a simple one, but I've found nothing in groups or google so
> here goes;
> trying to deploy a simple .net asp app to our web server, which has
> been hardended as it's public facing. It's only ever run classic asp
> apps before. I've tried to upload a basic app with nothing but an empty
> web form, and I get the default "Runtime error, The custom error
> settings prevent you blah"
>
> I've tried setting customErrors but I get the same page, I've tried
> aspnet_regiis -i to reinstall, I've tried doing a -ua then an -i to
> remove and install. I'm guessing it's something to do with whatever
> security settings were applied to the box, but I've even tried giving
> everyone full control to the folder and still nothing!
>
> Please has anyone got any ideas?
>
> ta
>
>

 
Reply With Quote
 
 
 
 
kristan.mcdonald@googlemail.com
Guest
Posts: n/a
 
      06-09-2006
Yeah, but thanks for reminding me to check though - "ASP.NET v1.1.4322
Allowed". Any other ideas?

Peter wrote:
> If this is IIS 6.0, have you "Allowed" the webservice extension for ASP.NET?
> They all come locked down by default, except for plain old HTML.
> Peter
>
> --
> Co-founder, Eggheadcafe.com developer portal:
> http://www.eggheadcafe.com
> UnBlog:
> http://petesbloggerama.blogspot.com
>
>
>
>
> "(E-Mail Removed)" wrote:
>
> > Probably a simple one, but I've found nothing in groups or google so
> > here goes;
> > trying to deploy a simple .net asp app to our web server, which has
> > been hardended as it's public facing. It's only ever run classic asp
> > apps before. I've tried to upload a basic app with nothing but an empty
> > web form, and I get the default "Runtime error, The custom error
> > settings prevent you blah"
> >
> > I've tried setting customErrors but I get the same page, I've tried
> > aspnet_regiis -i to reinstall, I've tried doing a -ua then an -i to
> > remove and install. I'm guessing it's something to do with whatever
> > security settings were applied to the box, but I've even tried giving
> > everyone full control to the folder and still nothing!
> >
> > Please has anyone got any ideas?
> >
> > ta
> >
> >


 
Reply With Quote
 
kristan.mcdonald@googlemail.com
Guest
Posts: n/a
 
      06-09-2006
Just to thicken the plot slightly, if I just copy a default app up I
get told
"Server cannot access application directory 'E:\site\atest\'. The
directory does not exist or is not accessible because of security
settings. "

This is true, and interestingly I get the footer giving me the
information about the framework and asp.net versions. If I grant
permissions to the relevant accounts, I get the default runtime error
page, but without the footer. It's like it can't find some part of
asp.net and it giving up.

http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> Yeah, but thanks for reminding me to check though - "ASP.NET v1.1.4322
> Allowed". Any other ideas?
>
> Peter wrote:
> > If this is IIS 6.0, have you "Allowed" the webservice extension for ASP.NET?
> > They all come locked down by default, except for plain old HTML.
> > Peter
> >
> > --
> > Co-founder, Eggheadcafe.com developer portal:
> > http://www.eggheadcafe.com
> > UnBlog:
> > http://petesbloggerama.blogspot.com
> >
> >
> >
> >
> > "(E-Mail Removed)" wrote:
> >
> > > Probably a simple one, but I've found nothing in groups or google so
> > > here goes;
> > > trying to deploy a simple .net asp app to our web server, which has
> > > been hardended as it's public facing. It's only ever run classic asp
> > > apps before. I've tried to upload a basic app with nothing but an empty
> > > web form, and I get the default "Runtime error, The custom error
> > > settings prevent you blah"
> > >
> > > I've tried setting customErrors but I get the same page, I've tried
> > > aspnet_regiis -i to reinstall, I've tried doing a -ua then an -i to
> > > remove and install. I'm guessing it's something to do with whatever
> > > security settings were applied to the box, but I've even tried giving
> > > everyone full control to the folder and still nothing!
> > >
> > > Please has anyone got any ideas?
> > >
> > > ta
> > >
> > >


 
Reply With Quote
 
kristan.mcdonald@googlemail.com
Guest
Posts: n/a
 
      06-09-2006
horrah, got it working!

In case anyone else has problems with this, I edited the machine.config
to set customerrors to off, go the actual error (which was due to me
being stupid, as I didn't grant asp.net permissions to the folder of
the website, only the app folder which was underneath) and now it
works. Only taken me 5 hours!!

(E-Mail Removed) wrote:
> Just to thicken the plot slightly, if I just copy a default app up I
> get told
> "Server cannot access application directory 'E:\site\atest\'. The
> directory does not exist or is not accessible because of security
> settings. "
>
> This is true, and interestingly I get the footer giving me the
> information about the framework and asp.net versions. If I grant
> permissions to the relevant accounts, I get the default runtime error
> page, but without the footer. It's like it can't find some part of
> asp.net and it giving up.
>
> (E-Mail Removed) wrote:
> > Yeah, but thanks for reminding me to check though - "ASP.NET v1.1.4322
> > Allowed". Any other ideas?
> >
> > Peter wrote:
> > > If this is IIS 6.0, have you "Allowed" the webservice extension for ASP.NET?
> > > They all come locked down by default, except for plain old HTML.
> > > Peter
> > >
> > > --
> > > Co-founder, Eggheadcafe.com developer portal:
> > > http://www.eggheadcafe.com
> > > UnBlog:
> > > http://petesbloggerama.blogspot.com
> > >
> > >
> > >
> > >
> > > "(E-Mail Removed)" wrote:
> > >
> > > > Probably a simple one, but I've found nothing in groups or google so
> > > > here goes;
> > > > trying to deploy a simple .net asp app to our web server, which has
> > > > been hardended as it's public facing. It's only ever run classic asp
> > > > apps before. I've tried to upload a basic app with nothing but an empty
> > > > web form, and I get the default "Runtime error, The custom error
> > > > settings prevent you blah"
> > > >
> > > > I've tried setting customErrors but I get the same page, I've tried
> > > > aspnet_regiis -i to reinstall, I've tried doing a -ua then an -i to
> > > > remove and install. I'm guessing it's something to do with whatever
> > > > security settings were applied to the box, but I've even tried giving
> > > > everyone full control to the folder and still nothing!
> > > >
> > > > Please has anyone got any ideas?
> > > >
> > > > ta
> > > >
> > > >


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make page dispay regardless of file extension CSINVA ASP .Net 1 11-08-2007 04:42 PM
URL Unchanged Regardless of Page Viewed Bob Johnson ASP .Net 1 06-26-2007 08:22 PM
Runtime error when customErrors are Off Justin Dutoit ASP .Net 0 06-11-2007 04:32 AM
redirect missing php page to aspx page - CustomErrors won't work? Les Caudle ASP .Net 0 10-31-2006 12:31 AM
IE6 always rejects a particular cookie regardless of privacy/cookie setting Timur Tabi Javascript 1 05-14-2004 09:13 PM



Advertisments