Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Redistribution between IS-IS, EIGRP & OSPF

Reply
Thread Tools

Redistribution between IS-IS, EIGRP & OSPF

 
 
Sam Soh
Guest
Posts: n/a
 
      08-12-2003
Termserver---R1---R3
\--R7--/
R1, R7, and R3 connect altogether in ethernet interfaces.
Termserver connect to R1 thru serial to R1
Termserver connect to R7 thru serial to R7

Termserver, R1 and R7 are running IS-IS.
R1, R7 and R3 are running EIGRP.
R3 is running OSPF and attached to the OSPF network.
All the redistribution looks just fine, EXCEPT the serial interfaces
between Termserver, R1, and R7 (which is 135.3.117.X 255.255.255.240
network) cannot be seen in routing tables of R3 and the continuing
OSPF network.

TermServer#
interface Loopback11
ip address 135.3.251.11 255.255.255.192
ip router isis
!
interface Serial0
ip address 135.3.117.11 255.255.255.240 (isis network connect to
R1&R7)
ip router isis
clockrate 64000
!
interface Serial1
ip address 135.3.117.12 255.255.255.240 (isis network connect to
R1&R7)
ip router isis
clockrate 64000
!
router isis
net 49.0001.0000.0000.000a.00

R1#
interface Loopback10
ip address 135.3.1.1 255.255.255.0
!
interface Loopback11
ip address 135.3.11.1 255.255.255.192
ip router isis
!
interface Ethernet0
ip address 135.3.137.1 255.255.255.0 (EIGRP network connect to R7&R3)
!
interface Serial0
ip address 135.3.117.1 255.255.255.240 (isis network connect to
Termserver&R7)
ip router isis
!
router eigrp 1
redistribute isis level-1-2 metric 1 100 255 150 1500
network 135.3.1.0 0.0.0.255
network 135.3.137.0 0.0.0.255
no auto-summary
!
router isis
net 49.0001.0000.0000.000b.00
redistribute eigrp 1 metric 20

R7#
interface Loopback10
ip address 135.3.7.7 255.255.255.0
!
interface Loopback77
ip address 135.3.77.7 255.255.255.192
ip router isis
!
interface Ethernet0
ip address 135.3.137.7 255.255.255.0 (EIGRP network connect to R1&R3)
!
interface Serial0
ip address 135.3.117.7 255.255.255.240 (isis network connect to R1&
Termserver)
ip router isis
!
router eigrp 1
redistribute isis level-1-2 metric 1 100 255 150 1500
network 135.3.7.0 0.0.0.255
network 135.3.137.0 0.0.0.255
no auto-summary
!
router isis
net 49.0001.0000.0000.000c.00
redistribute eigrp 1 metric 20

R3#
interface Loopback10
ip address 135.3.3.3 255.255.255.0
!
interface Loopback20
ip address 135.3.33.33 255.255.255.0
!
interface Ethernet0
ip address 135.3.137.3 255.255.255.0 (EIGRP network connect to R7&R3)
!
router eigrp 1
redistribute ospf 1
network 135.3.33.0 0.0.0.255
network 135.3.137.0 0.0.0.255
default-metric 10000 100 255 1 1500
no auto-summary
!
router ospf 1
router-id 135.3.3.3
log-adjacency-changes
redistribute eigrp 1 subnets
network 135.3.3.0 0.0.0.255 area 0
network 135.3.34.0 0.0.0.7 area 0
network 135.3.53.0 0.0.0.255 area 5
neighbor 135.3.53.5 priority 1

Network 135.3.117.X can not be seen in R3. Help, please anybody.

Best Regards,
Sam
 
Reply With Quote
 
 
 
 
The Real Slim Shady
Guest
Posts: n/a
 
      08-12-2003
On R1 and R7, you need to do a redistribute connected under the EIGRP
process. Networks that are part of the ISIS process on directly connected
interfaces on a router DO NOT get redistributed into the receiving protocol
(EIGRP in your case) - you have to do a redistribute connected to get them
there. This is NOT the case with any other IGP - it is unique to ISIS on
cisco boxes.

This is the reason that R3 cannot see the two serial interface routes.

This is a common trap in the real world and on certain cisco "practical"
exams!!


"Sam Soh" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) om...
> Termserver---R1---R3
> \--R7--/
> R1, R7, and R3 connect altogether in ethernet interfaces.
> Termserver connect to R1 thru serial to R1
> Termserver connect to R7 thru serial to R7
>
> Termserver, R1 and R7 are running IS-IS.
> R1, R7 and R3 are running EIGRP.
> R3 is running OSPF and attached to the OSPF network.
> All the redistribution looks just fine, EXCEPT the serial interfaces
> between Termserver, R1, and R7 (which is 135.3.117.X 255.255.255.240
> network) cannot be seen in routing tables of R3 and the continuing
> OSPF network.
>
> TermServer#
> interface Loopback11
> ip address 135.3.251.11 255.255.255.192
> ip router isis
> !
> interface Serial0
> ip address 135.3.117.11 255.255.255.240 (isis network connect to
> R1&R7)
> ip router isis
> clockrate 64000
> !
> interface Serial1
> ip address 135.3.117.12 255.255.255.240 (isis network connect to
> R1&R7)
> ip router isis
> clockrate 64000
> !
> router isis
> net 49.0001.0000.0000.000a.00
>
> R1#
> interface Loopback10
> ip address 135.3.1.1 255.255.255.0
> !
> interface Loopback11
> ip address 135.3.11.1 255.255.255.192
> ip router isis
> !
> interface Ethernet0
> ip address 135.3.137.1 255.255.255.0 (EIGRP network connect to R7&R3)
> !
> interface Serial0
> ip address 135.3.117.1 255.255.255.240 (isis network connect to
> Termserver&R7)
> ip router isis
> !
> router eigrp 1
> redistribute isis level-1-2 metric 1 100 255 150 1500
> network 135.3.1.0 0.0.0.255
> network 135.3.137.0 0.0.0.255
> no auto-summary
> !
> router isis
> net 49.0001.0000.0000.000b.00
> redistribute eigrp 1 metric 20
>
> R7#
> interface Loopback10
> ip address 135.3.7.7 255.255.255.0
> !
> interface Loopback77
> ip address 135.3.77.7 255.255.255.192
> ip router isis
> !
> interface Ethernet0
> ip address 135.3.137.7 255.255.255.0 (EIGRP network connect to R1&R3)
> !
> interface Serial0
> ip address 135.3.117.7 255.255.255.240 (isis network connect to R1&
> Termserver)
> ip router isis
> !
> router eigrp 1
> redistribute isis level-1-2 metric 1 100 255 150 1500
> network 135.3.7.0 0.0.0.255
> network 135.3.137.0 0.0.0.255
> no auto-summary
> !
> router isis
> net 49.0001.0000.0000.000c.00
> redistribute eigrp 1 metric 20
>
> R3#
> interface Loopback10
> ip address 135.3.3.3 255.255.255.0
> !
> interface Loopback20
> ip address 135.3.33.33 255.255.255.0
> !
> interface Ethernet0
> ip address 135.3.137.3 255.255.255.0 (EIGRP network connect to R7&R3)
> !
> router eigrp 1
> redistribute ospf 1
> network 135.3.33.0 0.0.0.255
> network 135.3.137.0 0.0.0.255
> default-metric 10000 100 255 1 1500
> no auto-summary
> !
> router ospf 1
> router-id 135.3.3.3
> log-adjacency-changes
> redistribute eigrp 1 subnets
> network 135.3.3.0 0.0.0.255 area 0
> network 135.3.34.0 0.0.0.7 area 0
> network 135.3.53.0 0.0.0.255 area 5
> neighbor 135.3.53.5 priority 1
>
> Network 135.3.117.X can not be seen in R3. Help, please anybody.
>
> Best Regards,
> Sam



 
Reply With Quote
 
 
 
 
slarmas
Guest
Posts: n/a
 
      08-14-2003
Wow, somone actually running ISIS? Talk about shock and awe


"Sam Soh" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) om...
> Termserver---R1---R3
> \--R7--/
> R1, R7, and R3 connect altogether in ethernet interfaces.
> Termserver connect to R1 thru serial to R1
> Termserver connect to R7 thru serial to R7
>
> Termserver, R1 and R7 are running IS-IS.
> R1, R7 and R3 are running EIGRP.
> R3 is running OSPF and attached to the OSPF network.
> All the redistribution looks just fine, EXCEPT the serial interfaces
> between Termserver, R1, and R7 (which is 135.3.117.X 255.255.255.240
> network) cannot be seen in routing tables of R3 and the continuing
> OSPF network.
>
> TermServer#
> interface Loopback11
> ip address 135.3.251.11 255.255.255.192
> ip router isis
> !
> interface Serial0
> ip address 135.3.117.11 255.255.255.240 (isis network connect to
> R1&R7)
> ip router isis
> clockrate 64000
> !
> interface Serial1
> ip address 135.3.117.12 255.255.255.240 (isis network connect to
> R1&R7)
> ip router isis
> clockrate 64000
> !
> router isis
> net 49.0001.0000.0000.000a.00
>
> R1#
> interface Loopback10
> ip address 135.3.1.1 255.255.255.0
> !
> interface Loopback11
> ip address 135.3.11.1 255.255.255.192
> ip router isis
> !
> interface Ethernet0
> ip address 135.3.137.1 255.255.255.0 (EIGRP network connect to R7&R3)
> !
> interface Serial0
> ip address 135.3.117.1 255.255.255.240 (isis network connect to
> Termserver&R7)
> ip router isis
> !
> router eigrp 1
> redistribute isis level-1-2 metric 1 100 255 150 1500
> network 135.3.1.0 0.0.0.255
> network 135.3.137.0 0.0.0.255
> no auto-summary
> !
> router isis
> net 49.0001.0000.0000.000b.00
> redistribute eigrp 1 metric 20
>
> R7#
> interface Loopback10
> ip address 135.3.7.7 255.255.255.0
> !
> interface Loopback77
> ip address 135.3.77.7 255.255.255.192
> ip router isis
> !
> interface Ethernet0
> ip address 135.3.137.7 255.255.255.0 (EIGRP network connect to R1&R3)
> !
> interface Serial0
> ip address 135.3.117.7 255.255.255.240 (isis network connect to R1&
> Termserver)
> ip router isis
> !
> router eigrp 1
> redistribute isis level-1-2 metric 1 100 255 150 1500
> network 135.3.7.0 0.0.0.255
> network 135.3.137.0 0.0.0.255
> no auto-summary
> !
> router isis
> net 49.0001.0000.0000.000c.00
> redistribute eigrp 1 metric 20
>
> R3#
> interface Loopback10
> ip address 135.3.3.3 255.255.255.0
> !
> interface Loopback20
> ip address 135.3.33.33 255.255.255.0
> !
> interface Ethernet0
> ip address 135.3.137.3 255.255.255.0 (EIGRP network connect to R7&R3)
> !
> router eigrp 1
> redistribute ospf 1
> network 135.3.33.0 0.0.0.255
> network 135.3.137.0 0.0.0.255
> default-metric 10000 100 255 1 1500
> no auto-summary
> !
> router ospf 1
> router-id 135.3.3.3
> log-adjacency-changes
> redistribute eigrp 1 subnets
> network 135.3.3.0 0.0.0.255 area 0
> network 135.3.34.0 0.0.0.7 area 0
> network 135.3.53.0 0.0.0.255 area 5
> neighbor 135.3.53.5 priority 1
>
> Network 135.3.117.X can not be seen in R3. Help, please anybody.
>
> Best Regards,
> Sam



 
Reply With Quote
 
The Real Slim Shady
Guest
Posts: n/a
 
      08-14-2003
You are welcome. Bear in mind that ISIS only works in broadcast networks
and point to point links. It does not work on multipoint or NBMA networks.
I understand Cisco are addressing this. However, in the meantime this has
design and IP address implications in networks that currently run OSPF and
are migrating to ISIS.

Slim


"Sam Soh" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) om...
> WOW....Thanks alot, Real Slim Shady.
> I really appreciate the answer. For a whole day, I thought my weird
> problem won't be solved. Thank you alot.
>
> Best Regards,
> Sam
>
> "The Real Slim Shady" <(E-Mail Removed)> wrote in message

news:<bhaiei$105uga$(E-Mail Removed)-berlin.de>...
> > On R1 and R7, you need to do a redistribute connected under the EIGRP
> > process. Networks that are part of the ISIS process on directly

connected
> > interfaces on a router DO NOT get redistributed into the receiving

protocol
> > (EIGRP in your case) - you have to do a redistribute connected to get

them
> > there. This is NOT the case with any other IGP - it is unique to ISIS

on
> > cisco boxes.
> >
> > This is the reason that R3 cannot see the two serial interface routes.
> >
> > This is a common trap in the real world and on certain cisco "practical"
> > exams!!
> >
> >
> > "Sam Soh" <(E-Mail Removed)> wrote in message
> > news:(E-Mail Removed) om...
> > > Termserver---R1---R3
> > > \--R7--/
> > > R1, R7, and R3 connect altogether in ethernet interfaces.
> > > Termserver connect to R1 thru serial to R1
> > > Termserver connect to R7 thru serial to R7
> > >
> > > Termserver, R1 and R7 are running IS-IS.
> > > R1, R7 and R3 are running EIGRP.
> > > R3 is running OSPF and attached to the OSPF network.
> > > All the redistribution looks just fine, EXCEPT the serial interfaces
> > > between Termserver, R1, and R7 (which is 135.3.117.X 255.255.255.240
> > > network) cannot be seen in routing tables of R3 and the continuing
> > > OSPF network.
> > >
> > > TermServer#
> > > interface Loopback11
> > > ip address 135.3.251.11 255.255.255.192
> > > ip router isis
> > > !
> > > interface Serial0
> > > ip address 135.3.117.11 255.255.255.240 (isis network connect to
> > > R1&R7)
> > > ip router isis
> > > clockrate 64000
> > > !
> > > interface Serial1
> > > ip address 135.3.117.12 255.255.255.240 (isis network connect to
> > > R1&R7)
> > > ip router isis
> > > clockrate 64000
> > > !
> > > router isis
> > > net 49.0001.0000.0000.000a.00
> > >
> > > R1#
> > > interface Loopback10
> > > ip address 135.3.1.1 255.255.255.0
> > > !
> > > interface Loopback11
> > > ip address 135.3.11.1 255.255.255.192
> > > ip router isis
> > > !
> > > interface Ethernet0
> > > ip address 135.3.137.1 255.255.255.0 (EIGRP network connect to R7&R3)
> > > !
> > > interface Serial0
> > > ip address 135.3.117.1 255.255.255.240 (isis network connect to
> > > Termserver&R7)
> > > ip router isis
> > > !
> > > router eigrp 1
> > > redistribute isis level-1-2 metric 1 100 255 150 1500
> > > network 135.3.1.0 0.0.0.255
> > > network 135.3.137.0 0.0.0.255
> > > no auto-summary
> > > !
> > > router isis
> > > net 49.0001.0000.0000.000b.00
> > > redistribute eigrp 1 metric 20
> > >
> > > R7#
> > > interface Loopback10
> > > ip address 135.3.7.7 255.255.255.0
> > > !
> > > interface Loopback77
> > > ip address 135.3.77.7 255.255.255.192
> > > ip router isis
> > > !
> > > interface Ethernet0
> > > ip address 135.3.137.7 255.255.255.0 (EIGRP network connect to R1&R3)
> > > !
> > > interface Serial0
> > > ip address 135.3.117.7 255.255.255.240 (isis network connect to R1&
> > > Termserver)
> > > ip router isis
> > > !
> > > router eigrp 1
> > > redistribute isis level-1-2 metric 1 100 255 150 1500
> > > network 135.3.7.0 0.0.0.255
> > > network 135.3.137.0 0.0.0.255
> > > no auto-summary
> > > !
> > > router isis
> > > net 49.0001.0000.0000.000c.00
> > > redistribute eigrp 1 metric 20
> > >
> > > R3#
> > > interface Loopback10
> > > ip address 135.3.3.3 255.255.255.0
> > > !
> > > interface Loopback20
> > > ip address 135.3.33.33 255.255.255.0
> > > !
> > > interface Ethernet0
> > > ip address 135.3.137.3 255.255.255.0 (EIGRP network connect to R7&R3)
> > > !
> > > router eigrp 1
> > > redistribute ospf 1
> > > network 135.3.33.0 0.0.0.255
> > > network 135.3.137.0 0.0.0.255
> > > default-metric 10000 100 255 1 1500
> > > no auto-summary
> > > !
> > > router ospf 1
> > > router-id 135.3.3.3
> > > log-adjacency-changes
> > > redistribute eigrp 1 subnets
> > > network 135.3.3.0 0.0.0.255 area 0
> > > network 135.3.34.0 0.0.0.7 area 0
> > > network 135.3.53.0 0.0.0.255 area 5
> > > neighbor 135.3.53.5 priority 1
> > >
> > > Network 135.3.117.X can not be seen in R3. Help, please anybody.
> > >
> > > Best Regards,
> > > Sam



 
Reply With Quote
 
The Real Slim Shady
Guest
Posts: n/a
 
      08-14-2003
ISIS is a very powerful protocol that can scale to many thousands of nodes.
It does not employ the area 0 principle in the way that OSPF does so you do
not have to connect every area to area 0 - only to the set of contiguous L2
routers. The ISIS book by Abe Martey is a must read if you are into this
protocol.

Slim


"slarmas" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Wow, somone actually running ISIS? Talk about shock and awe
>
>
> "Sam Soh" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed) om...
> > Termserver---R1---R3
> > \--R7--/
> > R1, R7, and R3 connect altogether in ethernet interfaces.
> > Termserver connect to R1 thru serial to R1
> > Termserver connect to R7 thru serial to R7
> >
> > Termserver, R1 and R7 are running IS-IS.
> > R1, R7 and R3 are running EIGRP.
> > R3 is running OSPF and attached to the OSPF network.
> > All the redistribution looks just fine, EXCEPT the serial interfaces
> > between Termserver, R1, and R7 (which is 135.3.117.X 255.255.255.240
> > network) cannot be seen in routing tables of R3 and the continuing
> > OSPF network.
> >
> > TermServer#
> > interface Loopback11
> > ip address 135.3.251.11 255.255.255.192
> > ip router isis
> > !
> > interface Serial0
> > ip address 135.3.117.11 255.255.255.240 (isis network connect to
> > R1&R7)
> > ip router isis
> > clockrate 64000
> > !
> > interface Serial1
> > ip address 135.3.117.12 255.255.255.240 (isis network connect to
> > R1&R7)
> > ip router isis
> > clockrate 64000
> > !
> > router isis
> > net 49.0001.0000.0000.000a.00
> >
> > R1#
> > interface Loopback10
> > ip address 135.3.1.1 255.255.255.0
> > !
> > interface Loopback11
> > ip address 135.3.11.1 255.255.255.192
> > ip router isis
> > !
> > interface Ethernet0
> > ip address 135.3.137.1 255.255.255.0 (EIGRP network connect to R7&R3)
> > !
> > interface Serial0
> > ip address 135.3.117.1 255.255.255.240 (isis network connect to
> > Termserver&R7)
> > ip router isis
> > !
> > router eigrp 1
> > redistribute isis level-1-2 metric 1 100 255 150 1500
> > network 135.3.1.0 0.0.0.255
> > network 135.3.137.0 0.0.0.255
> > no auto-summary
> > !
> > router isis
> > net 49.0001.0000.0000.000b.00
> > redistribute eigrp 1 metric 20
> >
> > R7#
> > interface Loopback10
> > ip address 135.3.7.7 255.255.255.0
> > !
> > interface Loopback77
> > ip address 135.3.77.7 255.255.255.192
> > ip router isis
> > !
> > interface Ethernet0
> > ip address 135.3.137.7 255.255.255.0 (EIGRP network connect to R1&R3)
> > !
> > interface Serial0
> > ip address 135.3.117.7 255.255.255.240 (isis network connect to R1&
> > Termserver)
> > ip router isis
> > !
> > router eigrp 1
> > redistribute isis level-1-2 metric 1 100 255 150 1500
> > network 135.3.7.0 0.0.0.255
> > network 135.3.137.0 0.0.0.255
> > no auto-summary
> > !
> > router isis
> > net 49.0001.0000.0000.000c.00
> > redistribute eigrp 1 metric 20
> >
> > R3#
> > interface Loopback10
> > ip address 135.3.3.3 255.255.255.0
> > !
> > interface Loopback20
> > ip address 135.3.33.33 255.255.255.0
> > !
> > interface Ethernet0
> > ip address 135.3.137.3 255.255.255.0 (EIGRP network connect to R7&R3)
> > !
> > router eigrp 1
> > redistribute ospf 1
> > network 135.3.33.0 0.0.0.255
> > network 135.3.137.0 0.0.0.255
> > default-metric 10000 100 255 1 1500
> > no auto-summary
> > !
> > router ospf 1
> > router-id 135.3.3.3
> > log-adjacency-changes
> > redistribute eigrp 1 subnets
> > network 135.3.3.0 0.0.0.255 area 0
> > network 135.3.34.0 0.0.0.7 area 0
> > network 135.3.53.0 0.0.0.255 area 5
> > neighbor 135.3.53.5 priority 1
> >
> > Network 135.3.117.X can not be seen in R3. Help, please anybody.
> >
> > Best Regards,
> > Sam

>
>



 
Reply With Quote
 
Sam Soh
Guest
Posts: n/a
 
      08-15-2003
Slim,
I really do appreciate your commentary and help solving my problem. In
the mean time I have been reading the RFC about this powerful ISIS. I
sure will buy the book. Thanks Slim.

Best Regards,
Sam Soh

p.s.
May I have your email, Slim?

"The Real Slim Shady" <(E-Mail Removed)> wrote in message news:<bhfvu0$b2p1$(E-Mail Removed)-berlin.de>...
> ISIS is a very powerful protocol that can scale to many thousands of nodes.
> It does not employ the area 0 principle in the way that OSPF does so you do
> not have to connect every area to area 0 - only to the set of contiguous L2
> routers. The ISIS book by Abe Martey is a must read if you are into this
> protocol.
>
> Slim

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bgp redistribution into Eigrp ciscokid Cisco 2 06-25-2012 10:41 AM
Newbie route redistribution eigrp into bgp question Sean.Evershed@gmail.com Cisco 3 06-25-2009 10:18 AM
ISIS and EIGRP mutual redistribution --Help! phillip Cisco 2 09-19-2008 08:27 PM
Redistribution into EIGRP problem Rob Cisco 14 12-21-2004 03:49 AM
route redistribution RIP and EIGRP slipstream_242 Cisco 1 07-15-2004 11:21 PM



Advertisments