Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > C++ > 'No symbols loaded' Warning During Debug

Reply
Thread Tools

'No symbols loaded' Warning During Debug

 
 
Adam Hartshorne
Guest
Posts: n/a
 
      04-24-2005
Hi All,

I was wondering if anybody can tell me the reason for the following
problem that occurs with a whole range of applications that I have
written in c++ using Visual Studio .NET 2003 and all compile without any
warnings.

Whatever application I run I get a whole host of the following types of
messages in the debug window during execution using the Debug->Start
option in Visual Studio


'chart.exe': Loaded 'C:\WINDOWS\system32\ntdll.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\kernel32.dll', No symbols loaded.

'chart.exe': Loaded 'C:\WINDOWS\system32\user32.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\gdi32.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\advapi32.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\rpcrt4.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\shell32.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\msvcrt.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\shlwapi.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\ole32.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\imm32.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\winspool.drv', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\msvcp60.dll', No symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\msvcp71.dll', Symbols loaded.
'chart.exe': Loaded 'C:\WINDOWS\system32\Msvcr71.dll', Symbols loaded.


Any ideas why this occurs, as it doesn't affect the execution of the
program?

Adam
 
Reply With Quote
 
 
 
 
Jack Klein
Guest
Posts: n/a
 
      04-25-2005
On Sun, 24 Apr 2005 16:28:48 +0100, Adam Hartshorne
<(E-Mail Removed)> wrote in comp.lang.c++:

> Hi All,
>
> I was wondering if anybody can tell me the reason for the following
> problem that occurs with a whole range of applications that I have
> written in c++ using Visual Studio .NET 2003 and all compile without any
> warnings.


[snip]

Most likely somebody in a Windows programming group like
news:comp.os.ms-windows.programmer.win32, or one of Microsoft's many
support groups in the news:microsoft.public.* family.

We do not discuss non-language issues like debuggers here.

--
Jack Klein
Home: http://JK-Technology.Com
FAQs for
comp.lang.c http://www.eskimo.com/~scs/C-faq/top.html
comp.lang.c++ http://www.parashift.com/c++-faq-lite/
alt.comp.lang.learn.c-c++
http://www.contrib.andrew.cmu.edu/~a...FAQ-acllc.html
 
Reply With Quote
 
 
 
 
Pelle Beckman
Guest
Posts: n/a
 
      04-25-2005
Adam Hartshorne skrev:
> Hi All,
>
> I was wondering if anybody can tell me the reason for the following
> problem that occurs with a whole range of applications that I have
> written in c++ using Visual Studio .NET 2003 and all compile without any
> warnings.
>
> Whatever application I run I get a whole host of the following types of
> messages in the debug window during execution using the Debug->Start
> option in Visual Studio
>
>
> 'chart.exe': Loaded 'C:\WINDOWS\system32\ntdll.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\kernel32.dll', No symbols loaded.
>
> 'chart.exe': Loaded 'C:\WINDOWS\system32\user32.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\gdi32.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\advapi32.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\rpcrt4.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\shell32.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\msvcrt.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\shlwapi.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\ole32.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\imm32.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\winspool.drv', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\msvcp60.dll', No symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\msvcp71.dll', Symbols loaded.
> 'chart.exe': Loaded 'C:\WINDOWS\system32\Msvcr71.dll', Symbols loaded.
>
>
> Any ideas why this occurs, as it doesn't affect the execution of the
> program?
>
> Adam


This message is OT. Go to microsoft.public.x.xx

However, these are not error messages.
The debugger is merely telling you that above DLLs
were loaded, and that they contain no debugging info.

-- Pelle
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
debug symbols VS 2005 ASP .Net 9 04-20-2011 03:15 PM
Warning during generating classes through WSIMPORT & Error during xmlvalidation traveller Java 0 01-08-2008 07:00 AM
How to debug? "No Symbols Have Been Loaded" asdf ASP .Net 6 05-22-2007 12:51 PM
Can anyone recommend a source for information on debug symbols? markscottwright Java 2 09-18-2005 11:40 PM
Debug symbols not for all .aspx forms. =?Utf-8?B?QUs=?= ASP .Net 1 01-23-2004 11:48 AM



Advertisments