Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > tftp & ftp troubles

Reply
Thread Tools

tftp & ftp troubles

 
 
Draschl Clemens
Guest
Posts: n/a
 
      07-09-2003
hi,

seems, that I've got a strange thing on my cisco 1720, running IOS
12.1(5)-YB4. None of the copy-commands for backing up the startup-config or
updating the IOS in the flash works. I tried:

copy startup-config tft
copy startup-config ftp

copy tftp flash
copy ftp flash

Every time I recieve an error message like "%Error opening
flash:start-config (No such device)" when backing up the startup-config to
a ftp/tftp-server.

When i try to load an image from tftp/ftp, "%Error opening
ftp://usernameassword@location/ios-image (No such device)"

i verified the ftp-server and the tftp server, both are working correctly.
But it's funny, that backing up the IOS-image to the ftp-serve works well,
only copying back ends with one of the error-messages above. I've set the
tftp-source-interface (as far as I know, this only takes effect if the
router is a tftp-server itself), I minimized the interface, where the
tftp-server is connected to nothing, only the IP-address. No access-lists,
o fw/ids, no crypto. Nothing. But it doesn't work. Using the console cable
isn't possible due to geographical distance (Europe -> USA).

Anybody knows what's wrong here?


Thanks in advance

/cd

config:

Current configuration : 4483 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
!
logging rate-limit console 10 except errors
!
memory-size iomem 20
ip subnet-zero
!
!
no ip finger
no ip ftp passive
no ip domain-lookup
!
ip inspect name fw http java-list 51 timeout 30
ip inspect name fw smtp
ip inspect name fw h323
ip inspect name fw udp
ip inspect name fw ftp
ip inspect name fw fragment maximum 256 timeout 1
ip inspect name fw tcp
ip audit notify log
ip audit po max-events 100
no ip dhcp-client network-discovery
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.1.254 255.255.255.0
no ip redirects
ip nat inside
no ip route-cache
no ip mroute-cache
half-duplex
!
interface FastEthernet0
no ip address
shutdown
speed auto
!
interface Serial0
bandwidth 1024
ip address xxxx
no ip redirects
ip nat outside
ip inspect fw out
no ip route-cache
no ip mroute-cache
no fair-queue
!
ip nat inside source list 110 interface Serial0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
no ip http server
!
[access-lists]
!
!
!
line con 0
exec-timeout 0 0
transport input none
escape-character 27
line aux 0
line vty 0 4
exec-timeout 0 0
login
escape-character 27
!
end

 
Reply With Quote
 
 
 
 
REBOOT REBOOT is offline
Junior Member
Join Date: Oct 2008
Posts: 1
 
      10-08-2008
Try issuing the "dir" command at a CLI prompt:

This should tell you what filesystem type you're using.

Remember to use ftp you need to tell it the username and password

ip ftp username <name>
ip ftp password <passwd>

service password-encryptiton
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP vs TFTP JR Cisco 6 02-16-2010 04:56 AM
booting router from tftp: image is stored within a sub-dir in tftp root Sharad Cisco 0 02-13-2007 11:31 AM
FTP vs. TFTP JR Cisco 0 08-15-2004 07:56 PM
Net::FTP problems getting files from Windows FTP server, but not Linux FTP Server. D. Buck Perl Misc 2 06-29-2004 02:05 PM
error while copying ios image from flash to tftp or ftp server Saket Badola Cisco 3 04-05-2004 06:35 AM



Advertisments