Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl cgi not updating

Reply
Thread Tools

Perl cgi not updating

 
 
Mark Simon
Guest
Posts: n/a
 
      08-16-2004
I am having a very hard time trying to write a cgi script in perl.

Whenever I change the code, and call it from my form, I usually find
results from an older version of the scrip, though it happens
inconistently. Obviously something is being cached somewhere.

An example of this weirdness is when I write a line, and the script
stops working. Then I coment out the line, and the script works again.
OK, so I delete the line, but the script doesn't work again. I have one
print statement that I deleted half an hour ago, but I still get its output.

Or was it something I ate?

I am running Redhat 9, apache 2.0.48 and associated perl modules, and
testing from another machine running Mozilla on Windows XP.

Thanks,

Mark
 
Reply With Quote
 
 
 
 
Gunnar Hjalmarsson
Guest
Posts: n/a
 
      08-16-2004
Mark Simon wrote:
> I am having a very hard time trying to write a cgi script in perl.
>
> Whenever I change the code, and call it from my form, I usually
> find results from an older version of the scrip, though it happens
> inconistently. Obviously something is being cached somewhere.


Are you possibly running the script under mod_perl?

--
Gunnar Hjalmarsson
Email: http://www.gunnar.cc/cgi-bin/contact.pl
 
Reply With Quote
 
 
 
 
Mark Simon
Guest
Posts: n/a
 
      08-16-2004
I am. Is this not a Good Thing ... ?

Gunnar Hjalmarsson wrote:
> Mark Simon wrote:
>
>> I am having a very hard time trying to write a cgi script in perl.
>>
>> Whenever I change the code, and call it from my form, I usually
>> find results from an older version of the scrip, though it happens
>> inconistently. Obviously something is being cached somewhere.

>
>
> Are you possibly running the script under mod_perl?
>

 
Reply With Quote
 
Gunnar Hjalmarsson
Guest
Posts: n/a
 
      08-16-2004
Mark Simon wrote:
> Gunnar Hjalmarsson wrote:
>> Mark Simon wrote:
>>> I am having a very hard time trying to write a cgi script in
>>> perl.
>>>
>>> Whenever I change the code, and call it from my form, I usually
>>> find results from an older version of the scrip, though it
>>> happens inconistently. Obviously something is being cached
>>> somewhere.

>>
>> Are you possibly running the script under mod_perl?

>
> I am. Is this not a Good Thing ... ?


Well, as long as you don't understand what mod_perl does (and your
original post indicates that you don't), I suppose you'd better run
the script as a plain CGI script.

Of course, you can start learning about mod_perl:
http://perl.apache.org/

One way to ensure that code changes take effect when running programs
under mod_perl is to restart the Apache server.

--
Gunnar Hjalmarsson
Email: http://www.gunnar.cc/cgi-bin/contact.pl
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recommendation for a small web framework like Perl's CGI::Applicationto run as CGI? excord80 Python 17 01-29-2009 06:02 PM
what's wrong calling a Perl/CGI script in Perl/CGI script under Tomcat server? kath Perl Misc 4 04-09-2007 09:21 PM
Python-cgi or Perl-cgi script doubt praba kar Python 1 07-30-2005 08:25 AM
perl/cgi exploit with bracketed module names passed in as CGI param shumsta Perl Misc 1 07-21-2005 11:30 PM
Re: CGI Perl "use CGI" statement fail Jürgen Exner Perl 0 07-31-2003 02:00 PM



Advertisments