Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Callback not working following a postback

Reply
Thread Tools

Callback not working following a postback

 
 
ozy
Guest
Posts: n/a
 
      05-03-2006
Hi All,

I have a aspnet page that collects some simple data from the user. I
have implemented 1 of the fields as a "cascading combo box" (a pair of
drop down lists, where the second is populated based on the selection
made on the first). In ASP1.1 this was implemented using a postback
which occured when the user changed the first combo.

Now ASP2.0 has arrived, I have changed this implementation to use the
new Callback feature. This works great when you first get to the page.
However, if the user hits the save button (or does any thing else that
causes a PostBack) subsequent Callbacks do not occur as expected.

This is what I am seeing:
The client triggers the Callback. The Page_Load event fires on the
server, but the Page.IsCallback property returns false and neither the
RaiseCallbackEvent or the GetCallbackResult methods are called.

Any ideas?

Thanks in advance

Darren

 
Reply With Quote
 
 
 
 
ozy
Guest
Posts: n/a
 
      05-04-2006
OK I got there in the end. The page i was using also had
SmartNavigation="true" in the Page directive. This attribute (as far as
I can tell) has been deprecated in ASP.Net2.0. When I set this
attribute to false all my callbacks work as expected. The reason I had
the SmartNavigation set to true in the first place was because i wanted
to maintain the scroll position of the page on postback. I was able to
use the new MaintainScrollPositionOnPostback attribute of the page
directive instead, and all is working fine now!

Phew a happy ending

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Web server reported the following error when attempting to create or open the Web project located at the following URL: 'http://localhost/822319ev1'. 'HTTP/1.1 500 Internal Server Error'. chanmm ASP .Net 2 09-07-2010 07:37 AM
Following XSLT Logic not working sanket002 XML 0 10-23-2009 04:30 AM
Using callback, I fill dorpdownlist without postback but it gets empty when a postback is executed Fabio Mastria ASP .Net 5 01-30-2008 09:07 PM
Invalid postback or callback argument - Why only in IE and not Firefox? Alan Silver ASP .Net 1 07-05-2006 01:24 PM
RE: The Web server reported the following error when attempting to create or open the Web project located at the following URL: <URL> =?Utf-8?B?VHJldm9yIEJlbmVkaWN0IFI=?= ASP .Net 0 06-07-2004 07:36 AM



Advertisments