Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > VOIP > Voice Port Echo

Reply
Thread Tools

Voice Port Echo

 
 
TexasMirty@gmail.com
Guest
Posts: n/a
 
      05-02-2006
On a Cisco 2851 router / Call Manager Express, we have our T1 Voice
line set as follows:

In Gain is Set to 0 dB
Out Attenuation is Set to 0 dB
Echo Cancellation is enabled
Echo Cancellation NLP mute is disabled
Echo Cancellation NLP threshold is -21 dB
Echo Cancel Coverage is set to 64 ms
Echo Cancel worst case ERL is set to 6 dB

We are getting a lot of echo on calls to external analog phones.

We have tried different settings on the ERL, Echo Cancel Coverage,
Input Gain and Output Attenuation. So far nothing works to diminish the
echo. Cisco IOS version is 12.3(11).

Please advise. Thank you.

 
Reply With Quote
 
 
 
 
jay
Guest
Posts: n/a
 
      05-03-2006
Read up on how echo is formed. Its either feedback from the handset,
where gain adjustments help minimise the 'applitude' of the echo - and
the echo problem is therefore at how the remote end is setup (ie echo
on one end ?) - the router can only do so much, but maybe you tweaking
the end where the echo is ? instead of remote end ?

The real killer is analog to digital points in the network. Like where
you may have an E&M card to PABX ?

 
Reply With Quote
 
 
 
 
Zeng
Guest
Posts: n/a
 
      05-05-2006
On 3 May 2006 01:56:59 -0700, "jay" <(E-Mail Removed)> wrote:

>Read up on how echo is formed. Its either feedback from the handset,
>where gain adjustments help minimise the 'applitude' of the echo - and
>the echo problem is therefore at how the remote end is setup (ie echo
>on one end ?) - the router can only do so much, but maybe you tweaking
>the end where the echo is ? instead of remote end ?
>
>The real killer is analog to digital points in the network. Like where
>you may have an E&M card to PABX ?


Jay,
E&M cards are 4-wire devices, i.e., they use a separate pair for tx
audio and another pair for rcv audio with no hybrid involved.

TexasMirty,
I'm not sure about the Ciscos, but in PBX's and channel banks a 2db
loss and 3db on some chl-banks would be recommended values for a
Rcv-side loss-insertion.

I know you said you've played around with those, but maybe by changing
too many parameters in a short time you lost track of what was tried?

Assuming the analog phones are called parties directly connected to a
a Telco C.O., see the following:

Aside from acoustic echo which is probably not your issue (the handset
audio coupled back into mic element) the biggest offender is what's
hitting you--the 2-wire analog set. It uses a device called a hybrid.
Everytime you convert from 4-wire to two-wire, you need a "hybrid" to
accomplish that transition. (handset is 4-wire; telco 'drop' line is
2-wire. It's usually the impedance mismatches or challenges
accentuated by the hybrid devices that contribute and ultimately cause
the echo. The end-office E.O or C.O. has to take what arrives as a
"4-wire" (a separate path each way in other words) circuit [between
other Telco facilities i.e., that's how call gets there] and with the
line-side interface convert it to a 2=wire 'drop' to run to the house
or business. So, viewing it from the PSTN 'cloud' heading toward that
line-side drop, there's two hybrids. One in the E.O. and another in
the phone set. The whole point of this was not to place blame on the
Telco ckts, but rather to offer an understanding. Furthermore, if you
happen to place a call to an enterprise PBX that has digital trunks
(local loops) and then on top of that have digital or 4-wire phones on
the desk--then that will sound good; no echo.

Try inserting a 2 db loss and see what happens.

I can't believe I actually spent all this time doing that....must be
feeling really generous

Zeng
 
Reply With Quote
 
Jonathan
Guest
Posts: n/a
 
      05-14-2006

<(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
> On a Cisco 2851 router / Call Manager Express, we have our T1 Voice
> line set as follows:
>
> In Gain is Set to 0 dB
> Out Attenuation is Set to 0 dB


This is your problem.

You need 6 dB of separation.

> Echo Cancellation is enabled
> Echo Cancellation NLP mute is disabled
> Echo Cancellation NLP threshold is -21 dB
> Echo Cancel Coverage is set to 64 ms
> Echo Cancel worst case ERL is set to 6 dB
>
> We are getting a lot of echo on calls to external analog phones.
>
> We have tried different settings on the ERL, Echo Cancel Coverage,
> Input Gain and Output Attenuation. So far nothing works to diminish the
> echo. Cisco IOS version is 12.3(11).
>
> Please advise. Thank you.
>


Try this:

Output-gain -3 dB
Input Attenuation 3dB
Echo Cancel Coverage 64



Jonathan


--
NewsGuy.Com 30Gb $9.95 Carry Forward and On Demand Bandwidth
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Voice Port settings to minimize VOIP Echo TexasMirty@gmail.com Cisco 0 05-18-2006 03:46 PM
Voice Port Echo TexasMirty@gmail.com Cisco 2 05-14-2006 03:40 PM
echo echo echo craig judd Computer Support 1 09-23-2003 08:53 PM
voice chat under win2k: voice pitch wrong, deep voice (2) Sven Holm VOIP 0 09-09-2003 02:00 PM
voice chat under win2k: voice pitch wrong, deep voice Sven Holm VOIP 0 09-07-2003 03:23 PM



Advertisments