Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > VOIP > h248 Megaco/1 W/NAT via PIX 515E

Reply
Thread Tools

h248 Megaco/1 W/NAT via PIX 515E

 
 
Mikeal
Guest
Posts: n/a
 
      01-13-2006
I am fairly new to the world of VOIP networking so please bare with me
a bit.

I have a PIX 515e w/ PIX Version 6.3(3)

Strata extended CTX670
*VOIP card config is:
ip 10.10.11.45
sub 255.255.0.0
gw 10.10.10.98

~~~~~~~~~~~~~

fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69

access-list outside_in permit icmp any any
access-list outside_in permit tcp any host xxx.xxx.xxx.xxx range 1
65000
access-list outside_in permit udp any host xxx.xxx.xxx.xxx range 1
65000

access-list outbound_access permit tcp any any eq www
access-list outbound_access permit tcp any any eq https
access-list outbound_access permit tcp any any eq ftp
access-list outbound_access permit tcp any any eq aol
access-list outbound_access permit tcp any any eq 3389
access-list outbound_access permit tcp any any eq domain
access-list outbound_access permit udp any any eq domain
access-list outbound_access permit tcp any any eq ssh
access-list outbound_access permit tcp any any eq 714
access-list outbound_access permit icmp any any

static (inside,outside) xxx.xxx.xxx.xxx 10.10.11.45 netmask
255.255.255.255 0 0

~~~~~~~~~~~~~~~~~~~~

Inside my NAT network I have a phone working without problem connecting
to 10.10.11.45

I have a remote location that I have configured with a static internet
IP address for a hardware phone. The phone is setup to connect to
xxx.xxx.xxx.xxx

The phone does connect and start up correctly but I only get voice in
one direction.

Now, I am ASSUMING this is h248 as I have no real documentation that
says so.
How I came to assume this is going a bit of packet sniffing using
ettercap on a FreeBSD machine.

~~~~~~~~~~~~~~~~~~~~
08:44:45 xxx.xxx.xxx.xxx:2944 --> yyy.yyy.yyy.yyy:2659 proto: T

.....MEGACO/1 [10.10.11.45]:2944
Transaction = 4547 {
Context = - {
Modify = IPT {
Events = 4547 {
dkt/up }
,
Signals {
dkt/down {
data = "A000AA" }
}
}
}
}

08:44:45 yyy.yyy.yyy.yyy:2659 --> xxx.xxx.xxx.xxx:2944 proto: T

....RMEGACO/1 [209.103.237.204]
Reply=4547 {
Context=- {
Modify=IPT
}
}

08:44:45 xxx.xxx.xxx.xxx:2944 --> yyy.yyy.yyy.yyy:2659 proto: T

....OMEGACO/1 [10.10.11.45]:2944
Reply = 4394 {
Context = - {
Notify = IPT }
}

~~~~~~~~~~~~~~~~~~~~~~~~~~

Now seeing 10.10.11.45 in the proto transmission makes me wonder if my
problem is related to NAT issues I have seen talked about on this
forum. I have looked for a fixup protocol for h248 but I cannot find
one for my PIX.

Any suggestions, comments, direction or acts of god would be greatly
appreciated.

Mikeal

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IPsec-VPN via an Cisco PIX 515E? Dairenn Lombard Cisco 3 07-05-2007 01:55 PM
Cisco System PIX 515E - Memory and PIX OS upgrade Speed3ple Cisco 0 04-04-2006 10:24 AM
Cisco PIX 6.1 (4) - Model PIX 515E Romeo Cisco 1 03-20-2006 03:26 PM
Replacing a PIX 515E with a PIX 515 Dustin Cisco 3 11-08-2005 11:06 PM
PIX 515E, VPN client has no route to outside network via vpn Clemens Schwaighofer Cisco 7 06-13-2005 03:48 PM



Advertisments