Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Secondary addresses and static DHCP

Reply
Thread Tools

Secondary addresses and static DHCP

 
 
Daryle A. Tilroe
Guest
Posts: n/a
 
      04-28-2006
My bloody ISP has gone and broken my setup and being only
a bi-occasional IOS hack I've exhausted my alternatives.

I have a 1605R.

I have 5 static IPs from the ISP and previously I used the
first as primary and the rest as secondaries for linking
several inside services to the outside (eg. 3 different
ftp servers that I want assessable from the outside):

interface Ethernet0
description connected to ADSL
ip address xxx.xxx.207.104 255.255.248.0 secondary
ip address xxx.xxx.207.105 255.255.248.0 secondary
ip address xxx.xxx.207.106 255.255.248.0 secondary
ip address xxx.xxx.207.107 255.255.248.0 secondary
ip address xxx.xxx.207.103 255.255.248.0
ip access-group 101 in
ip nat outside

Now the ISP has change something whereby things will not
route unless you request your static IP via DHCP (it is
mapped by registering the MAC address of the interface).
So basically I have to change the above to:

interface Ethernet0
description connected to ADSL
ip address dhcp
ip access-group 101 in
ip nat outside

and remove:

ip route 0.0.0.0 0.0.0.0 xxx.xxx.200.1

Everything on the xxx.xxx.200.103 then works fine and 90%
of things work as they used to. However without the secondaries
I loose things like having outside access to other ftp and web
servers mapped like these examples:

ip nat inside source static tcp 172.16.0.4 21 xxx.xxx.207.105 21
extendable
ip nat inside source static tcp 172.16.0.4 20 xxx.xxx.207.105 20
extendable
ip nat inside source static tcp 172.16.0.10 80 xxx.xxx.207.105 80
extendable

Now there may be some way to fix/kludge this with static
routes and/or playing around with arp but I can't get it
to work. I also suspect I need to tweak the rip settings
since without the secondary entries on the interface I loose
automatic advertising and setting Ethernet0 to passive may
not work. This is my current rip section:

router rip
version 2
passive-interface Ethernet0
network 172.16.0.0
no auto-summary

Thanks for any help!

--
Daryle Tilroe
 
Reply With Quote
 
 
 
 
Daryle A. Tilroe
Guest
Posts: n/a
 
      04-29-2006
Daryle A. Tilroe wrote:

> interface Ethernet0
> description connected to ADSL
> ip address xxx.xxx.207.104 255.255.248.0 secondary
> ip address xxx.xxx.207.105 255.255.248.0 secondary
> ip address xxx.xxx.207.106 255.255.248.0 secondary
> ip address xxx.xxx.207.107 255.255.248.0 secondary
> ip address xxx.xxx.207.103 255.255.248.0
> ip access-group 101 in
> ip nat outside



So just to follow-up to my previous message; I think that the
above secondary listings may (when things were working fine
before the ISP fubar'd things) have been redundant. It appears
that the mappings like the ones below below:

> ip nat inside source static tcp 172.16.0.4 21 xxx.xxx.207.105 21 extendable
> ip nat inside source static tcp 172.16.0.4 20 xxx.xxx.207.105 20 extendable
> ip nat inside source static tcp 172.16.0.10 80 xxx.xxx.207.105 80
> extendable


etc. serve to make the correct arp entries:

Internet xxx.xxx.207.106 - 0030.94be.yyyy ARPA Ethernet0
Internet xxx.xxx.207.107 - 0030.94be.yyyy ARPA Ethernet0
Internet xxx.xxx.207.104 - 0030.94be.yyyy ARPA Ethernet0
Internet xxx.xxx.207.105 - 0030.94be.yyyy ARPA Ethernet0
Internet xxx.xxx.207.103 - 0030.94be.yyyy ARPA Ethernet0

(where all the 0030.94be.yyyy are identical MAC addresses)

Anyhow, it now seems that the main problem is the need to trigger the
static DHCP request to the ISP in order to get their router to route
to any of my IPs. Of course their system does not allow you to put in
the same MAC for multiple IPs. I wonder if there is some way to
have the router make the multiple DHCP requests for different MACs
and then have the Ethernet0 interface with multiple MACS bound to it?

--
Daryle Tilroe
 
Reply With Quote
 
 
 
 
Merv
Guest
Posts: n/a
 
      04-29-2006
It would seem that you are going to have to change from routing to
bridging and setup each of your PC's to reuest an IP address via DHCP.
Those DHCP requests will be need to be bridged to the Ethernet
interface facing the ISP.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Secondary IP Addresses Greg Cisco 3 03-05-2008 08:01 PM
DHCP and secondary networks branigan Cisco 3 03-15-2007 11:49 AM
Dhcp Relay Agent And Acl On Sw 3750, DHCP Relay Agent and ACL on Sw 3750 Vimokh Cisco 3 09-06-2006 02:16 AM
ip address secondary and static routing Mikhael47 Cisco 1 09-21-2004 08:38 PM
static route with secondary ip address chaidan Cisco 1 08-25-2004 02:35 PM



Advertisments