Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Computing > Cisco > Etherchannel problem

Reply
Thread Tools

Etherchannel problem

 
 
thejayman
Guest
Posts: n/a
 
      04-27-2006
Hi group.
I have an issue whilst trying to set up an etherchannel between a 6513
and 6509. As soon as the Channel is up and bonded a switch in an
external office (Cat.3650) goes off line and only a reboot of this
external switch will bring it back with the Port Channel shutdown. The
default gateway of the remote netowrk sits on the 6513, the external
switch is just in default setup with ports set to cisco-desktop macro.

Port Channel set up below:
6513:
..........
!
interface Port-channel1
switchport
switchport access vlan 4
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet13/1
switchport
switchport access vlan 4
switchport mode trunk
channel-group 1 mode desirable non-silent
.........

6509:
........
interface Port-channel1
no ip address
switchport
switchport access vlan 4
switchport trunk encapsulation dot1q
switchport mode trunk
!
no ip address
switchport
switchport access vlan 4
switchport mode trunk
channel-group 1 mode desirable non-silent
....

Any ideas?

Thanks
J

 
Reply With Quote
 
 
 
 
Merv
Guest
Posts: n/a
 
      04-27-2006

Is the connection a trunk or not ?

If is is then lose the "switchport access vlan 4" command and get rid
of DTP - configure the trunk as nonegotiate

 
Reply With Quote
 
 
 
 
thejayman
Guest
Posts: n/a
 
      04-27-2006
Thank for the prompt reply.
I am assuming it should be a trunk, I was just trying to allow the
channel to pass only traffic on that vlan.

So should i enter:

no switchport access vlan 4
switchport mode trunk nonegotiate

Thanks
J

 
Reply With Quote
 
thejayman
Guest
Posts: n/a
 
      04-27-2006
Thank for the prompt reply.
I am assuming it should be a trunk, I was just trying to allow the
channel to pass only traffic on that vlan.

So should i enter:

no switchport access vlan 4
switchport mode trunk nonegotiate

Thanks
J

 
Reply With Quote
 
URB
Guest
Posts: n/a
 
      04-27-2006
What is the status of the 3560 port that is connected to the network?
Is it err-disabled? If so, what is the cause?

If you only want vlan 4 on the trunk use switchport trunk allowed vlan
otherwise use switch trun native vlan or something like that.

URB

On 27 Apr 2006 10:56:56 -0700, "thejayman"
<(E-Mail Removed)> wrote:

>Hi group.
>I have an issue whilst trying to set up an etherchannel between a 6513
>and 6509. As soon as the Channel is up and bonded a switch in an
>external office (Cat.3650) goes off line and only a reboot of this
>external switch will bring it back with the Port Channel shutdown. The
>default gateway of the remote netowrk sits on the 6513, the external
>switch is just in default setup with ports set to cisco-desktop macro.
>
>Port Channel set up below:
>6513:
>.........
>!
>interface Port-channel1
> switchport
> switchport access vlan 4
> switchport trunk encapsulation dot1q
> switchport mode trunk
>!
>interface GigabitEthernet13/1
> switchport
> switchport access vlan 4
> switchport mode trunk
> channel-group 1 mode desirable non-silent
>........
>
>6509:
>.......
>interface Port-channel1
> no ip address
> switchport
> switchport access vlan 4
> switchport trunk encapsulation dot1q
> switchport mode trunk
>!
>no ip address
>switchport
>switchport access vlan 4
>switchport mode trunk
>channel-group 1 mode desirable non-silent
>...
>
>Any ideas?
>
>Thanks
>J


 
Reply With Quote
 
Merv
Guest
Posts: n/a
 
      04-27-2006
try




! 6513 port channel configuration


no int po 1
no int gi 13/1


interface Port-channel 1
description trunk between 6513 and 6509
no ip address
load-interval 30
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
switchport trunk allowed vlan 4 ! permit only vlan 4 traffic
across trunk
no shutdown




interface GigabitEthernet 13/1
description trunk between 6513 and 6509
no ip address
load-interval 30
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
switchport trunk allowed vlan 4
channel-group 1 mode on
no shutdown

 
Reply With Quote
 
thejayman
Guest
Posts: n/a
 
      04-28-2006
Thanks for this. Works a charm. I am trying to understand the load
balancing aspect. I have many hosts going to few servers. From my
reading it looks like
port-channel load-balance src-dst-mac would work best.

Do you agree?
Thanks again

 
Reply With Quote
 
Merv
Guest
Posts: n/a
 
      04-28-2006
I am not sure of the best load balancing algorithm as I have never
tested.

You can configure load-interval 30 on each of teh interface you place
in a port-channel to be able to get a better idea of their instanteious
utilization

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
etherchannel problem Ivana Cisco 3 08-15-2008 03:48 PM
Problem with etherchannel between 2 3550 FXs Who knows? Cisco 4 09-02-2005 02:33 PM
Cat 4506 etherchannel problem. TJ Cisco 1 02-07-2005 05:46 PM
Cisco 2970 Switch, Etherchannel Problem, Layer2 Down Todd Richert Cisco 3 01-10-2004 05:27 AM
Etherchannel 4006 Roland Waidhas Cisco 0 07-13-2003 11:35 AM



Advertisments