Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > XML > no tags in my xml-to-xml transformation, help....

Reply
Thread Tools

no tags in my xml-to-xml transformation, help....

 
 
yannicklaclau
Guest
Posts: n/a
 
      02-28-2005
my xml-to-xml transformation is outputting an xml header and then just
text like this:

<?xml version="1.0" encoding="iso-8859-1"?>e19dbb7b-5529-43a0......

I've searched regarding this problem and it seems that if there's no
match in your xsl template then by default everything gets spat out.

But I've tested this with very definite matches in my template, and
still there are no xml tags in the output.

Has anyone seen this before? Any help much appreciated....

Yannick

 
Reply With Quote
 
 
 
 
Martin Honnen
Guest
Posts: n/a
 
      02-28-2005


yannicklaclau wrote:

> my xml-to-xml transformation is outputting an xml header and then just
> text like this:
>
> <?xml version="1.0" encoding="iso-8859-1"?>e19dbb7b-5529-43a0......
>
> I've searched regarding this problem and it seems that if there's no
> match in your xsl template then by default everything gets spat out.
>
> But I've tested this with very definite matches in my template, and
> still there are no xml tags in the output.
>
> Has anyone seen this before?


We do not need to guess, try to reduce to the minimum necessary to show
the problem, then post the relevant XML and XSLT here, and tell us which
XSLT processor you use.


--

Martin Honnen
http://JavaScript.FAQTs.com/
 
Reply With Quote
 
 
 
 
yannicklaclau
Guest
Posts: n/a
 
      02-28-2005
Ok, false alarm.

As I suspected, it was a newbie issue. In case anyone else has this
problem, the solution is to use copy-of instead of value-of. Pretty
self-explanatory: value-of will output the value of the matched node;
copy-of will output a complete copy of the matched node, including the
tags.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
All style tags after the first 30 style tags on an HTML page are not applied in Internet Explorer Rob Nicholson ASP .Net 3 05-28-2005 03:11 PM
Evaluating struts tags inside my own custom tags... A. Brinkmann Java 2 04-16-2004 07:44 AM
JSP newbie - use include, custom tags, standard tags - or what? Mike Java 3 01-09-2004 09:30 AM
RegEx to find CFML tags nested in HTML tags Dean H. Saxe Perl 0 01-03-2004 06:11 PM
Custom Tags within Custom Tags. Ranganath Java 2 10-21-2003 06:14 AM



Advertisments