Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > XML > Xerces2-J http://apache.org/xml/features/validation/warn-on-undeclared-elemdef?

Reply
Thread Tools

Xerces2-J http://apache.org/xml/features/validation/warn-on-undeclared-elemdef?

 
 
Gerben
Guest
Posts: n/a
 
      09-29-2003
I try to use
"http://apache.org/xml/features/validation/warn-on-undeclared-elemdef":

---
System.setProperty("javax.xml.parsers.SAXParserFac tory",
"org.apache.xerces.jaxp.SAXParserFactoryImpl") ;

SAXParserFactory parserFactory = SAXParserFactory.newInstance();
SAXParser parser = parserFactory.newSAXParser();
XMLReader reader = parser.getXMLReader();


reader.getFeature("http://apache.org/xml/features/validation/warn-on-undecla
red-elemdef");
---

but an exception is thrown:

org.xml.sax.SAXNotRecognizedException:
http://apache.org/xml/features/valid...clared-elemdef

other features work. Any ideas?


 
Reply With Quote
 
 
 
 
Alexey Dmitriev
Guest
Posts: n/a
 
      09-30-2003
Gerben wrote:

> I try to use
> "http://apache.org/xml/features/validation/warn-on-undeclared-elemdef":
>

....
> but an exception is thrown:
>
> org.xml.sax.SAXNotRecognizedException:
> http://apache.org/xml/features/valid...clared-elemdef
>
> other features work. Any ideas?
>
>

This is bug that was fixed (see:
http://nagoya.apache.org/bugzilla/sh....cgi?id=21845). I think If you
install fresh stable Xerces2-J version(2.5.0) then It's Ok!

--
Alex

 
Reply With Quote
 
 
 
 
Gerben
Guest
Posts: n/a
 
      10-02-2003
As far as i know, i am using 2.5.0. How can i be sure?

"Alexey Dmitriev" <(E-Mail Removed)> wrote in message
news:blc63g$g3$(E-Mail Removed)...
> Gerben wrote:
>
> > I try to use
> > "http://apache.org/xml/features/validation/warn-on-undeclared-elemdef":
> >

> ...
> > but an exception is thrown:
> >
> > org.xml.sax.SAXNotRecognizedException:
> > http://apache.org/xml/features/valid...clared-elemdef
> >
> > other features work. Any ideas?
> >
> >

> This is bug that was fixed (see:
> http://nagoya.apache.org/bugzilla/sh....cgi?id=21845). I think If you
> install fresh stable Xerces2-J version(2.5.0) then It's Ok!
>
> --
> Alex
>



 
Reply With Quote
 
Alexey Dmitriev
Guest
Posts: n/a
 
      10-11-2003
Gerben wrote:

> As far as i know, i am using 2.5.0. How can i be sure?
>


As they say in Xerces2-J general FAQs
to find out the release version of Xerces, execute the following:
java org.apache.xerces.impl.Version

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Advertisments