Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > HTML > stupid problem but client is going bonkers

Reply
Thread Tools

stupid problem but client is going bonkers

 
 
Cinnamon Thunder
Guest
Posts: n/a
 
      03-13-2006
Hi Guys

Our client requested we fix this but I don't know where to start.

It's a shop using X-Cart shopping cart system.

You may view the site @
http://www.mousemall.co.za/home.php?shopkey=m0us3

When loading the homepage for instance, the 3 product boxes columns
(Featured products: im using 3 columns) have different widths.

For instance the left column is wider than the other 3... then once the
page has finished loading they jump back to their specified width.

You don't really see it on a fast connection, but on a modem connection
its quite visible.

I know this isn't a MAJOR problem, but the client is jumping up and down
and I don't know where to turn. The site is going live today sometime.

Please, any ideas?? Any help would be appreciated.

Thanks
Xenlab
 
Reply With Quote
 
 
 
 
Andy Dingley
Guest
Posts: n/a
 
      03-13-2006
Cinnamon Thunder wrote:

> Our client requested we fix this but I don't know where to start.


Neither do I. Your code's a right old mess and it's really not worth
trying to look for subtle layout errors in such a rats-nest of 1997
coding. You chose to code it in this style, your problem to sort it
out. Sorry.

 
Reply With Quote
 
 
 
 
Carolyn Marenger
Guest
Posts: n/a
 
      03-13-2006
Cinnamon Thunder wrote:

> Hi Guys
>
> Our client requested we fix this but I don't know where to start.
>
> It's a shop using X-Cart shopping cart system.
>
> You may view the site @
> http://www.mousemall.co.za/home.php?shopkey=m0us3
>
> When loading the homepage for instance, the 3 product boxes columns
> (Featured products: im using 3 columns) have different widths.
>
> For instance the left column is wider than the other 3... then once the
> page has finished loading they jump back to their specified width.
>
> You don't really see it on a fast connection, but on a modem connection
> its quite visible.
>
> I know this isn't a MAJOR problem, but the client is jumping up and down
> and I don't know where to turn. The site is going live today sometime.
>
> Please, any ideas?? Any help would be appreciated.
>
> Thanks
> Xenlab


I checked and I could not replicate your problem. When I used mozilla
firefox v1.0.2 the site looks normal. Very slow to finish loading, with
the center content not appearing until the end. My guess would be, it
didn't try to render the section until it knew the dimensions of the
content. To see what I saw...

http://www.marenger.com/mousemall/mo...mozilla-p1.png

I did experience another problem however. My default browser, konqueror
totally screwed up the page. With the exception that the majority of your
hopeful customers won't be using konqueror, it would in my mind be a
critical issue. I can't say that I have ever seen such a garbled mess, so
the easiest way to tell you about it is to show you. p1 is the top third
of the page, p2 is the bottom third.

http://www.marenger.com/mousemall/mousemall-p1.png
http://www.marenger.com/mousemall/mousemall-p2.png

Good luck in working this out.

Carolyn
--
Carolyn Marenger

 
Reply With Quote
 
Carolyn Marenger
Guest
Posts: n/a
 
      03-13-2006
Andy Dingley wrote:

> Cinnamon Thunder wrote:
>
>> Our client requested we fix this but I don't know where to start.

>
> Neither do I. Your code's a right old mess and it's really not worth
> trying to look for subtle layout errors in such a rats-nest of 1997
> coding. You chose to code it in this style, your problem to sort it
> out. Sorry.


It was so garbled in my default browser, I didn't even look at the code. I
just went back, and I agree with you, it is a right old mess.

Carolyn
--
Carolyn Marenger

 
Reply With Quote
 
Carolyn Marenger
Guest
Posts: n/a
 
      03-13-2006
Carolyn Marenger wrote:

> content. To see what I saw...
>
> http://www.marenger.com/mousemall/mo...mozilla-p1.png
> http://www.marenger.com/mousemall/mousemall-p1.png
> http://www.marenger.com/mousemall/mousemall-p2.png
>
> Good luck in working this out.
>
> Carolyn


I forgot to mention, I will leave these graphics up on my site for a day or
two, then I will remove them. I hope that is long enough for you to get
what you need.

Carolyn
--
Carolyn Marenger

 
Reply With Quote
 
Barbara de Zoete
Guest
Posts: n/a
 
      03-13-2006
On Mon, 13 Mar 2006 11:10:18 +0100, Cinnamon Thunder
<(E-Mail Removed)> wrote:

> http://www.mousemall.co.za/home.php?shopkey=m0us3
>
> When loading the homepage for instance, the 3 product boxes columns
> (Featured products: im using 3 columns) have different widths.
>
> For instance the left column is wider than the other 3... then once the
> page has finished loading they jump back to their specified width.


If you set up the site so that the validator can access, you can use
<URL:http://validator.w3.org/check?uri=http%3A%2F%2Fwww.mousemall.co.za%2Fhome. php%3Fshopkey%3Dm0us3&charset=iso-8859-1&fbc=1&doctype=HTML+4.01+Transitional&fbd=1&verbo se=1>
for example to see what errors in your markup you should correct first.
Might do the trick, might not. But then atleast you know it is not the
coding and can start looking in other directions.

--
______PretLetters:
| weblog | http://www.pretletters.net/weblog/weblog.html |
| webontwerp | http://www.pretletters.net/html/webontwerp.html |
|zweefvliegen | http://www.pretletters.net/html/vliegen.html |
 
Reply With Quote
 
Jim Higson
Guest
Posts: n/a
 
      03-13-2006

> I checked and I could not replicate your problem. When I used mozilla
> firefox v1.0.2 the site looks normal. Very slow to finish loading, with
> the center content not appearing until the end. My guess would be, it
> didn't try to render the section until it knew the dimensions of the
> content. To see what I saw...
>
> http://www.marenger.com/mousemall/mo...mozilla-p1.png
>
> I did experience another problem however. My default browser, konqueror
> totally screwed up the page.


Funny, Konqueror is fine here (version 3.5.1) on that page, with the
exception the tabs at the top are slightly out.

Maybe you have an older version? There've also been quite a few versions of
Firefox since 1.0.2, mostly security fixes but one major version.

Back to the OP, the jumping effect is almost certainly because of
table-based layout. The only cure is to change the order in the HTML so the
center column gets to the browser first, and then put the other stuff round
the sides using CSS.

> With the exception that the majority of your
> hopeful customers won't be using konqueror, it would in my mind be a
> critical issue. I can't say that I have ever seen such a garbled mess, so
> the easiest way to tell you about it is to show you. p1 is the top third
> of the page, p2 is the bottom third.
>
> http://www.marenger.com/mousemall/mousemall-p1.png
> http://www.marenger.com/mousemall/mousemall-p2.png
>
> Good luck in working this out.
>
> Carolyn


 
Reply With Quote
 
Jim Moe
Guest
Posts: n/a
 
      03-13-2006
Cinnamon Thunder wrote:
>
> You may view the site @
> http://www.mousemall.co.za/home.php?shopkey=m0us3
>
> When loading the homepage for instance, the 3 product boxes columns
> (Featured products: im using 3 columns) have different widths.
>
> For instance the left column is wider than the other 3... then once the
> page has finished loading they jump back to their specified width.
>

As noted by others your code is a mess. Ugh. Tables for layout. Spacer
GIFs. Empty columns for spacing. Sheesh!
You could try using a <colgroup> to set the initial widths of the columns.

--
jmm (hyphen) list (at) sohnen-moe (dot) com
(Remove .AXSPAMGN for email)
 
Reply With Quote
 
dorayme
Guest
Posts: n/a
 
      03-13-2006
In article <dv3gel$d98$(E-Mail Removed)>,
Cinnamon Thunder <(E-Mail Removed)> wrote:

> Hi Guys
>
> Our client requested we fix this but I don't know where to start.
>
> It's a shop using X-Cart shopping cart system.
>
> You may view the site @
> http://www.mousemall.co.za/home.php?shopkey=m0us3
>
> When loading the homepage for instance, the 3 product boxes columns
> (Featured products: im using 3 columns) have different widths.
>
> For instance the left column is wider than the other 3... then once the
> page has finished loading they jump back to their specified width.
>
> You don't really see it on a fast connection, but on a modem connection
> its quite visible.
>
> I know this isn't a MAJOR problem, but the client is jumping up and down
> and I don't know where to turn. The site is going live today sometime.
>
> Please, any ideas?? Any help would be appreciated.
>
> Thanks
> Xenlab


No trouble on Safari (Mac X browser) on dial up.

I hope that not too many of you folk are tearing their hair out
at the fact that this impossible dog's breakfast markup results
in a look that is nicer than the majority of better coded sites...

Is that the sound of suppressed gnashing of teeth...

--
dorayme
 
Reply With Quote
 
Jim Moe
Guest
Posts: n/a
 
      03-14-2006
dorayme wrote:
>
> I hope that not too many of you folk are tearing their hair out
> at the fact that this impossible dog's breakfast markup results
> in a look that is nicer than the majority of better coded sites...
>

No one has ever said (well, maybe someone has) that beautiful, useful
websites cannot be done with tables. Obviously there are many that succeed
wonderfully.
Table-based layouts tend to be rigid, and hard to maintain. The code
usually ends up looking like an "impossible dog's breakfast." (Personal
experience.)
And so on.
When web designer's are finally re-trained to better use HTML and CSS as
intended, we'll start seeing sites that are at least as good as those
created with legacy coding.

--
jmm (hyphen) list (at) sohnen-moe (dot) com
(Remove .AXSPAMGN for email)
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DVD/CD-RW Drive Goes Bonkers With Blank Disc SJ Carter Computer Support 2 11-16-2007 04:35 AM
Stupid question. Please, only stupid responders. If you're not sureif you're stupid, you probably aren't. =?ISO-8859-1?Q?R=F4g=EAr?= Computer Support 6 07-18-2005 05:11 AM
stupid stupid stupid kpg MCSE 17 11-26-2004 02:59 PM
Stupid is as Stupid Does! Michael P Gabriel Digital Photography 3 06-26-2004 12:49 PM
VPN going up but traffic going one way PLP Cisco 1 07-11-2003 08:28 AM



Advertisments