Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > HTML > Charset not recognized

Reply
Thread Tools

Charset not recognized

 
 
Neal
Guest
Posts: n/a
 
      10-25-2004
On Mon, 25 Oct 2004 20:14:57 GMT, Andrew Urquhart
<(E-Mail Removed)> wrote:

> Gah - except since writing the above, the 'new design' page has started
> returning UTF-8 in the headers /


See my reply to Leif. PHP apparently makes the UA not refer to the HTTP
header. I supplied it in the php, that did it.
 
Reply With Quote
 
 
 
 
brucie
Guest
Posts: n/a
 
      10-25-2004
In alt.html Neal said:

> AddType 'text/html; charset=UTF-8' .php
> However, the document.php pages do not seem to carry an encoding.


check the default charset php is sending and change it if needed. host
probably has it as iso-8859-1.
http://www.php.net/manual/sv/configu...efault-charset

How to change configuration settings
http://www.php.net/manual/en/configuration.changes.php

> The page in question is http://www.opro.org/new%20redesign/


<gasp/> a space! you should know better than that.


--


v o i c e s
 
Reply With Quote
 
 
 
 
Neal
Guest
Posts: n/a
 
      10-25-2004
On Tue, 26 Oct 2004 07:40:32 +1000, brucie <****@usenetshit.info> wrote:

> In alt.html Neal said:
>
>> AddType 'text/html; charset=UTF-8' .php
>> However, the document.php pages do not seem to carry an encoding.

>
> check the default charset php is sending and change it if needed. host
> probably has it as iso-8859-1.
> http://www.php.net/manual/sv/configu...efault-charset
>
> How to change configuration settings
> http://www.php.net/manual/en/configuration.changes.php


Unfortunately, I do not have access to the host's PHP settings.

>> The page in question is http://www.opro.org/new%20redesign/

>
> <gasp/> a space! you should know better than that.


Just a working directory, not going to be public (anymore than the link
appearing here will make it). Everything will move to the root when it's
done.

 
Reply With Quote
 
brucie
Guest
Posts: n/a
 
      10-25-2004
In alt.html Neal said:

>> check the default charset php is sending and change it if needed.


> Unfortunately, I do not have access to the host's PHP settings.


you don't need it for charset:
http://www.php.net/manual/en/function.ini-set.php

--


v o i c e s
 
Reply With Quote
 
Neal
Guest
Posts: n/a
 
      10-25-2004
On Tue, 26 Oct 2004 08:48:13 +1000, brucie <****@usenetshit.info> wrote:

> In alt.html Neal said:
>
>>> check the default charset php is sending and change it if needed.

>
>> Unfortunately, I do not have access to the host's PHP settings.

>
> you don't need it for charset:
> http://www.php.net/manual/en/function.ini-set.php


Really new to this. I'm guessing frpm
http://www.php.net/manual/en/configuration.changes.php that I add to
..htaccess:

php_value default_charset "UTF-8"

Am I even close?
 
Reply With Quote
 
Neal
Guest
Posts: n/a
 
      10-26-2004
On Mon, 25 Oct 2004 19:14:11 -0400, Neal <(E-Mail Removed)> wrote:

> On Tue, 26 Oct 2004 08:48:13 +1000, brucie <****@usenetshit.info> wrote:
>
>> In alt.html Neal said:
>>
>>>> check the default charset php is sending and change it if needed.

>>
>>> Unfortunately, I do not have access to the host's PHP settings.

>>
>> you don't need it for charset:
>> http://www.php.net/manual/en/function.ini-set.php

>
> Really new to this. I'm guessing frpm
> http://www.php.net/manual/en/configuration.changes.php that I add to
> .htaccess:
>
> php_value default_charset "UTF-8"
>
> Am I even close?


Apparently not close enough - that causes a 500 error when I try to access
a page. Funny - if I access a page where I've set the encoding in PHP on
the page, it works even with that line.
 
Reply With Quote
 
Mark Parnell
Guest
Posts: n/a
 
      10-26-2004
On Mon, 25 Oct 2004 20:07:41 -0400, Neal <(E-Mail Removed)> declared in
alt.html:

>> Really new to this. I'm guessing frpm
>> http://www.php.net/manual/en/configuration.changes.php that I add to
>> .htaccess:
>>
>> php_value default_charset "UTF-8"

> Apparently not close enough - that causes a 500 error when I try to access
> a page. Funny - if I access a page where I've set the encoding in PHP on
> the page, it works even with that line.


Looks right to me. What web server is your host running? If it's Apache,
that should work AFAICT. If it's Zeus, you can't do it - Zeus supports
..htaccess, but not the php_value option.

--
Mark Parnell
http://www.clarkecomputers.com.au
"Never drink rum&coke whilst reading usenet" - rf 2004
 
Reply With Quote
 
Neal
Guest
Posts: n/a
 
      10-26-2004
On Tue, 26 Oct 2004 10:25:23 +1000, Mark Parnell
<(E-Mail Removed)> wrote:
> On Mon, 25 Oct 2004 20:07:41 -0400, Neal <(E-Mail Removed)> declared in
> alt.html:
>>> php_value default_charset "UTF-8"

> Looks right to me. What web server is your host running? If it's Apache,
> that should work AFAICT. If it's Zeus, you can't do it - Zeus supports
> .htaccess, but not the php_value option.


Apache. I just put that line in like that - should it be in any sort of
markup?

Use small words, I'm PHP stoopid.
 
Reply With Quote
 
Mark Parnell
Guest
Posts: n/a
 
      10-26-2004
On Mon, 25 Oct 2004 20:51:58 -0400, Neal <(E-Mail Removed)> declared in
alt.html:

> Apache. I just put that line in like that - should it be in any sort of
> markup?


No, just exactly as you have it there. Weird. I can't remember offhand,
but it may be a configuration option in Apache - you'd have to check
with your host. Maybe they have disabled php_value directives for some
reason.

--
Mark Parnell
http://www.clarkecomputers.com.au
"Never drink rum&coke whilst reading usenet" - rf 2004
 
Reply With Quote
 
Neal
Guest
Posts: n/a
 
      10-26-2004
On Tue, 26 Oct 2004 11:34:56 +1000, Mark Parnell
<(E-Mail Removed)> wrote:

> On Mon, 25 Oct 2004 20:51:58 -0400, Neal <(E-Mail Removed)> declared in
> alt.html:
>
>> Apache. I just put that line in like that - should it be in any sort of
>> markup?

>
> No, just exactly as you have it there. Weird. I can't remember offhand,
> but it may be a configuration option in Apache - you'd have to check
> with your host. Maybe they have disabled php_value directives for some
> reason.


I read something like that. I have an email into them, history says
they'll mail me back sometime tomorrow.

At any rate, setting it in php on top of the document works well enough.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
javascript charset <> page charset optimistx Javascript 2 08-15-2008 12:42 PM
Inserted DVD is not not recognized Driver is good as is the burner Alan Computer Support 8 01-03-2008 03:08 AM
sending email with charset utf-8 but subject is not coded properly =?ISO-8859-2?Q?Grzegorz_=A6lusarek?= Python 1 04-14-2006 10:21 AM
ascii or not, the charset of a string Guoqi Zheng ASP .Net 5 09-05-2004 10:17 PM
Re: onkeypress not being recognized, or not firing S. Justin Gengo ASP .Net 0 08-26-2003 04:15 PM



Advertisments