Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > HTML > Not sure if this is a CSS or JS problem

Reply
Thread Tools

Not sure if this is a CSS or JS problem

 
 
Paul F. Johnson
Guest
Posts: n/a
 
      08-10-2004
Hi,

I seem to be having a problem with a rework of a site I'm doing. If you
look at http://146.87.55.8:82 on Opera, Moz or Konqueror, the site should
show fine. Move to IE and the menu bar isn't right.

That is at 1024x768

If you reduce the resolution 800x600, you can see the menubar and the
menus which are on the far right should be on the left. There is no text
at all. These problems only happen on IE.

If I remove the menubar, then the page displays to the "stop press" at the
bottom (and then nothing after that). Again, this problem is only visible
on IE.

I've checked at w3c.org and the page validates as do the style sheets.

Can anyone spot the problem?

TIA

TTFN

Paul
 
Reply With Quote
 
 
 
 
Mark Parnell
Guest
Posts: n/a
 
      08-10-2004
On Tue, 10 Aug 2004 15:17:47 +0100, "Paul F. Johnson"
<(E-Mail Removed)> declared in alt.html:

> Hi,


G'day.

> I seem to be having a problem with a rework of a site I'm doing. If you
> look at http://146.87.55.8:82 on Opera, Moz or Konqueror, the site should
> show fine. Move to IE and the menu bar isn't right.


Try adding clear: left; to your #container div.

> I've checked at w3c.org and the page validates as do the style sheets.


You must have changed the page since then, because the HTML doesn't
validate now, though the errors have nothing to do with this problem.
And it refused to validate the CSS at all. The CSS did validate (with
lots of warnings) using the WDG validator, though.

Nice site, BTW.

--
Mark Parnell
http://www.clarkecomputers.com.au
"Never drink rum&coke whilst reading usenet" - rf 2004
 
Reply With Quote
 
 
 
 
Paul F. Johnson
Guest
Posts: n/a
 
      08-11-2004
Hi,

On Wed, 11 Aug 2004 08:52:50 +1000, Mark Parnell wrote:

> On Tue, 10 Aug 2004 15:17:47 +0100, "Paul F. Johnson"
> <(E-Mail Removed)> declared in alt.html:


>> I seem to be having a problem with a rework of a site I'm doing. If you
>> look at http://146.87.55.8:82 on Opera, Moz or Konqueror, the site
>> should show fine. Move to IE and the menu bar isn't right.

>
> Try adding clear: left; to your #container div.


Seems to have done the trick. Thanks. Only problem now is that under IE,
the page ends directly under the Stop Press in 800x600 (coincides with the
bottom of the menu box - change the res and it re-appears)

>> I've checked at w3c.org and the page validates as do the style sheets.


> You must have changed the page since then, because the HTML doesn't
> validate now, though the errors have nothing to do with this problem.


Very odd! Local copies go through without a hitch!

> Nice site, BTW.


Thanks

TTFN

Paul
 
Reply With Quote
 
Mark Parnell
Guest
Posts: n/a
 
      08-11-2004
On Wed, 11 Aug 2004 09:41:15 +0100, "Paul F. Johnson"
<(E-Mail Removed)> declared in alt.html:

> Seems to have done the trick. Thanks. Only problem now is that under IE,
> the page ends directly under the Stop Press in 800x600 (coincides with the
> bottom of the menu box - change the res and it re-appears)


It stops in a different place depending on your font size and screen
width. It seems that it is always stopping at the bottom of the navbar
div. Not entirely sure why. Try adding a <div id="footer"> at the bottom
of the page. No need to put any content in it.

> Very odd! Local copies go through without a hitch!


Don't know why, unless your upload is changing the files somehow. It's
due to your XHTML syntax on the <link> elements, BTW.

--
Mark Parnell
http://www.clarkecomputers.com.au
"Never drink rum&coke whilst reading usenet" - rf 2004
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sure shot requirement for C++ with Unix Experience !!! sure interviewto day !!! Himayat66@gmail.com ASP .Net 0 02-07-2008 12:40 AM
'' is not a valid name. Make sure that it does not include invalid characters or punctuation and that it is not too long. rote ASP .Net 2 01-23-2008 03:07 PM
Works in IE but not in firefox (not sure if syntax is correct) chrisgibson Firefox 0 08-26-2006 04:01 AM
not sure why close window function not working =?Utf-8?B?UGF1bA==?= ASP .Net 14 11-29-2004 03:17 PM
JDialog.setModal(true) does not work with Suse 9.0 (not sure of kernel ver) Deshaies Java 1 04-15-2004 12:57 AM



Advertisments