Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > HTML > Newbie - strange problem (with frames) - help ?

Reply
Thread Tools

Newbie - strange problem (with frames) - help ?

 
 
Jane Doe
Guest
Posts: n/a
 
      12-12-2003
Hello,

problem as follows:

I have made a webpage with 3 frames

left | main
footer

but for some reason, when I put table on main.html, it leaves a blank space
on right edge, I cannot make the first line complete from left edge to right
edge. Code follows, can someone help me with this one ?

btw, is there a news group, where i could send screen shot of problem (would
be much easier to explain problem with picture?)

Thanks in advance.

index.html --------------------------------------------

<HTML>
<TITLE></TITLE>
<FRAMESET ROWS="*,47" frameborder="0"
framespacing="0" border="0" scrolling="none">

<FRAMESET COLS="165,*">
<FRAME name="left" SRC="left.html">
<FRAME name="main" SRC="main.html">

</FRAMESET>
<FRAME name="footer" SRC="footer.html">
</FRAMESET>
</HTML>

left.html --------------------------------------------

<html>
<body bgcolor="#ffffff" text="#000000" link="#000066"
vlink="#000066" marginwidth=0 marginheight=0 leftmargin=0 topmargin=0>
</body>

<table width="100%" cellspacing=0 cellpadding=0 border=0>

<tr><td>
<a href="link_1.html" target="Main">Link_1</a>
</td></tr>

</table>

</body></html>

main.html --------------------------------------------

<html>
<body bgcolor="#fhjfff" text="#000000" link="#000066"
vlink="#000066" marginwidth=0 marginheight=0
leftmargin=0 topmargin=0>

<TABLE BORDER="0" width="100%" CELLPADDING="0" CELLSPACING="0"
BGCOLOR="#FFFFFF">

<TR>
<TD width="100%" height="16" background="gfx/left_up_1_x1.jpg"></TD>
</TR>

</TABLE>

</body></html>

footer.html --------------------------------------------

<html>
<body bgcolor="#f99off" text="#000000" link="#000066"
vlink="#000066" marginwidth=0 marginheight=0 leftmargin=0 topmargin=0>
</body>
</html>



 
Reply With Quote
 
 
 
 
William Tasso
Guest
Posts: n/a
 
      12-12-2003
Jane Doe wrote:
> Hello,
>
> problem as follows:
>
> I have made a webpage with 3 frames


there's your first problem - frames are evil (look it up)

> but for some reason, when I put table on main.html, it leaves a blank
> space on right edge, I cannot make the first line complete from left
> edge to right edge.


You don't need a table to display one image - that's an inappropriate use of
table markup

> Code follows, can someone help me with this one ?
>
> btw, is there a news group, where i could send screen shot of problem
> (would be much easier to explain problem with picture?)


post the URL

--
William Tasso - http://WilliamTasso.com


 
Reply With Quote
 
 
 
 
rf
Guest
Posts: n/a
 
      12-12-2003
[crossposted groups removed]
"Jane Doe" <jane.doe@spam_me_like_never_before.com> wrote in message
news:QTfCb.613$(E-Mail Removed)...
> Hello,
>
> problem as follows:
>
> I have made a webpage with 3 frames


Therein lies your problem. You are using obsolete technology.

Cheers
Richard.


 
Reply With Quote
 
Jane Doe
Guest
Posts: n/a
 
      12-12-2003

"William Tasso" <(E-Mail Removed)> wrote in message
news:brc2tg$1lg89$(E-Mail Removed)-berlin.de...
> Jane Doe wrote:
> > Hello,
> >
> > problem as follows:
> >
> > I have made a webpage with 3 frames

>
> there's your first problem - frames are evil (look it up)
>
> > but for some reason, when I put table on main.html, it leaves a blank
> > space on right edge, I cannot make the first line complete from left
> > edge to right edge.

>
> You don't need a table to display one image - that's an inappropriate use

of
> table markup


There is going to be more than one image (actually three), that was just as
an example.

Even if I use three images, situation is the same, small empty space in the
right edge...


 
Reply With Quote
 
Trevor George
Guest
Posts: n/a
 
      12-12-2003
Jane Doe wrote in message ...
> but for some reason, when I put table on main.html, it leaves a blank space
> on right edge, I cannot make the first line complete from left edge to

right
> edge. Code follows, can someone help me with this one ?


In your index.html you've used a lower-case 'm' in the word 'main'.
In left.html you've used a capital 'M' in the target name 'Main'

Make the capital 'M' into a lower-case 'm'

That's one problem solved.

--
Cheers ..... Trevor George, Bristol, UK. http://www.OnMyWindow.co.uk


 
Reply With Quote
 
Tina - AffordableHOST.com
Guest
Posts: n/a
 
      12-12-2003
"Jane Doe" <jane.doe@spam_me_like_never_before.com> wrote in message
news:QTfCb.613$(E-Mail Removed)...
> Hello,
>
> problem as follows:
>
> I have made a webpage with 3 frames
>
> left | main
> footer
>
> but for some reason, when I put table on main.html, it leaves a blank

space
> on right edge, I cannot make the first line complete from left edge to

right
> edge. Code follows, can someone help me with this one ?




You might want to reconsider your use of frames. There is rarely a good
reason to use frames and they pretty much scream "newbie!". That said, take
a look at your HTML again and make sure that you don't have any spaces or
'carriage returns' anywhere before or after the problem area. Sometimes you
can't see them, so you have to backspace or delete around that area.

PS: Next time send us a URL to the page and we can see the actual live
HTML.

--Tina
--
http://www.AffordableHOST.com
20% Discount Code: newsgroup
We transfer time from your current host!
Serving the web since 1997


 
Reply With Quote
 
Jane Doe
Guest
Posts: n/a
 
      12-12-2003
Thanks for your reply Tina,

here is the URL

http://members.surfeu.fi/janedoe/

and screenshot of problem is at

http://members.surfeu.fi/janedoe/gfx...screenshot.jpg

still, help needed. Atleast I would like to understand, what is the problem.
Eventhough I am not going to use frames anymore, but still...

"Tina - AffordableHOST.com" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> "Jane Doe" <jane.doe@spam_me_like_never_before.com> wrote in message
> news:QTfCb.613$(E-Mail Removed)...
> > Hello,
> >
> > problem as follows:
> >
> > I have made a webpage with 3 frames
> >
> > left | main
> > footer
> >
> > but for some reason, when I put table on main.html, it leaves a blank

> space
> > on right edge, I cannot make the first line complete from left edge to

> right
> > edge. Code follows, can someone help me with this one ?

>
>
>
> You might want to reconsider your use of frames. There is rarely a good
> reason to use frames and they pretty much scream "newbie!". That said,

take
> a look at your HTML again and make sure that you don't have any spaces or
> 'carriage returns' anywhere before or after the problem area. Sometimes

you
> can't see them, so you have to backspace or delete around that area.
>
> PS: Next time send us a URL to the page and we can see the actual live
> HTML.
>
> --Tina
> --
> http://www.AffordableHOST.com
> 20% Discount Code: newsgroup
> We transfer time from your current host!
> Serving the web since 1997
>
>



 
Reply With Quote
 
PeterMcC
Guest
Posts: n/a
 
      12-12-2003
Jane Doe wrote:
> Thanks for your reply Tina,
>
> here is the URL
>
> http://members.surfeu.fi/janedoe/
>
> and screenshot of problem is at
>
> http://members.surfeu.fi/janedoe/gfx...screenshot.jpg
>
> still, help needed. Atleast I would like to understand, what is the
> problem. Eventhough I am not going to use frames anymore, but still...


Try the following in the table tag on main.html
style="border-collapse:collapse"

--
PeterMcC
If you feel that any of the above is incorrect,
inappropriate or offensive in any way,
please ignore it and accept my apologies.
 
Reply With Quote
 
William Tasso
Guest
Posts: n/a
 
      12-12-2003
Jane Doe wrote:
> "William Tasso" <(E-Mail Removed)> wrote in message
> news:brc2tg$1lg89$(E-Mail Removed)-berlin.de...
>> Jane Doe wrote:
>>> Hello,
>>>
>>> problem as follows:
>>>
>>> I have made a webpage with 3 frames

>>
>> there's your first problem - frames are evil (look it up)
>>
>>> but for some reason, when I put table on main.html, it leaves a
>>> blank space on right edge, I cannot make the first line complete
>>> from left edge to right edge.

>>
>> You don't need a table to display one image - that's an
>> inappropriate use of table markup

>
> There is going to be more than one image (actually three), that was
> just as an example.


Still not necessary.

> Even if I use three images, situation is the same, small empty space
> in the right edge...


Page is still using frames.

From another post: http://members.surfeu.fi/janedoe/ looks fine (no gap) in
Opera and Mozilla but your markup is not quite up to scratch -
http://validator.w3.org/check?uri=ht...i%2Fjanedoe%2F
leaving your page to the mercy of in-browser error correction techniques.

--
William Tasso - http://WilliamTasso.com


 
Reply With Quote
 
Trevor George
Guest
Posts: n/a
 
      12-12-2003
Jane Doe wrote in message ...
> here is the URL
> http://members.surfeu.fi/janedoe/


Jane - there's nothing you can do about that. It's the nature of HTML. If you
centre the table you'll get an equal space either end. At least that doesn't
look so bad. Alternatively make the table width 90% then it will read better,
especially on large monitors. Another option is to have the table background
colour the same as the page colour so nobody will notice the oddity.

--
Cheers ..... Trevor George, Bristol, UK. http://www.OnMyWindow.co.uk


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie needs help! Strange error in code Tom Savage Ruby 2 06-25-2007 09:34 AM
Cisco Pix 501 Very Strange issues ! Newbie needs help !! fartblast@googlemail.com Cisco 4 12-17-2006 02:53 PM
strange problem with SOAP - newbie chris Java 0 07-01-2004 12:26 AM
Strange (for a newbie) problem Angelo Secchi Python 5 02-22-2004 10:05 AM
Question About Strange 'C' Code Syntax ( Well strange to me anyway ) Harvey Twyman C Programming 8 10-25-2003 05:54 AM



Advertisments