Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Cross-browser compatibility of Asp.net v.1.1 & 2.0

Reply
Thread Tools

Cross-browser compatibility of Asp.net v.1.1 & 2.0

 
 
=?Utf-8?B?cHJvZl9tYXJ0aW4=?=
Guest
Posts: n/a
 
      04-25-2006
Hi Everyone,

I got question from Customer. What kind of browser and version which can
browse properly if application running on ASP.net v.1.1 or 2.0 beside IE.5x
above? Firefox, Nescape, Mozilla, Opera?

Any info which can help, thank you very much.

Have a nice day,
Martin Adhie
 
Reply With Quote
 
 
 
 
Juan T. Llibre
Guest
Posts: n/a
 
      04-25-2006
All of them, as long as your Browser definitions are properly updated.

For 2.0, there's a new .browser file definition system, although browsercaps can still be used.
1.1 can only use browsercaps.

See http://slingfive.com/pages/code/browserCaps/
and http://slingfive.com/pages/code/brow...aps_spaces.txt

Test with :
http://slingfive.com/pages/code/brow..._info.aspx.txt
( copy that whole page as "Browser_info.aspx" and run it. )

You can call that page with the browser you're interested in defining in browsercaps,
and create an entry for it with the capabilities reported by that file.

For the new .browser file definition system, open several .browser files in the directory:
Drive:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\ CONFIG\Browsers

with a plain-text editor ( Notepad will do ) and analyze the contents.

As long as you know which browser capabilities the browser you're interested in sending correct
html to has ( by running "Browser_info.aspx" ) , you'll be able to create a .browser file for it.





Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"prof_martin" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi Everyone,
>
> I got question from Customer. What kind of browser and version which can
> browse properly if application running on ASP.net v.1.1 or 2.0 beside IE.5x
> above? Firefox, Nescape, Mozilla, Opera?
>
> Any info which can help, thank you very much.
>
> Have a nice day,
> Martin Adhie



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compatibility Issues -- Windows Media Center and Wireless Adapters =?Utf-8?B?RG91Z2ggRG9jdG9y?= Wireless Networking 2 10-30-2005 11:15 PM
WPA2 backward compatibility with WPA: TKIP and/or AES? =?Utf-8?B?U2NvdCBCYWxmb3Vy?= Wireless Networking 0 10-05-2005 06:15 PM
PreN and G+ Chipset Compatibility =?Utf-8?B?SiZK?= Wireless Networking 1 06-18-2005 03:03 AM
Backward compatibility problem JimD Wireless Networking 3 11-28-2004 05:50 AM
File compatibility? Chris Firefox 0 11-25-2003 03:46 AM



Advertisments