Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Datagrid: Old data after update

Reply
Thread Tools

Datagrid: Old data after update

 
 
marty
Guest
Posts: n/a
 
      04-19-2006
I did some searchs, but can't find the answer to my problems.

I have a editable DataGrid.
I do an update of one of the rows.
Postback "OnUpdateCommand"
Call Oracle proc to do that actual update, which in turn creates a new
row (effective dating).
Call BindGrid which retrieves the rows and binds the data to the grid
again.

Old data is showing in the DataGrid still. If I do a Edit then cancel
the new data shows. If I step through the code (ie: take some time)
the new data will show.

I'm running locally. I'm thinking it's something to do with IE caching
the data, but can't figure it out. ie 6.0.

 
Reply With Quote
 
 
 
 
Onwuka Emeka
Guest
Posts: n/a
 
      04-19-2006
Check the procedure that loads data unto the grid when it loads before your
update make sure it only loads when your page is not posting back i.e

if (!Page.IsPostBack)
{
grid.DataSource = GetDataSource();
grid.DataBind();
}

there is a posibility that the grid re-binds with the old values before the
OnUpdateCommand executes.


"marty" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
>I did some searchs, but can't find the answer to my problems.
>
> I have a editable DataGrid.
> I do an update of one of the rows.
> Postback "OnUpdateCommand"
> Call Oracle proc to do that actual update, which in turn creates a new
> row (effective dating).
> Call BindGrid which retrieves the rows and binds the data to the grid
> again.
>
> Old data is showing in the DataGrid still. If I do a Edit then cancel
> the new data shows. If I step through the code (ie: take some time)
> the new data will show.
>
> I'm running locally. I'm thinking it's something to do with IE caching
> the data, but can't figure it out. ie 6.0.
>



 
Reply With Quote
 
 
 
 
marty
Guest
Posts: n/a
 
      04-20-2006
I verified that already. All of my pages have that if statement. This
only seems to be happening with IE. Firefox doesn't show the old
values.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Update On The Windows Phone 7 Update Update Lawrence D'Oliveiro NZ Computing 2 02-25-2011 08:03 AM
Vista reactivation required after Microsoft Update optional update Colin Barnhorst Windows 64bit 32 05-26-2007 04:36 PM
Problem with Instiki update after OCI update Stephan Kämper Ruby 1 07-15-2006 01:41 PM
How to update datagrid after update =?Utf-8?B?TWljaGFlbA==?= ASP .Net 1 03-17-2006 07:24 PM
Editable DataGrid Shows Old Values "After" Update Kevin Pedersen ASP .Net 3 11-28-2003 06:31 AM



Advertisments