Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > Eclipse: List of TODO tags in Task view

Reply
Thread Tools

Eclipse: List of TODO tags in Task view

 
 
veljovic@gmail.com
Guest
Posts: n/a
 
      12-07-2004
Hi all,

It seems that I cannot see any of the TODO tasks in my Tasks window. I
probably disabled it somehow some time ago and now when I make // TODO
comment it does not show in the Tasks list. I made sure that in
Preferences->Java->Task Tags menu everything is setup correctly. TODO
is a default tag.
Please help if you know how to make my TODO tasks show in the Tasks
window again.

Thanks,
Tzar

 
Reply With Quote
 
 
 
 
Paul van Rossem
Guest
Posts: n/a
 
      12-07-2004
On 07-12-2004 22:03, http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> Hi all,
>
> It seems that I cannot see any of the TODO tasks in my Tasks window. I
> probably disabled it somehow some time ago and now when I make // TODO
> comment it does not show in the Tasks list. I made sure that in
> Preferences->Java->Task Tags menu everything is setup correctly. TODO
> is a default tag.
> Please help if you know how to make my TODO tasks show in the Tasks
> window again.
>
> Thanks,
> Tzar
>

Did you check the filter setting and the selected working set in the
task view? Got me once...

Paul.
 
Reply With Quote
 
 
 
 
Tzar
Guest
Posts: n/a
 
      12-07-2004
I checked that. It looks fine.
I think problem is when I enter a comment like // TODO it does not
create a task icon on the left edge of the editor (after saving). If I
manually click on the left edge and select Add Task then it does but
for some reason it's not doing it for the // TODO comment.
I tried it on couple of other machines and they work fine. It
automatically creates a TODO task and it shows it in the Tasks View.

One thing I have different on my machine is I have Lomboz plug-in
installed. I am not sure if that could interfere.

Tzar,

Paul van Rossem wrote:
> On 07-12-2004 22:03, (E-Mail Removed) wrote:
> > Hi all,
> >
> > It seems that I cannot see any of the TODO tasks in my Tasks

window. I
> > probably disabled it somehow some time ago and now when I make //

TODO
> > comment it does not show in the Tasks list. I made sure that in
> > Preferences->Java->Task Tags menu everything is setup correctly.

TODO
> > is a default tag.
> > Please help if you know how to make my TODO tasks show in the Tasks
> > window again.
> >
> > Thanks,
> > Tzar
> >

> Did you check the filter setting and the selected working set in the
> task view? Got me once...
>
> Paul.


 
Reply With Quote
 
deansjones@gmail.com
Guest
Posts: n/a
 
      12-08-2004
I'm not sure if this is the reason, but I noticed the feature stopped
working sometime after this was announced:

http://news.com.com/Microsoft+checks...3-5228693.html
http://www.theinquirer.net/?article=16489
http://www.flipcode.com/cgi-bin/fcms...ead_show=22715
Dean S. Jones

 
Reply With Quote
 
John C. Bollinger
Guest
Posts: n/a
 
      12-08-2004
Tzar wrote:

> I think problem is when I enter a comment like // TODO it does not
> create a task icon on the left edge of the editor (after saving). If I
> manually click on the left edge and select Add Task then it does but
> for some reason it's not doing it for the // TODO comment.
> I tried it on couple of other machines and they work fine. It
> automatically creates a TODO task and it shows it in the Tasks View.


It seemed to me that this behavior of Eclipse 2 was omitted from Eclipse
3, or at least not enabled by default. I last looked into when Eclipse
3 was still prerelease, however, and I never fully characterized the
problem.


John Bollinger
(E-Mail Removed)
 
Reply With Quote
 
Paul van Rossem
Guest
Posts: n/a
 
      12-08-2004
On 08-12-2004 14:55, John C. Bollinger wrote:
> Tzar wrote:
>
>> I think problem is when I enter a comment like // TODO it does not
>> create a task icon on the left edge of the editor (after saving). If I
>> manually click on the left edge and select Add Task then it does but
>> for some reason it's not doing it for the // TODO comment.
>> I tried it on couple of other machines and they work fine. It
>> automatically creates a TODO task and it shows it in the Tasks View.

>
>
> It seemed to me that this behavior of Eclipse 2 was omitted from Eclipse
> 3, or at least not enabled by default. I last looked into when Eclipse
> 3 was still prerelease, however, and I never fully characterized the
> problem.
>
>
> John Bollinger
> (E-Mail Removed)


It still works for me. Eclipse 3.0 split the task tags (todo) and
compiler errors into separate panes ("Tasks" and "Problems").
And indeed todos must now be enabled in Window->Preferences
->Java->Task Tags. And, as said before, the Filter setting on the
Task view must enable them. That's all I can find about it...

Paul.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Eclipse's Problems View to Show TODO items Nathan Given Java 3 07-16-2010 01:39 AM
Re: TODO and FIXME tags Chris Rebert Python 4 11-19-2009 09:44 AM
TODO and FIXME tags Yasser Almeida HernŠndez Python 0 11-16-2009 08:27 PM
add a task to todo steven masala Ruby 2 12-05-2005 08:12 PM
Eclipse: List of TODO tags in Task view veljovic@gmail.com Java 0 12-07-2004 09:04 PM



Advertisments